Bug 149565 - OOWriter crash on initial save
OOWriter crash on initial save
Status: CLOSED DUPLICATE of bug 144607
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
3
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Dan Williams
:
: 149559 149560 149563 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-23 18:32 EST by Per Bjornsson
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 21:42:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Backtrace from OOo crash (12.65 KB, text/plain)
2005-02-23 18:33 EST, Per Bjornsson
no flags Details

  None (edit)
Description Per Bjornsson 2005-02-23 18:32:42 EST
Description of problem:
OpenOffice Writer crashes when I initially attempt to save a document.
This doesn't happen really every time, and I can't really nail down
what triggers it; at first I thought I could reproduce it with a
one-line document containing non-US characters (specifically I used
the Swedish characters å, ä and ö since I was writing in Swedish) but
when I just tried again that didn't trigger the crash. Also, I have
seen it on documents written entirely in English, which were thus less
likely to contain "exotic" characters.

Version-Release number of selected component (if applicable):
openoffice.org-1.1.3-6.5.0.fc3

How reproducible:
Frequent but not always. Can't nail down exact trigger.

Steps to Reproduce:
1.Start OOWriter (haven't tested other components though)
2.Type
3.Attempt to save. Watch OpenOffice crash as you hit the "Save" button
in the save dialog.
  
Actual results:
OpenOffice crashed. I installed the debuginfo package and got a
backtrace from bug-buddy; I'll attach that.


Expected results:
Ideally, my document would have been saved to disk instead of /dev/null.

Additional info:
I'm running FC3; basically the only exotic thing about my setup is
that I rebuilt GTK, glib and Pango from Rawhide RPMs in order to get
GTK 2.6.
Comment 1 Per Bjornsson 2005-02-23 18:33:38 EST
Created attachment 111361 [details]
Backtrace from OOo crash
Comment 2 Per Bjornsson 2005-02-23 18:39:42 EST
*** Bug 149559 has been marked as a duplicate of this bug. ***
Comment 3 Per Bjornsson 2005-02-23 18:40:11 EST
*** Bug 149560 has been marked as a duplicate of this bug. ***
Comment 4 Per Bjornsson 2005-02-23 18:40:37 EST
*** Bug 149563 has been marked as a duplicate of this bug. ***
Comment 5 Per Bjornsson 2005-02-23 18:41:14 EST
*** Bug 149563 has been marked as a duplicate of this bug. ***
Comment 6 Per Bjornsson 2005-02-23 18:42:50 EST
Sorry about all the empty dupes and the bugzilla spam I just generated, I was
using the "beta" bugzilla interface and when I submitted the report I got a "500
Internal server error". I didn't realize that anything actually went into
Bugzilla until too late...
Comment 7 Andy Shevchenko 2005-02-25 04:00:40 EST
I have installed FC3 + updates, but this behaviour reproduced only 
under KDE, and works ok in Gnome environment.
Comment 8 Andy Shevchenko 2005-02-25 04:02:33 EST
Per, may be this bug blocks the #144607?
Comment 9 Per Bjornsson 2005-03-01 21:42:52 EST
Re Comment #8: I think what you mean is that it's a duplicate? Sure seems like
it, I just reproduced when starting oowriter from the commandline and it hit the
assertion in gnome-vfs:

libgnomevfs-ERROR **: file gnome-vfs-cancellation.c: line 133
(gnome_vfs_cancellation_cancel): assertion failed: (gnome_vfs_is_primary_thread())
aborting...

Closing as a duplicate.


*** This bug has been marked as a duplicate of 144607 ***

Note You need to log in before you can comment on or make changes to this bug.