Bug 149871 - (IT_69401) kickstart fails to assign IP address with AS4
kickstart fails to assign IP address with AS4
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: anaconda (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
Mike McLean
:
: 157640 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-02-28 10:17 EST by Simon Hargrave
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2005-220
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-09 07:29:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simon Hargrave 2005-02-28 10:17:32 EST
Description of problem:

Booting HP DL360 server off AS4 CD for Kickstart installation fails.  
Worked fine with AS3.
When booting and specifying kickstart file with "linux 
ks=nfs:server:/dir/file", DHCP query fails (expected as there is no 
server), after inputting TCP/IP params the following errors occur: -

tg3: eth0: Link is up at 100 Mbps, full duplex.
tg3: eth0: Flow control is off for TX and off for RX.
loader: failed to set default route: Network is unreachable

the server is not pingable.  If doing exactly the same but not 
specifying a kickstart file (ie choosing NFS install later manually), 
the same network parameters work fine, and the server is pingable as 
expected.

It appears there is some difference in the way the network is started 
when using Kickstart to when not using Kickstart?


Version-Release number of selected component (if applicable):

AS4 base release.


How reproducible:

Every time on DL360 server.


Steps to Reproduce:

1. Boot from AS4 CD, specify boot param "linux ks=nfs:server:/path".  
Actual path doesn't matter as it doesn't get as far as starting the 
network properly.
  
Actual results:

Network params don't initialise properly.

Expected results:

Network params should initialise properly, and Kickstart file should 
be downloaded and used.  This worked fine in AS3.
Comment 1 Simon Hargrave 2005-02-28 11:04:32 EST
I have done some further investigation (using my PC, a compaq deskpro 
to eliminate the server as being the sole problem).

It would appear that the issue is setting static IP parameters after 
a failed DHCP attempt.  I have reproduced this as follows: -

On my PC, boot the AS4 CD with the network cable DETACHED.  Boot 
parameters as:

linux ks=nfs:server:/path

DHCP fails, I give the TCP/IP parameters manually, and the error once 
again is: 

tg3: eth0: Link is up at 100 Mbps, full duplex.
tg3: eth0: Flow control is off for TX and off for RX.
loader: failed to set default route: Network is unreachable


If I reboot off the CD and specify the TCP/IP parameters manually on 
the boot line, ie:

linux ks=nfs:server:/path ip=xxx.xxx.xxx.xxx netmask=xxx.xxx.xxx.xxx 
gateway=xxx.xxx.xxx.xxx dns=xxx.xxx.xxx.xxx

The install doesn't attempt to perform a DHCP request, and the 
network is initialised correctly.

This has now been reproduced on both a dual-nic server and a single-
nic PC, on different LANs (and with ethernet cables disconnected) so 
the problem is definately somewhere in the installer.

One other note, when booting on a LAN with a DHCP server, the DHCP 
address is accepted and installation works as expected.
Comment 2 Chris Lumens 2005-03-02 10:10:24 EST
Could you check the comments in bug 149682 and see if using the driver from
Broadcom (bcm5700-7.3.5.tar.gz) fixes these issues?
Comment 3 Simon Hargrave 2005-03-07 08:59:56 EST
The driver disk DD that comes in that doesn't support the AS4 kernel.  I will 
try and create a driver disk and feed this to the install, however I don't 
believe the tg3 driver to be the problem.  I can reproduce the problem on a PC 
with an Intel NIC, which doesn't use the tg3 driver.
Comment 4 Jeremy Katz 2005-03-14 11:59:50 EST
Does it work if you pass the IP information on the boot command line
(the syntax is in /usr/share/doc/anaconda*/command-line.txt or it
should also be in the kernel parameters appendix of the install guide)
Comment 5 Simon Hargrave 2005-03-23 06:33:03 EST
Yes it does work passing the IP on the boot command line, as per Comment #1 of 
this bug report.
Comment 6 Chris Lumens 2005-03-28 15:37:40 EST
*** Bug 150844 has been marked as a duplicate of this bug. ***
Comment 7 Jeremy Katz 2005-04-11 13:16:30 EDT
Fixed in CVS
Comment 9 Jeremy Katz 2005-05-16 16:17:03 EDT
*** Bug 157640 has been marked as a duplicate of this bug. ***
Comment 11 Tim Powers 2005-06-09 07:29:36 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-220.html

Note You need to log in before you can comment on or make changes to this bug.