Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.

Bug 1501473

Summary: Invalid ssh configuration is generated on compute nodes when hieradata is invalid
Product: Red Hat OpenStack Reporter: Ollie Walsh <owalsh>
Component: puppet-tripleoAssignee: Ollie Walsh <owalsh>
Status: CLOSED ERRATA QA Contact: Gurenko Alex <agurenko>
Severity: medium Docs Contact:
Priority: medium    
Version: 11.0 (Ocata)CC: agurenko, jhakimra, jjoyce, jschluet, lyarwood, mbooth, mburns, owalsh, rhel-osp-director-maint, slinaber, tvignaud
Target Milestone: ---Keywords: Triaged, ZStream
Target Release: 11.0 (Ocata)   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard:
Fixed In Version: puppet-tripleo-6.5.4-1.el7ost Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of: 1466879 Environment:
Last Closed: 2018-02-13 16:31:58 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:
Bug Depends On: 1466879    
Bug Blocks: 1464504, 1501470, 1501471, 1501472, 1539769, 1539770    

Description Ollie Walsh 2017-10-12 15:37:12 UTC
+++ This bug was initially created as a clone of Bug #1466879 +++

Description of problem:
If either NovaLibvirtNetwork or NovaColdMigrationNetwork is missing from ServiceNetMap, IPs are missing from the hieradata, which results in an invalid sshd_config on compute nodes.

Version-Release number of selected component (if applicable):
openstack-tripleo-heat-templates-2.0.0-55.el7ost

How reproducible:
I could not reproduce but this.

Actual results:
SSH to compute nodes fails until the missing value are add and the stack is updated.

Expected results:
Validation should chatch the bad input and fail immediately instead of modified the sshd_config.

Additional info:
Forked from https://bugzilla.redhat.com/show_bug.cgi?id=1463680

Comment 5 errata-xmlrpc 2018-02-13 16:31:58 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0310