Bug 150360 - perl HTML::Tagset 3.04 is released
Summary: perl HTML::Tagset 3.04 is released
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-HTML-Tagset   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chip Turner
QA Contact:
URL: http://search.cpan.org/dist/HTML-Tagset/
Whiteboard:
Keywords:
: 133463 140914 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-04 23:08 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-29 19:29:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
New diff (2.17 KB, patch)
2005-03-29 10:38 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2005-03-04 23:08:16 UTC
Description of problem:
perl HTML::Tagset 3.04 was released at December 29th, 2004; while Fedora Core 
Development hangs around at version 3.03.

Version-Release number of selected component (if applicable):
perl-HTML-Tagset-3.03-30

Actual results:
The following works for me:

--- snipp ---
--- perl-HTML-Tagset.spec       2004-09-22 16:21:35.000000000 +0200
+++ perl-HTML-Tagset.spec.rsc   2005-03-05 00:06:19.000000000 +0100
@@ -2,13 +2,13 @@

 Summary: HTML::Tagset - data tables useful in parsing HTML.
 Name: perl-HTML-Tagset
-Version: 3.03
-Release: 30
+Version: 3.04
+Release: 1
 License: distributable
 Group: Applications/CPAN
-Source0: HTML-Tagset-%{version}.tar.gz
-Url: http://www.cpan.org
-BuildRoot: /var/tmp/perl-HTML-Tagset-buildroot/
+Source0: http://search.cpan.org/CPAN/authors/id/S/SB/SBURKE/HTML-Tagset-%{version}.tar.gz
+URL: http://search.cpan.org/dist/HTML-Tagset/
+BuildRoot: %{_tmppath}/%{name}-buildroot/
 BuildRequires: perl >= 0:5.00503
 Requires: perl >= 0:5.00503
 BuildArch: noarch
@@ -53,6 +53,9 @@
 %defattr(-,root,root)

 %changelog
+* Sat Mar 05 2005 Robert Scheck <redhat@linuxnetz.de> 3.04-1
+- upgrade to 3.04
+
 * Wed Sep 22 2004 Chip Turner <cturner@redhat.com> 3.03-30
 - rebuild

--- snapp ---

Expected results:
Upgrade to 3.04 ;-)

Comment 1 Warren Togami 2005-03-29 08:55:27 UTC
*** Bug 133463 has been marked as a duplicate of this bug. ***

Comment 2 Warren Togami 2005-03-29 08:57:01 UTC
Hi Robert.  Could you please merge in the changes mentioned in Bug 140914 and
supply a new spec patch?

Comment 3 Warren Togami 2005-03-29 08:57:58 UTC
*** Bug 140914 has been marked as a duplicate of this bug. ***

Comment 4 Robert Scheck 2005-03-29 10:38:34 UTC
Created attachment 112411 [details]
New diff

I didn't merge some things from Marius's patch, which (I would say) aren't 
really needed, because Fedora has lots of individual spec files:
- macrofying of "HTML-Tagset" to %pkg_name
- "make test" never should be conditional, if failing something _always_
  went wrong and has to be debugged
- replaced the filelist stuff by two simple macros in the %files section
- Fedora doesn't currently use POD files at most perl-* packages, skipped it

Comment 5 Warren Togami 2005-03-29 19:29:58 UTC
Thanks, will be in tomorrow's rawhide.


Note You need to log in before you can comment on or make changes to this bug.