Bug 1506647 - Add support for running octavia overcloud configuration from heat templates
Summary: Add support for running octavia overcloud configuration from heat templates
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M3
: 13.0 (Queens)
Assignee: Brent Eagles
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
: 1441759 (view as bug list)
Depends On: 1506641 1506643
Blocks: 1488801 1552443
TreeView+ depends on / blocked
 
Reported: 2017-10-26 13:43 UTC by Brent Eagles
Modified: 2019-09-10 14:09 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180122224017.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1506643
Environment:
Last Closed: 2018-06-27 13:38:59 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 508195 None master: MERGED tripleo-heat-templates: Run Octavia configuration on the overcloud (I2d10dbd33b3a0ed0463096849d01aa2c1b9f293e) 2018-02-28 13:41:26 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:39:58 UTC

Description Brent Eagles 2017-10-26 13:43:24 UTC
+++ This bug was initially created as a clone of Bug #1506643 +++

+++ This bug was initially created as a clone of Bug #1506641 +++

Complete configuration of Octavia requires the creation of resources in the overcloud. This requires host configuration steps and openstack cloud operations on the overcloud glance, neutron and nova services. Running ansible from a mistral workflow seems to be a workable solution as it has the required integration with heat and allows host level commands to be run in a deterministic intuitive manner.

--- Additional comment from Brent Eagles on 2017-10-26 09:37:54 EDT ---

Current u/s patch submitted to master (queens)
https://review.openstack.org/#/c/508195/

Comment 11 Brent Eagles 2018-01-23 20:02:56 UTC
*** Bug 1441759 has been marked as a duplicate of this bug. ***

Comment 13 Stuart Corcoran 2018-04-03 16:58:36 UTC
Added blocker flag for OSP13 blocker RFE tracking

Comment 15 errata-xmlrpc 2018-06-27 13:38:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.