Bug 151630 - [punjabi] font has some incorrect combinations
[punjabi] font has some incorrect combinations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: ttfonts-indic (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Leon Ho
:
Depends On: 167692
Blocks: Indic 156322
  Show dependency treegraph
 
Reported: 2005-03-21 01:29 EST by A S Alam
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-636
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-05 11:33:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Lohist fonts problem (c, d,e) (41.52 KB, image/png)
2005-03-21 01:35 EST, A S Alam
no flags Details
Output fontforge (1.61 KB, text/plain)
2005-03-21 01:37 EST, A S Alam
no flags Details
font problem in OpenOffice (8.45 KB, image/png)
2005-05-16 01:12 EDT, A S Alam
no flags Details
Gurmukhi Test Case (2.49 KB, text/plain)
2005-09-07 05:21 EDT, Sukhjinder Sidhu
no flags Details
Test Case Solutions (81.27 KB, image/png)
2005-09-26 10:27 EDT, Sukhjinder Sidhu
no flags Details

  None (edit)
Description A S Alam 2005-03-21 01:29:51 EST
Description of problem:
a) it does not implement 'pstf' to create a
post-base form of Ya when entering Virama + Ya.  See TUS 4.0, ch9, p235.

b)two simple additions of Adak Bindi and Visarg at U+0A01 and
U+0A03 would enable Unicode 4.0 support for the font.

c)  u0A07 + u0A70, where there is no such combination is there in Punjabi.

d) Chaining Substitution by coverage
	  -Rule 0
	     Back coverage -1: u0A07
	     Coverage 0: u0A70
	    -Apply at 0 'L005'
	       u0A70 => glyph147
e)  These variable put worng constrains on Punjabi combination.
-'vatu' Vattu Variants
	   u0A15_u0A30_u0A4D.blwf.vatu <= u0A15 u0A30_u0A4D.blwf
	   u0A21_u0A30_u0A4D.blwf.vatu <= u0A21 u0A30_u0A4D.blwf
	   u0A24_u0A30_u0A4D.blwf.vatu <= u0A24 u0A30_u0A4D.blwf
	   u0A26_u0A30_u0A4D.blwf.vatu <= u0A26 u0A30_u0A4D.blwf
	   u0A2D_u0A30_u0A4D.blwf.vatu <= u0A2D u0A30_u0A4D.blwf
f)  One other rule in same area make incorrect combination.
 Rule 0
	     Back coverage -1: u0A3F
	     Coverage 0: u0A70
	    -Apply at 0 'L005'
	       u0A70 => glyph147

Version-Release number of selected component (if applicable):
ttfonts-pa-1.8-1

How reproducible:
Everytime

Steps to Reproduce:
1. Enter Cons + Virama + Ya
2.
3.
  
Actual results:
a) full form of Ya with a Halant (Virama).
c) incorrect combination

Expected results:
a)Post-base form of Ya
c)Character should render as such

Additional info:
Comment 1 A S Alam 2005-03-21 01:35:51 EST
Created attachment 112164 [details]
Lohist fonts problem (c, d,e)
Comment 2 A S Alam 2005-03-21 01:37:40 EST
Created attachment 112165 [details]
Output fontforge

Output for Fontforge, showing incorrect combination in fonts
Comment 4 A S Alam 2005-04-20 04:11:45 EDT
Is there any plan to update fonts???
Comment 6 Sukhjinder Sidhu 2005-05-11 17:22:14 EDT
Does anyone know who is in charge of the Lohit Punjabi font?  It is unusable in
its current state for Punjabi and should either be fixed or removed completely.

As far as I know, Red Hat contracted someone to make these Unicode fonts - I
suggest they either get their money back or get the original contractors to fix it.
Comment 8 A S Alam 2005-05-16 01:09:05 EDT
there is need to add following characters from Hindi Unicode

0964  DEVANAGARI DANDA
 = purna viram
• phrase separator
0965  DEVANAGARI DOUBLE DANDA
= deergh viram

these characters are used in Punjabi to show end of Line as Full stop (.) in English
 
without this OpenOffice is not showing (Danda), but BLOCK instead.

Comment 9 A S Alam 2005-05-16 01:12:07 EDT
Created attachment 114408 [details]
font problem in OpenOffice

font problem with OpenOffic
Comment 10 Leon Ho 2005-06-03 00:06:33 EDT
Devel ACK for U2.
Comment 14 Lawrence Lim 2005-09-05 20:35:42 EDT
There are seven issues reported in this bug. I will use this bug as a tracker
and create seven individual bug report. Hope this will make our tracking effort
easier.

a) it does not implement 'pstf' to create a post-base form of Ya when entering
Virama + Ya. - FAIL

b)two simple additions of Adak Bindi and Visarg at U+0A01 and U+0A03 would
enable Unicode 4.0 support for the font. - FAIL

c)  u0A07 + u0A70, where there is no such combination is there in Punjabi. - PASS

d) Chaining Substitution by coverage - FAIL
	  -Rule 0
	     Back coverage -1: u0A07
	     Coverage 0: u0A70
	    -Apply at 0 'L005'
	       u0A70 => glyph147

e)  These variable put worng constrains on Punjabi combination. - PASS
-'vatu' Vattu Variants
	   u0A15_u0A30_u0A4D.blwf.vatu <= u0A15 u0A30_u0A4D.blwf
	   u0A21_u0A30_u0A4D.blwf.vatu <= u0A21 u0A30_u0A4D.blwf
	   u0A24_u0A30_u0A4D.blwf.vatu <= u0A24 u0A30_u0A4D.blwf
	   u0A26_u0A30_u0A4D.blwf.vatu <= u0A26 u0A30_u0A4D.blwf
	   u0A2D_u0A30_u0A4D.blwf.vatu <= u0A2D u0A30_u0A4D.blwf

f)  One other rule in same area make incorrect combination. - FAIL
 Rule 0
	     Back coverage -1: u0A3F
	     Coverage 0: u0A70
	    -Apply at 0 'L005'
	       u0A70 => glyph147

g) adding the following from Hindi Undicode - FAIL

0964  DEVANAGARI DANDA
 = purna viram
• phrase separator
0965  DEVANAGARI DOUBLE DANDA
= deergh viram

these characters are used in Punjabi to show end of Line as Full stop (.) in
English without this OpenOffice is not showing (Danda), but BLOCK instead.
Comment 15 Lawrence Lim 2005-09-06 02:47:03 EDT
The new bugs are as follows:

a. Bug 167590 (relates to glyph 149)
b. Bug 167591, 
c. Bug 167592, 
d.+ f. Bug 167594, (relates to glyph 147)
e. Bug 167595, 
g. Bug 167599
Comment 16 Lawrence Lim 2005-09-06 02:48:24 EDT
Removing all deps as bugs created today will be closed automatically soon after
this bug is closed by ERRATA.
Comment 17 Lawrence Lim 2005-09-06 03:00:27 EDT
Priority for bugs in comment #15 is as follows: c, e, g, d, f, a, b 
Comment 18 Sukhjinder Sidhu 2005-09-06 05:38:19 EDT
Found another bug: U+0A5E (ਫ਼) and the corresponding 'nukt' feature is missing. 
This should take priority over all the above bugs.
Comment 19 Leon Ho 2005-09-06 21:11:14 EDT
@Comment #18: Sukhjinder, is it possible to submit another bug for this issue?
We can then pass the problem up.
Comment 21 Sukhjinder Sidhu 2005-09-07 05:16:32 EDT
Added Bug 151630.
Comment 22 Sukhjinder Sidhu 2005-09-07 05:21:01 EDT
Created attachment 118544 [details]
Gurmukhi Test Case

This should be useful for you.	More useful for rendering engines I suppose,
but you still may find it helpful.
Comment 23 Sukhjinder Sidhu 2005-09-20 18:22:32 EDT
Ignore comment 21, the correct bug is bug 167692 
Comment 24 Lawrence Lim 2005-09-26 00:55:50 EDT
Comment #22,
Thank you for your Test Case. These are very valuable during testing. Could you
please take a screenshot of your test case? It will be good for matching test
result.
Comment 25 Sukhjinder Sidhu 2005-09-26 10:27:48 EDT
Created attachment 119263 [details]
Test Case Solutions
Comment 26 Sukhjinder Sidhu 2005-09-26 10:30:11 EDT
Shows how a rendering engine in combination with a font *should* show Gurmukhi
text.  The last one is missed out because the ICU CVS build I've used is only
allowing the OO + U combination (and not U + OO) for double vowel signs. 
Because the UTC hasn't decided anything yet in regards to preferred orders, it
might be dangerous implementing a behaviour that allows one method over the other.
Comment 27 Red Hat Bugzilla 2005-10-05 11:33:16 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-636.html
Comment 28 Sukhjinder Sidhu 2005-10-23 19:21:10 EDT
The fix has dramatically improved the situation in my limited testing.  However,
it still does not implement 'pstf' to create a post-base form of Ya when entering
Virama + Ya. But, for some reason, it works fine on Linux and not at all on Windows.
Comment 29 Sukhjinder Sidhu 2005-10-23 20:51:03 EDT
I've also now noticed that the font doesn't include Danda or Double Danda which
is also required for a Gurmukhi font ;)

Shall I open new bugs for these problems?

PS. Your font designer may use AnmolUni or Saab for references at
http://guca.sourceforge.net/typography/fonts/ - they are both GPL fonts.

Note You need to log in before you can comment on or make changes to this bug.