This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 152027 - error creating "C/C++" project
error creating "C/C++" project
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: eclipse-bugs
:
: 152206 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-24 10:22 EST by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-31 12:40:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backtrace (5.26 KB, text/plain)
2005-03-24 10:24 EST, Joe Orton
no flags Details

  None (edit)
Description Joe Orton 2005-03-24 10:22:21 EST
From the File->New Project menu:

-> select "Standard Make C Project", hit Next
-> enter "foo", hit "Finish" button

this pops up an error dialog:

"Error Creating Project", "Reason: Internal error"

after being returned the the new project dialog and hitting Cancel, a new dialog
pops up: "An internal error occurred during CDT Project async save"

if I go through the same process again, it seems to work.



"
Comment 1 Joe Orton 2005-03-24 10:24:05 EST
Created attachment 112291 [details]
backtrace

This backtrace was printed to the console whilst I was doing this; may be
relevant.
Comment 2 Joe Orton 2005-03-24 10:25:12 EST
Not to forget important details; this is a fresh Raw Hide install as of this
morning:

$ rpm -qf /usr/bin/eclipse
eclipse-platform-3.1.0_fc-0.M5.13.i386
Comment 3 Keith Sharp 2005-03-28 13:37:44 EST
*** Bug 152206 has been marked as a duplicate of this bug. ***
Comment 4 Ben Konrath 2005-03-29 14:25:39 EST
This looks like a libgcj bug. A fix is in classpath and will be moved over to
libgcj soon. I will report back when new gcc rpms are available.
Comment 5 Ben Konrath 2005-03-29 22:02:48 EST
I built gcc with the fix and it solved this problem. I will request a new gcc4 rpm.
Comment 6 Ben Konrath 2005-03-31 12:40:00 EST
This problem is fixed with gcc-java-4.0.0-0.38.
Comment 7 Victor Bogado 2006-04-06 11:14:26 EDT
I am having this same problem with the gcc-java-4.1.0-3 from FC5. I already
tried to erase all the eclipse data I found, so I could rule out a "trashed"
environment (I removed ~/.eclipse and the workspace dir). 

I first noticed a problem similar to the Bug 181510, but it didn't gave me no
clear backtrace. So I performed the cleanup and tried to recreate my project,
and got this result, also with no backtrace at all. 

For information I have the following packages installed, and I am running in a
i686 with hyperthreading enabled (smp): 

$ rpm -qa | grep eclipse
eclipse-rcp-3.1.2-1jpp_13fc
eclipse-pydev-0.9.3_fc-14
eclipse-ecj-3.1.2-1jpp_13fc
eclipse-platform-3.1.2-1jpp_13fc
eclipse-cdt-3.0.2-1jpp_2fc
eclipse-platform-devel-3.1.2-1jpp_13fc
eclipse-pde-3.1.2-1jpp_13fc
eclipse-jdt-3.1.2-1jpp_13fc
eclipse-rcp-devel-3.1.2-1jpp_13fc
eclipse-jdt-devel-3.1.2-1jpp_13fc
eclipse-bugzilla-0.2.2-2

$ rpm -qa | grep gcj
java-1.4.2-gcj-compat-1.4.2.0-40jpp_83rh
libgcj-devel-4.1.0-3
libgcj-src-4.1.0-3
java-1.4.2-gcj-compat-devel-1.4.2.0-40jpp_83rh
java-1.4.2-gcj-compat-src-1.4.2.0-40jpp_83rh
libgcj-4.1.0-3
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp_83rh

Note You need to log in before you can comment on or make changes to this bug.