Bug 15216 - mkisofs: undocumented pathspec syntax change??
mkisofs: undocumented pathspec syntax change??
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: cdrecord (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
Winston gold
:
: 15529 19142 37511 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 05:42 EDT by giulioo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-05 22:44:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description giulioo 2000-08-03 05:42:17 EDT
Up to beta4:
[root@i5 go]# ls -l ./bin
total 165316
-rwxr-xr-x    1 go       go             61 Jul 15 19:24 cle
-rwxr-xr-x    1 go       go             74 Jul 15 14:36 copia
-rw-rw-r--    1 root     root      1413170 Jul 16 12:33 hylafax-4.1beta2-
5rh6.src.rpm
-rw-rw-r--    1 go       go          18360 Jul 15 14:41 ls120cpio.cmp
-rw-rw-r--    1 go       go              0 Jul 15 15:18 ls120tar.cmp
-rwxr-xr-x    1 go       go             28 Jul 15 14:39 ripri
-rw-rw-r--    1 go       go       167659520 Aug  3 12:57 test_164M.img
[root@i5 go]# mkisofs -J -l -R -v -o test.iso bin/=./bin
mkisofs 1.12.1 (i686-pc-linux-gnu)
Scanning ./bin
...
...


Beta5 (does not accept the same pathspec):
[root@i5 go]# ls -l ./bin
total 165316
-rwxr-xr-x    1 go       go             61 Jul 15 19:24 cle
-rwxr-xr-x    1 go       go             74 Jul 15 14:36 copia
-rw-rw-r--    1 root     root      1413170 Jul 16 12:33 hylafax-4.1beta2-
5rh6.src.rpm
-rw-rw-r--    1 go       go          18360 Jul 15 14:41 ls120cpio.cmp
-rw-rw-r--    1 go       go              0 Jul 15 15:18 ls120tar.cmp
-rwxr-xr-x    1 go       go             28 Jul 15 14:39 ripri
-rw-rw-r--    1 go       go       167659520 Aug  3 12:57 test_164M.img
[root@i5 go]# mkisofs -J -l -R -v -o test.iso bin/=./bin
mkisofs 1.13 (i686-pc-linux-gnu)
mkisofs: No such file or directory. Invalid node - bin/=./bin
[root@i5 go]#


I tried looking at the Changelog for possible explanations, but it's not 
updated (it's still at 1.12.1, whereas pinstripe has 1.13).

[root@i5 go]# head -5 /usr/share/doc/mkisofs-1.9/ChangeLog
**************** Release 1.12.1 *******************
 
Thu Apr 27 12:44:54 2000 Joerg Schilling <joerg@schily.isdn.cs.tu-
berlin.de>
        * tree.c 1.52
        * rock.c 1.24
Comment 1 Glen Foster 2000-08-04 11:23:28 EDT
This defect is considered MUST-FIX for Winston Gold-release
... the functional regression presented is concerning enough to warrant a fix.
Comment 2 Jeff Johnson 2000-08-04 16:29:32 EDT
mkisopfs is now built as a sub-package of cdrecord
Comment 3 Alan Cox 2000-08-05 22:44:24 EDT
*** Bug 15529 has been marked as a duplicate of this bug. ***
Comment 4 Crutcher Dunnavant 2000-08-08 11:22:24 EDT
This is documented. From the man page:

       If  the  option -graft-points has been specified, it is possible to graft
the
       paths at points other than the root directory, and it is  possible  to 
graft
       files or directories onto the cdrom image with names different than what
they
       have in the source filesystem.  This is easiest to illustrate with  a 
couple
       of  examples.    Let's start by assuming that a local file ../old.lis
exists,
       and you wish to include it in the cdrom image.

            foo/bar/=../old.lis

This grafting is NOT assumed by default (at least not now).
Closing.
Comment 5 giulioo 2000-08-08 11:42:20 EDT
Thanks.

Since this a very big change in behavior, can 

/usr/share/doc/mkisofs-1.9/ChangeLog

be updated, since the authour did not do it?

Comment 6 Crutcher Dunnavant 2000-10-17 15:05:55 EDT
*** Bug 19142 has been marked as a duplicate of this bug. ***
Comment 7 giulioo 2001-04-25 07:08:44 EDT
*** Bug 37511 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.