Bug 1523776 - [RFE] Support direct baremetal 2.0 Jewel to containerised 3.0 Luminous upgrades in OSP 13
Summary: [RFE] Support direct baremetal 2.0 Jewel to containerised 3.0 Luminous upgrad...
Keywords:
Status: CLOSED DUPLICATE of bug 1488566
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: ceph-ansible
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: Upstream M3
: ---
Assignee: leseb
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks: 1485413
TreeView+ depends on / blocked
 
Reported: 2017-12-08 17:27 UTC by Lee Yarwood
Modified: 2018-01-04 16:24 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-01-04 16:23:05 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lee Yarwood 2017-12-08 17:27:05 UTC
Description of problem:

This is a late breaking Upgrades DFG requirement for fast-forward upgrades:

[RFE] Fast Forward Upgrade RHOSP10 to RHOSP13
https://bugzilla.redhat.com/show_bug.cgi?id=1485413

As discussed with members of the Ceph DFG, we would like to explore the possibility of upgrading Ceph directly from the original OSP 10 baremetal  installation of Ceph 2.0 Jewel to the OSP 13 containerised version of Ceph 3.0 Luminous using ceph-ansible in a single step.

At present the containerisation and version update are treated as two separate steps during the OSP 11 to 12 and upcoming 12 to 13 upgrade respectively.

By doing both of these in a single step we would be able to upgrade ceph _after_ upgrading the Controller and Compute roles to OSP 13, allowing for an easier rollback to OSP 10 / Newton if issues arise.

The aim of this RFE is to verify that this is even possible with ceph-ansible today.

Comment 3 leseb 2017-12-21 15:09:51 UTC
We have a playbook that we use already today in OSP to does the switch from non-containerized to containerized Ceph daemons. We currently do non-container 2.4 to container 2.5. I believe the switch from non-container 2.X to 3.0 is possible as well. This will have to be verified though.

Comment 4 Giulio Fidente 2018-01-04 16:23:05 UTC

*** This bug has been marked as a duplicate of bug 1488566 ***


Note You need to log in before you can comment on or make changes to this bug.