Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1485413 - [RFE] Fast Forward Upgrade RHOSP10 to RHOSP13
Summary: [RFE] Fast Forward Upgrade RHOSP10 to RHOSP13
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 13.0 (Queens)
Hardware: x86_64
OS: Linux
high
high
Target Milestone: zstream
: 13.0 (Queens)
Assignee: Lukas Bezdicka
QA Contact: Marius Cornea
URL:
Whiteboard:
: 1466922 (view as bug list)
Depends On: 1488566 1523776 1539052 1556992 1566294
Blocks: 1419948 1458798 1465537 1466922 1488065 1488066 1488067 1488068 1488069 1508762 1541050 1541051 1541053 1541054 1541056 1544752
TreeView+ depends on / blocked
 
Reported: 2017-08-25 15:37 UTC by Maria Bracho
Modified: 2018-09-06 21:30 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-09-03 11:33:59 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Maria Bracho 2017-08-25 15:37:58 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Red Hat Bugzilla Rules Engine 2017-10-04 15:42:59 UTC
This bugzilla has been removed from the release and needs to be reviewed for Triaging and release planning for an appropriate Target Milestone.

Comment 7 Maria Bracho 2017-11-16 13:37:58 UTC
Description of the request:
As a customer, I want to upgrade between long life releases RHOSP 10 to RHOSP 13. 

The solution shall include steps that can be controlled by the operator to plan for minimum disruption during specific time windows. Upgrading in place with the same equipment is necessary when the logistics and resources to acquire additional hardware are prohibitive. Upgrading to a supported version of OpenStack (RHOSP 13) is the main goal, given the Long Life release approach, this requires not stopping the upgrade in RHOSP 11 or 12. In case the Fast Forward Upgrade is not successful, the operator shall follow steps to return to the starting point RHOSP 10 for another attempt.
Key customers (particularly Telcos) require approaches with minimum downtime. 

Version-Release number of selected component (if applicable):
RHOSP 10, RHOSP 13

Comment 8 Maria Bracho 2017-11-16 13:38:14 UTC
Description of the request:
As a customer, I want to upgrade between long life releases RHOSP 10 to RHOSP 13. 

The solution shall include steps that can be controlled by the operator to plan for minimum disruption during specific time windows. Upgrading in place with the same equipment is necessary when the logistics and resources to acquire additional hardware are prohibitive. Upgrading to a supported version of OpenStack (RHOSP 13) is the main goal, given the Long Life release approach, this requires not stopping the upgrade in RHOSP 11 or 12. In case the Fast Forward Upgrade is not successful, the operator shall follow steps to return to the starting point RHOSP 10 for another attempt.
Key customers (particularly Telcos) require approaches with minimum downtime. 

Version-Release number of selected component (if applicable):
RHOSP 10, RHOSP 13

Comment 19 Martin Magr 2018-07-17 12:36:45 UTC
*** Bug 1466922 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.