Bug 1488566 - [RFE] Support N to N+3 upgrades for Ceph
Summary: [RFE] Support N to N+3 upgrades for Ceph
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: John Fulton
QA Contact: Marius Cornea
Derek
URL:
Whiteboard:
: 1523776 1539052 1555313 (view as bug list)
Depends On: 1556992 1558787 1568986
Blocks: 1475555 1485413
TreeView+ depends on / blocked
 
Reported: 2017-09-05 17:33 UTC by jomurphy
Modified: 2018-06-27 13:37 UTC (History)
12 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-0.20180327213846.el7ost openstack-tripleo-common-8.5.1-0.20180326153322.91f52e9.el7ost
Doc Type: Enhancement
Doc Text:
Clone Of:
: 1539052 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:36:15 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 522203 None master: MERGED tripleo-heat-templates: ffu: Add fast-forward-upgrade env (I3c690b8d08ca3a7d75481e176760a0efddebf82a) 2018-04-11 02:53:13 UTC
OpenStack gerrit 539325 None master: MERGED tripleo-common: Add support for multiple playbooks (I70786ab7b81f9985ddf1148b14ef803c327752b9) 2018-04-11 02:53:07 UTC
OpenStack gerrit 539717 None master: MERGED tripleo-heat-templates: Change type of CephAnsiblePlaybook from string to comma_delimited_list (Ie0e6e53ed08a22b1453ab12... 2018-04-11 02:52:59 UTC
OpenStack gerrit 546774 None master: MERGED tripleo-heat-templates: FFU: Add update-from-ceph-newton.yaml (Id46b07a8dae23ef3b12d656ce250e2959596eaeb) 2018-04-11 02:52:53 UTC
OpenStack gerrit 552920 None master: MERGED tripleo-common: Ensure ceph-ansible playbooks are run one at a time (Ia21f426d9c0961edd148c26fd6c22eb03c5bcf2f) 2018-04-11 02:52:46 UTC
OpenStack gerrit 553364 None stable/queens: MERGED tripleo-common: Ensure ceph-ansible playbooks are run one at a time (Ia21f426d9c0961edd148c26fd6c22eb03c5bcf2f) 2018-04-11 02:52:40 UTC
OpenStack gerrit 554123 None stable/queens: MERGED tripleo-heat-templates: FFU: Add update-from-ceph-newton.yaml (Id46b07a8dae23ef3b12d656ce250e2959596eaeb) 2018-04-11 02:52:34 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:07 UTC

Description jomurphy 2017-09-05 17:33:12 UTC

Comment 3 Giulio Fidente 2018-01-04 16:22:37 UTC
This is a late breaking Upgrades DFG requirement for fast-forward upgrades:

[RFE] Fast Forward Upgrade RHOSP10 to RHOSP13
https://bugzilla.redhat.com/show_bug.cgi?id=1485413

As discussed with members of the Ceph DFG, we would like to explore the possibility of upgrading Ceph directly from the original OSP 10 baremetal  installation of Ceph 2.0 Jewel to the OSP 13 containerised version of Ceph 3.0 Luminous using ceph-ansible in a single step.

At present the containerisation and version update are treated as two separate steps during the OSP 11 to 12 and upcoming 12 to 13 upgrade respectively.

By doing both of these in a single step we would be able to upgrade ceph _after_ upgrading the Controller and Compute roles to OSP 13, allowing for an easier rollback to OSP 10 / Newton if issues arise.

The aim of this RFE is to verify that this is even possible with ceph-ansible today.

Comment 4 Giulio Fidente 2018-01-04 16:23:05 UTC
*** Bug 1523776 has been marked as a duplicate of this bug. ***

Comment 5 Giulio Fidente 2018-01-31 15:48:21 UTC
As per conversation in BZ #1539052 , this is probably going to be implemented entirely in OSP by running sequentially the two playbooks to migrate jewel into containers first and upgrade it to luminous later.

Comment 8 Giulio Fidente 2018-02-19 12:38:48 UTC
*** Bug 1539052 has been marked as a duplicate of this bug. ***

Comment 15 jomurphy 2018-03-14 22:16:43 UTC
*** Bug 1555313 has been marked as a duplicate of this bug. ***

Comment 22 errata-xmlrpc 2018-06-27 13:36:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.