Bug 1529496 - [3.8]master-api and master-controllers are not restarted when deploy metrics along with OCP
Summary: [3.8]master-api and master-controllers are not restarted when deploy metrics ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: 3.9.z
Assignee: ewolinet
QA Contact: Junqi Zhao
URL:
Whiteboard:
Depends On:
Blocks: 1532170 1533716 1537408
TreeView+ depends on / blocked
 
Reported: 2017-12-28 11:46 UTC by Junqi Zhao
Modified: 2018-05-17 06:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
: 1532170 1533716 1537408 (view as bug list)
Environment:
Last Closed: 2018-05-17 06:42:42 UTC
Target Upstream Version:


Attachments (Terms of Use)
The "Metrics" tab are not shown in web UI (176.83 KB, image/png)
2017-12-28 11:46 UTC, Junqi Zhao
no flags Details
The "Metrics" tab are shown in web UI after restarting master-api and master-controllers manually (132.89 KB, image/png)
2017-12-28 11:52 UTC, Junqi Zhao
no flags Details
metrics tab is shown in web UI after install OCP with metrics enabled (124.50 KB, image/png)
2018-01-24 01:12 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1566 None None None 2018-05-17 06:43:24 UTC

Description Junqi Zhao 2017-12-28 11:46:52 UTC
Created attachment 1373176 [details]
The "Metrics" tab are not shown in web UI

Description of problem:
Deploy metrics 3.8  along with OCP, atomic-openshift-master-api.service and atomic-openshift-master-controllers.service are not restarted after the installation is completed,
so the "Metrics" tab are not shown in web UI, it will show after restarting atomic-openshift-master-api.service and atomic-openshift-master-controllers.service

If we deploy OCP firstly and then deploy metrics later,this issue will not happen, master-api and master-controllers are restarted
RUNNING HANDLER [openshift_metrics : restart master api]
RUNNING HANDLER [openshift_metrics : restart master controllers] 

Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-callback-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-docs-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-lookup-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-playbooks-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-filter-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-roles-3.8.22-1.git.0.b4a1220.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy metrics 3.9 along with OCP by setting parameters
  openshift_metrics_install_metrics: true
  openshift_metrics_image_prefix: registry.reg-aws.openshift.com:443/openshift3/
  openshift_metrics_image_version: v3.8

2.
3.

Actual results:
"Metrics" tab are should be shown in web UI

Expected results:
"Metrics" tab are not shown in web UI

Additional info:

Comment 1 Junqi Zhao 2017-12-28 11:49:12 UTC
Correction:
Change:
 1. Deploy metrics 3.9 along with OCP by setting parameters
To:
 1. Deploy metrics 3.8 along with OCP by setting parameters

Comment 2 Junqi Zhao 2017-12-28 11:52:23 UTC
Created attachment 1373177 [details]
The "Metrics" tab are  shown in web UI after restarting master-api and master-controllers manually

Comment 3 Junqi Zhao 2018-01-05 08:15:26 UTC
Same issue with metrics 3.9 on OCP 3.9, need to restart atomic-openshift-master-api.service manually to show "Metrics" tab in web UI

Comment 4 Junqi Zhao 2018-01-24 01:11:06 UTC
Please change to ON_QA

Tested with latest openshift-ansible-3.9.0-0.23.0 and metrics images v3.9.0-0.23.0.0, this issue does not exist now, the "Metrics" tab is shown in web UI now.

See the attached picture

Comment 5 Junqi Zhao 2018-01-24 01:12:19 UTC
Created attachment 1385132 [details]
metrics tab is shown in web UI after install OCP with metrics enabled

Comment 6 Junqi Zhao 2018-01-25 00:07:57 UTC
Set to VERIFIED as per Comment 4 and 5

Comment 8 Junqi Zhao 2018-04-20 01:42:57 UTC
Tested with latest openshift-ansible-3.9.24-1 and metrics images v3.9.25-1, this issue does not exist now, the "Metrics" tab is shown in web UI now.


# openshift version
openshift v3.9.24
kubernetes v1.9.1+a0ce1bc657
etcd 3.2.16

metrics-cassandra/images/v3.9.25-1
metrics-hawkular-metrics/images/v3.9.25-1
metrics-heapster/images/v3.9.25-1

openshift-ansible version
openshift-ansible-3.9.24-1.git.0.d0289ea.el7.noarch.rpm
openshift-ansible-docs-3.9.24-1.git.0.d0289ea.el7.noarch.rpm
openshift-ansible-playbooks-3.9.24-1.git.0.d0289ea.el7.noarch.rpm
openshift-ansible-roles-3.9.24-1.git.0.d0289ea.el7.noarch.rpm

Comment 11 errata-xmlrpc 2018-05-17 06:42:42 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1566


Note You need to log in before you can comment on or make changes to this bug.