Bug 1533716 - master-api and master-controllers are not restarted when deploy metrics along with
Summary: master-api and master-controllers are not restarted when deploy metrics along...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.8.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.8.0
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On: 1529496 1537408
Blocks: 1532170
TreeView+ depends on / blocked
 
Reported: 2018-01-12 02:49 UTC by Junqi Zhao
Modified: 2019-08-01 14:30 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1529496
Environment:
Last Closed: 2019-08-01 14:30:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Junqi Zhao 2018-01-12 02:49:57 UTC
+++ This bug was initially created as a clone of Bug #1529496 +++

Description of problem:
Deploy metrics 3.8  along with OCP, atomic-openshift-master-api.service and atomic-openshift-master-controllers.service are not restarted after the installation is completed,
so the "Metrics" tab are not shown in web UI, it will show after restarting atomic-openshift-master-api.service and atomic-openshift-master-controllers.service

If we deploy OCP firstly and then deploy metrics later,this issue will not happen, master-api and master-controllers are restarted
RUNNING HANDLER [openshift_metrics : restart master api]
RUNNING HANDLER [openshift_metrics : restart master controllers] 

Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-callback-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-docs-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-lookup-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-playbooks-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-filter-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-roles-3.8.22-1.git.0.b4a1220.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy metrics 3.9 along with OCP by setting parameters
  openshift_metrics_install_metrics: true
  openshift_metrics_image_prefix: registry.reg-aws.openshift.com:443/openshift3/
  openshift_metrics_image_version: v3.8

2.
3.

Actual results:
"Metrics" tab are should be shown in web UI

Expected results:
"Metrics" tab are not shown in web UI

Additional info:

--- Additional comment from Junqi Zhao on 2017-12-28 06:49:12 EST ---

Correction:
Change:
 1. Deploy metrics 3.9 along with OCP by setting parameters
To:
 1. Deploy metrics 3.8 along with OCP by setting parameters

--- Additional comment from Junqi Zhao on 2017-12-28 06:52 EST ---



--- Additional comment from Junqi Zhao on 2018-01-05 03:15:26 EST ---

Same issue with metrics 3.9 on OCP 3.9, need to restart atomic-openshift-master-api.service manually to show "Metrics" tab in web UI

Comment 2 Junqi Zhao 2018-01-25 00:22:56 UTC
(In reply to ewolinet from comment #1)
> Is this a duplicate of either:
> https://bugzilla.redhat.com/show_bug.cgi?id=1529496 
> or 
> https://bugzilla.redhat.com/show_bug.cgi?id=1537408 ?

I set the Target Release for defect to 3.9.0, but Jeff set it to 3.8.0, I am not not sure whether it will be fixed in 3.8.0 or not.


Note You need to log in before you can comment on or make changes to this bug.