Bug 1537408 - [3.9]master-api and master-controllers are not restarted when deploy metrics along with OCP
Summary: [3.9]master-api and master-controllers are not restarted when deploy metrics ...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
medium
low
Target Milestone: ---
: ---
Assignee: Scott Dodson
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1537399 (view as bug list)
Depends On: 1529496
Blocks: 1532170 1533716
TreeView+ depends on / blocked
 
Reported: 2018-01-23 06:33 UTC by Junqi Zhao
Modified: 2018-01-24 01:08 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1529496
Environment:
Last Closed: 2018-01-24 01:08:03 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Junqi Zhao 2018-01-23 06:33:08 UTC
+++ This bug was initially created as a clone of Bug #1529496 +++

Description of problem:
Deploy metrics 3.8  along with OCP, atomic-openshift-master-api.service and atomic-openshift-master-controllers.service are not restarted after the installation is completed,
so the "Metrics" tab are not shown in web UI, it will show after restarting atomic-openshift-master-api.service and atomic-openshift-master-controllers.service

If we deploy OCP firstly and then deploy metrics later,this issue will not happen, master-api and master-controllers are restarted
RUNNING HANDLER [openshift_metrics : restart master api]
RUNNING HANDLER [openshift_metrics : restart master controllers] 

Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-callback-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-docs-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-lookup-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-playbooks-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-filter-plugins-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-3.8.22-1.git.0.b4a1220.el7.noarch
openshift-ansible-roles-3.8.22-1.git.0.b4a1220.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy metrics 3.9 along with OCP by setting parameters
  openshift_metrics_install_metrics: true
  openshift_metrics_image_prefix: registry.reg-aws.openshift.com:443/openshift3/
  openshift_metrics_image_version: v3.8

2.
3.

Actual results:
"Metrics" tab are should be shown in web UI

Expected results:
"Metrics" tab are not shown in web UI

Additional info:

--- Additional comment from Junqi Zhao on 2017-12-28 06:49:12 EST ---

Correction:
Change:
 1. Deploy metrics 3.9 along with OCP by setting parameters
To:
 1. Deploy metrics 3.8 along with OCP by setting parameters

--- Additional comment from Junqi Zhao on 2017-12-28 06:52 EST ---



--- Additional comment from Junqi Zhao on 2018-01-05 03:15:26 EST ---

Same issue with metrics 3.9 on OCP 3.9, need to restart atomic-openshift-master-api.service manually to show "Metrics" tab in web UI

Comment 1 Junqi Zhao 2018-01-23 06:35:21 UTC
*** Bug 1537399 has been marked as a duplicate of this bug. ***

Comment 2 Samuel Padgett 2018-01-23 13:16:22 UTC
I'm unclear if the problem is in 3.9 and 3.8 from the description. It seems to reference both versions. Can you clarify?

The metrics public URL is configured differently for 3.8 and 3.9 since the web console is split out into a separate pod.

Comment 3 Samuel Padgett 2018-01-23 13:19:14 UTC
3.8 requires you restart the masters.

3.9 should not, at least not for the web console to see the changed URL.

Comment 4 Samuel Padgett 2018-01-23 13:58:17 UTC
I just did a fresh install of 3.9 with metrics enabled, and it is showing up for me on the overview. Is this an upgrade from 3.8?

The following PR merged recently that should migrate the previous metrics URL from master-config.yaml assetConfig on 3.8 -> 3.9 upgrades.

https://github.com/openshift/openshift-ansible/pull/6676

Comment 5 Junqi Zhao 2018-01-24 01:07:39 UTC
(In reply to Samuel Padgett from comment #4)
> I just did a fresh install of 3.9 with metrics enabled, and it is showing up
> for me on the overview. Is this an upgrade from 3.8?
> 
> The following PR merged recently that should migrate the previous metrics
> URL from master-config.yaml assetConfig on 3.8 -> 3.9 upgrades.
> 
> https://github.com/openshift/openshift-ansible/pull/6676

Tested with latest openshift-ansible-3.9.0-0.23.0 and metrics images v3.9.0-0.23.0.0, this issue does not exist now.

Will close this defect, thanks


Note You need to log in before you can comment on or make changes to this bug.