Bug 1536795 - resharding doesn't seem to preserve bucket acls
Summary: resharding doesn't seem to preserve bucket acls
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: RGW
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 3.1
Assignee: Orit Wasserman
QA Contact: vidushi
URL:
Whiteboard:
Keywords: TestOnly
Depends On:
Blocks: 1557269 1584264
TreeView+ depends on / blocked
 
Reported: 2018-01-21 10:32 UTC by Orit Wasserman
Modified: 2018-09-26 18:18 UTC (History)
13 users (show)

(edit)
.Resharding a bucket that has ACLs set no longer alters the bucket ACL

Previously, in the Ceph Object Gateway (RGW), resharding a bucket with an access control list (ACL) set alters the bucket ACL. With this update to {product}, ACLs on a bucket are preserved even if they are resharded.
Clone Of:
(edit)
Last Closed: 2018-09-26 18:16:43 UTC


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2819 None None None 2018-09-26 18:18 UTC
Ceph Project Bug Tracker 22742 None None None 2018-01-21 10:32 UTC

Description Orit Wasserman 2018-01-21 10:32:22 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. s3 -us  create publicbucket cannedAcl=public-read-write
2. s3 -us list publicbucket
3. s3 -us getacl publicbucket filename=publicbucket.acl
4. radosgw-admin bucket reshard --bucket=publicbucket --num-shards=10
5. s3 -us getacl publicbucket filename=publicbucket2.acl

Actual results:
bucket acl are not the same

Expected results:
bucket acl unchanged

Additional info:

Comment 4 Orit Wasserman 2018-04-25 06:59:16 UTC
upstream luminous fix:
https://github.com/ceph/ceph/pull/20327

Comment 11 errata-xmlrpc 2018-09-26 18:16:43 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2819


Note You need to log in before you can comment on or make changes to this bug.