Bug 1539052 - [RFE] Migrate Jewel cluster from baremetal to Luminous in containes
Summary: [RFE] Migrate Jewel cluster from baremetal to Luminous in containes
Keywords:
Status: CLOSED DUPLICATE of bug 1488566
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 3.*
Assignee: leseb
QA Contact: ceph-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks: 1475555 1485413
TreeView+ depends on / blocked
 
Reported: 2018-01-26 14:14 UTC by Giulio Fidente
Modified: 2018-06-26 23:46 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of: 1488566
Environment:
Last Closed: 2018-02-19 12:38:48 UTC
Target Upstream Version:


Attachments (Terms of Use)

Comment 3 Giulio Fidente 2018-01-26 14:19:01 UTC
Would it be feasible to have a playbook which migrates a baremetal cluster to containers and, in the process, upgrades Ceph from Jewel to Luminous?

Comment 4 Alfredo Deza 2018-01-26 15:10:56 UTC
This sounds terrifying to implement. I can't fathom how, if implemented, we would attempt to test such a thing. The burden of support and maintenance would be tremendous.

Most of the "infrastructure playbooks" are a source of concern, and adding something like what is being proposed here would not improve that situation.

This sounds more like an administrator task rather than a ceph-ansible responsibility

Comment 5 Giulio Fidente 2018-01-26 15:33:00 UTC
(In reply to Alfredo Deza from comment #4)
> This sounds terrifying to implement. I can't fathom how, if implemented, we
> would attempt to test such a thing. The burden of support and maintenance
> would be tremendous.
> 
> Most of the "infrastructure playbooks" are a source of concern, and adding
> something like what is being proposed here would not improve that situation.
> 
> This sounds more like an administrator task rather than a ceph-ansible
> responsibility

Undestood. Note that in OSP we consume already two infrastructure playbooks: switch-from-non-containerized and rolling_update.

We could just run the two, sequentially, to get cluster into the wanted state but that implies downloading a 2.x container image to do the initial migration to containers and then a 3.x container image to do the upgrade.

Do you think that'd still be a better (safer maybe?) approach?

Comment 6 Alfredo Deza 2018-01-26 15:39:26 UTC
I cant' tell how will that play out in a production environment. I'm still concerned on the wild permutations of environments and attempting to mangle them all with a single playbook.

In short: I don't know how safe (if at all) is that approach.

Comment 7 leseb 2018-01-30 13:12:47 UTC
For now, this is pretty well handled by switch-from-non-containerized, we also have CI coverage for this. The mix of switch-from-non-containerized and rolling_update will be required.

Comment 10 Giulio Fidente 2018-02-19 12:38:48 UTC

*** This bug has been marked as a duplicate of bug 1488566 ***


Note You need to log in before you can comment on or make changes to this bug.