Bug 1546311 - Kibana page displays "OPENSHIFT ORIGIN" in OCP
Summary: Kibana page displays "OPENSHIFT ORIGIN" in OCP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.7.1
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.9.0
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks: 1547263 1547347 1573956
TreeView+ depends on / blocked
 
Reported: 2018-02-16 20:10 UTC by Nick Schuetz
Modified: 2018-06-20 15:06 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: The container image was not built with the required header image Consequence: Fix: Replace the origin header image with the OCP header image. Result: The Kibana page displays the desired header
Clone Of:
: 1547263 1547347 (view as bug list)
Environment:
Last Closed: 2018-03-28 14:29:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github openshift origin-aggregated-logging pull 964 None None None 2018-02-20 21:46:55 UTC
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 14:29:53 UTC

Description Nick Schuetz 2018-02-16 20:10:21 UTC
Description of problem:
Kibana page displays "OPENSHIFT ORIGIN" in the upper left hand corner on OpenShift Container Platform.

Version-Release number of selected component (if applicable):

openshift v3.7.23

How reproducible:

Always

Steps to Reproduce:
1. Open the web console and dig into a pod. Then click on Logs > View Archive.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 openshift-github-bot 2018-02-21 20:24:46 UTC
Commits pushed to master at https://github.com/openshift/origin-aggregated-logging

https://github.com/openshift/origin-aggregated-logging/commit/4ee6bb370999b33d847f1324b7f418f93f1dc08a
bug 1546311. fix ocp image in downstream

https://github.com/openshift/origin-aggregated-logging/commit/c2f42c65c738c930339e669abc4a94ae3eec5921
Merge pull request #964 from jcantrill/1546311_fix_ocp_log

Automatic merge from submit-queue.

bug 1546311. fix ocp image in downstream

This PR updates Dockerfile to latest and adds ocp image

ref: https://bugzilla.redhat.com/show_bug.cgi?id=1546311

Comment 3 Anping Li 2018-02-27 04:36:14 UTC
OPENSHIFT CONTAINERPLATFORM are displayed with logging-kibana/images/v3.9.0-0.53.0.0

Comment 6 errata-xmlrpc 2018-03-28 14:29:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489

Comment 7 openshift-github-bot 2018-06-20 15:06:18 UTC
Commit pushed to master at https://github.com/openshift/origin-aggregated-logging

https://github.com/openshift/origin-aggregated-logging/commit/2d53ad27643dd85e2f85c072a53ade321a324625
bug 1546311. fix ocp image in downstream

(cherry picked from commit 4ee6bb370999b33d847f1324b7f418f93f1dc08a)


Note You need to log in before you can comment on or make changes to this bug.