Bug 1546758 - python2-oslo-db 4.33 doesn't containing tests
Summary: python2-oslo-db 4.33 doesn't containing tests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-cinder
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: Eric Harney
QA Contact: Avi Avraham
Kim Nylander
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-02-19 14:19 UTC by David Sariel
Modified: 2018-06-27 13:45 UTC (History)
6 users (show)

Fixed In Version: openstack-cinder-12.0.0-0.20180227162609.7d27804.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1546809 1546818 1546827 (view as bug list)
Environment:
Last Closed: 2018-06-27 13:44:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 545860 None None None 2018-02-19 16:51:08 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:45:38 UTC

Comment 1 Michael Bayer 2018-02-19 14:41:06 UTC
Is there an upstream Cinder issue?   because that import is wrong.   they are not supposed to import from there.

Comment 2 Michael Bayer 2018-02-19 16:04:34 UTC
Cinder's test suite needs adjustment, and the package should include the changes in https://review.openstack.org/#/c/545860/.

same issue coming in glance, neutron, ironic, glare :(

Comment 3 Eric Harney 2018-02-19 23:31:56 UTC
Fix merged into upstream Cinder master.

Comment 9 pkomarov 2018-04-25 10:30:00 UTC
setting to verified the following :

https://bugzilla.redhat.com/show_bug.cgi?id=1546818  
https://bugzilla.redhat.com/show_bug.cgi?id=1546758

Notes:

The reason is : The reproducer job test has unit tests passing :

https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/blue/organizations/jenkins/DFG-storage-cinder-13-unit-rhos/detail/DFG-storage-cinder-13-unit-rhos/36/pipeline/

That job was triggered by :
https://code.engineering.redhat.com/gerrit/#/c/134946/

Which was the fix  advised as the solution to BZ1546818 in :
https://review.openstack.org/#/c/545860/
From the  Commit : "Make use of the
newer fixtures in oslo_db.sqlalchemy.test_fixtures which is
what was intended to supersede oslo_db.sqlalchemy.test_base"

I also see recent units tests passing :
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/blue/organizations/jenkins/DFG-storage-cinder-13-u

Comment 11 errata-xmlrpc 2018-06-27 13:44:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.