Bug 1546818 - python2-oslo-db 4.33 doesn't containing tests
Summary: python2-oslo-db 4.33 doesn't containing tests
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-ironic
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: beta
: 13.0 (Queens)
Assignee: RHOS Maint
QA Contact: mlammon
URL:
Whiteboard:
Depends On: 1546827
Blocks: 1546809
TreeView+ depends on / blocked
 
Reported: 2018-02-19 16:28 UTC by Michael Bayer
Modified: 2018-06-27 13:45 UTC (History)
14 users (show)

Fixed In Version: openstack-ironic-10.1.2-0.20180302010846.7cd9deb.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1546758
Environment:
Last Closed: 2018-06-27 13:44:45 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 545874 None master: MERGED ironic: Use oslo_db.sqlalchemy.test_fixtures (Iff0c77f60c4e8b48c56d165653b1d27295d0aa2e) 2018-03-21 13:38:58 UTC
OpenStack gerrit 546274 None None None 2018-03-21 15:12:58 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:45:38 UTC

Comment 1 Michael Bayer 2018-02-19 16:29:41 UTC
https://review.openstack.org/545874

Comment 5 pkomarov 2018-04-25 10:30:19 UTC
setting to verified the following :

https://bugzilla.redhat.com/show_bug.cgi?id=1546818  
https://bugzilla.redhat.com/show_bug.cgi?id=1546758

Notes:

The reason is : The reproducer job test has unit tests passing :

https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/blue/organizations/jenkins/DFG-storage-cinder-13-unit-rhos/detail/DFG-storage-cinder-13-unit-rhos/36/pipeline/

That job was triggered by :
https://code.engineering.redhat.com/gerrit/#/c/134946/

Which was the fix  advised as the solution to BZ1546818 in :
https://review.openstack.org/#/c/545860/
From the  Commit : "Make use of the
newer fixtures in oslo_db.sqlalchemy.test_fixtures which is
what was intended to supersede oslo_db.sqlalchemy.test_base"

I also see recent units tests passing :
https://rhos-qe-jenkins.rhev-ci-vms.eng.rdu2.redhat.com/blue/organizations/jenkins/DFG-storage-cinder-13-u

Comment 7 errata-xmlrpc 2018-06-27 13:44:45 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.