Bug 154956 - evolution data server crashes adding contact to ldap server
evolution data server crashes adding contact to ldap server
Status: CLOSED DUPLICATE of bug 165269
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 158154 164078 (view as bug list)
Depends On:
Blocks: FC4Update
  Show dependency treegraph
 
Reported: 2005-04-14 22:14 EDT by Brian Millett
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-09 17:24:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Brian Millett 2005-04-14 22:14:41 EDT
Description of the crash:
can not add a new, nor edit a contact in a ldap server.  Evolution data
server crashes

Steps to reproduce the crash:
1. click to add contact to ldap server
2. read crash info
3. 

Expected Results:
not that.  Should add contact.

How often does this happen?
every time

Additional Information:



Debugging Information:

Backtrace was generated from '/usr/libexec/evolution-data-server-1.2'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1209018688 (LWP 4216)]
[New Thread -1274340432 (LWP 4252)]
[New Thread -1242592336 (LWP 4240)]
[New Thread -1211118672 (LWP 4217)]
0x00eb4402 in ?? ()
#0  0x00eb4402 in ?? ()
#1  0x003d01eb in __waitpid_nocancel () from /lib/libc.so.6
#2  0x00379231 in do_system () from /lib/libc.so.6
#3  0x003795bd in system () from /lib/libc.so.6
#4  0x0059f1f9 in system () from /lib/libpthread.so.0
#5  0x0804b621 in gnome_segv_handler (signo=11) at server.c:109
#6  <signal handler called>
#7  0x00eb4402 in ?? ()
#8  0x0040476b in poll () from /lib/libc.so.6
#9  0x0689d248 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
#10 0x0689d6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#11 0x06920625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#12 0x0804be1f in main (argc=3, argv=0xbfc28794) at server.c:354

Thread 4 (Thread -1211118672 (LWP 4217)):
#0  0x00eb4402 in ?? ()
No symbol table info available.
#1  0x0040476b in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x0689d248 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x0689d6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x067373be in link_thread_io_context () from
/usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x068b5e9a in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00599b37 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x0040e63e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 3 (Thread -1242592336 (LWP 4240)):
#0  0x00eb4402 in ?? ()
No symbol table info available.
#1  0x0040476b in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x0689d248 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x0689d6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x0023f2d4 in startup_mainloop (arg=0x0) at e-book.c:3499
	loop = 
Thread 2 (Thread -1274340432 (LWP 4252)):
#0  0x00eb4402 in ?? ()
No symbol table info available.
#1  0x0059dd6e in __lll_mutex_lock_wait () from /lib/libpthread.so.0
No symbol table info available.
#2  0x0059ab65 in _L_mutex_lock_36 () from /lib/libpthread.so.0
No symbol table info available.
#3  0x0059c4ff in pthread_kill () from /lib/libpthread.so.0
No symbol table info available.
#4  0x0804b59f in gnome_segv_handler (signo=11) at server.c:92
	in_segv = 1
#5  <signal handler called>
No symbol table info available.
#6  0x001dce68 in ?? ()
   from
/usr/lib/evolution-data-server-1.2/extensions/libebookbackendldap.so
No symbol table info available.
#7  0x001de6d2 in build_mods_from_contacts (bl=0x9475020, current=0x0, 
    new=0x94847c0, new_dn_needed=0x0) at e-book-backend-ldap.c:1092
	new_prop_present = 1
	new_prop_bers = (struct berval **) 0x9481778
	new_prop = 0x0
	current_prop_present = 0
	current_prop = 
Thread 1 (Thread -1209018688 (LWP 4216)):
#0  0x00eb4402 in ?? ()
No symbol table info available.
#1  0x003d01eb in __waitpid_nocancel () from /lib/libc.so.6
No symbol table info available.
#2  0x00379231 in do_system () from /lib/libc.so.6
No symbol table info available.
#3  0x003795bd in system () from /lib/libc.so.6
No symbol table info available.
#4  0x0059f1f9 in system () from /lib/libpthread.so.0
No symbol table info available.
#5  0x0804b621 in gnome_segv_handler (signo=11) at server.c:109
	in_segv = 1
#6  <signal handler called>
No symbol table info available.
#7  0x00eb4402 in ?? ()
No symbol table info available.
#8  0x0040476b in poll () from /lib/libc.so.6
No symbol table info available.
#9  0x0689d248 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#10 0x0689d6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#11 0x06920625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
No symbol table info available.
#12 0x0804be1f in main (argc=3, argv=0xbfc28794) at server.c:354
	offline_listener = (OfflineListener *) 0x9457498
Comment 1 Brian Millett 2005-05-05 16:38:03 EDT
Well, as of 05/05/05 it still crashes.

Backtrace was generated from '/usr/libexec/evolution-data-server-1.2'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1209129280 (LWP 9633)]
[New Thread -1221719120 (LWP 9654)]
[New Thread -1211229264 (LWP 9634)]
0x00253402 in ?? ()
#0  0x00253402 in ?? ()
#1  0x0036b5eb in __waitpid_nocancel () from /lib/libc.so.6
#2  0x003140ad in do_system () from /lib/libc.so.6
#3  0x00314439 in system () from /lib/libc.so.6
#4  0x001ef309 in system () from /lib/libpthread.so.0
#5  0x0804b621 in gnome_segv_handler (signo=11) at server.c:109
#6  <signal handler called>
#7  0x00257318 in ?? ()
   from /usr/lib/evolution-data-server-1.2/extensions/libebookbackendldap.so
#8  0x00258830 in build_mods_from_contacts (bl=0x9289078, current=0x92a6280, 
    new=0x929ca78, new_dn_needed=0xbfe0bd30) at e-book-backend-ldap.c:1081
#9  0x0025ceb5 in modify_contact_search_handler (op=0x92a7b00, res=0x92a5dd0)
    at e-book-backend-ldap.c:1653
#10 0x0025a9e0 in poll_ldap (bl=0x9289078) at e-book-backend-ldap.c:3255
#11 0x007e7f06 in g_main_context_wakeup () from /usr/lib/libglib-2.0.so.0
#12 0x007e63ee in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#13 0x007e93f6 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#14 0x007e96e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#15 0x00137625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#16 0x0804be1f in main (argc=3, argv=0xbfe0c054) at server.c:354

Thread 3 (Thread -1211229264 (LWP 9634)):
#0  0x00253402 in ?? ()
No symbol table info available.
#1  0x0039fae3 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x007e9248 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x007e96e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x001a63be in link_thread_io_context () from /usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x00801e9a in g_static_private_free () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x001e9b80 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x003a9b9e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 2 (Thread -1221719120 (LWP 9654)):
#0  0x00253402 in ?? ()
No symbol table info available.
#1  0x0039fae3 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x007e9248 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x007e96e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x002c22d4 in startup_mainloop (arg=0x0) at e-book.c:3499
	loop = 
Thread 1 (Thread -1209129280 (LWP 9633)):
#0  0x00253402 in ?? ()
No symbol table info available.
#1  0x0036b5eb in __waitpid_nocancel () from /lib/libc.so.6
No symbol table info available.
#2  0x003140ad in do_system () from /lib/libc.so.6
No symbol table info available.
#3  0x00314439 in system () from /lib/libc.so.6
No symbol table info available.
#4  0x001ef309 in system () from /lib/libpthread.so.0
No symbol table info available.
#5  0x0804b621 in gnome_segv_handler (signo=11) at server.c:109
	in_segv = 1
#6  <signal handler called>
No symbol table info available.
#7  0x00257318 in ?? ()
   from /usr/lib/evolution-data-server-1.2/extensions/libebookbackendldap.so
No symbol table info available.
#8  0x00258830 in build_mods_from_contacts (bl=0x9289078, current=0x92a6280, 
    new=0x929ca78, new_dn_needed=0xbfe0bd30) at e-book-backend-ldap.c:1081
	current_prop_bers = 
Comment 2 Brian Millett 2005-05-10 11:39:51 EDT
After the 05/10/05 FC4rc3 release.  Am I the only one getting this?

Backtrace was generated from '/usr/libexec/evolution-data-server-1.2'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1208482112 (LWP 4092)]
[New Thread -1210582096 (LWP 4093)]
0x0084f402 in ?? ()
#0  0x0084f402 in ?? ()
#1  0x002785eb in __waitpid_nocancel () from /lib/libc.so.6
#2  0x002210ad in do_system () from /lib/libc.so.6
#3  0x00221439 in system () from /lib/libc.so.6
#4  0x00a7d309 in system () from /lib/libpthread.so.0
#5  0x0804b621 in gnome_segv_handler (signo=11) at server.c:109
#6  <signal handler called>
#7  0x00e6e318 in ?? ()
   from
/usr/lib/evolution-data-server-1.2/extensions/libebookbackendldap.so
#8  0x00e6f830 in build_mods_from_contacts (bl=0x80bf088,
current=0x80dcc58, 
    new=0x80d9f40, new_dn_needed=0xbffa98a0) at
e-book-backend-ldap.c:1081
#9  0x00e73eb5 in modify_contact_search_handler (op=0x80e18e0,
res=0x80dcb98)
    at e-book-backend-ldap.c:1653
#10 0x00e719e0 in poll_ldap (bl=0x80bf088) at
e-book-backend-ldap.c:3255
#11 0x00ccbf06 in g_main_context_wakeup () from
/usr/lib/libglib-2.0.so.0
#12 0x00cca3ee in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#13 0x00ccd3f6 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
#14 0x00ccd6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#15 0x0762d625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#16 0x0804be1f in main (argc=3, argv=0xbffa9bc4) at server.c:354

Thread 2 (Thread -1210582096 (LWP 4093)):
#0  0x0084f402 in ?? ()
No symbol table info available.
#1  0x002acae3 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x00ccd248 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x00ccd6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x075f33be in link_thread_io_context () from
/usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x00ce5e9a in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00a77b80 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x002b6b9e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread -1208482112 (LWP 4092)):
#0  0x0084f402 in ?? ()
No symbol table info available.
#1  0x002785eb in __waitpid_nocancel () from /lib/libc.so.6
No symbol table info available.
#2  0x002210ad in do_system () from /lib/libc.so.6
No symbol table info available.
#3  0x00221439 in system () from /lib/libc.so.6
No symbol table info available.
#4  0x00a7d309 in system () from /lib/libpthread.so.0
No symbol table info available.
#5  0x0804b621 in gnome_segv_handler (signo=11) at server.c:109
	in_segv = 1
#6  <signal handler called>
No symbol table info available.
#7  0x00e6e318 in ?? ()
   from
/usr/lib/evolution-data-server-1.2/extensions/libebookbackendldap.so
No symbol table info available.
#8  0x00e6f830 in build_mods_from_contacts (bl=0x80bf088,
current=0x80dcc58, 
    new=0x80d9f40, new_dn_needed=0xbffa98a0) at
e-book-backend-ldap.c:1081
	current_prop_bers = 

Comment 3 Dave Malcolm 2005-05-10 15:26:54 EDT
I'm sorry about the delay in getting back to you.

I just successfully reproduced this bug myself; will investigate further.

This looks like a general problem in upstream Evolution.  You may want to file
the report in the upstream bug tracking system, since more people who know the
code will be looking at the bug report there.

The upstream bug tracking system to use is:
http://bugzilla.gnome.org/
Comment 4 Brian Millett 2005-05-10 16:56:24 EDT
Thanks!!

This is the id:

http://bugzilla.gnome.org/show_bug.cgi?id=303685
Comment 5 Dave Malcolm 2005-05-10 17:35:35 EDT
Thanks.  Please can you install the debuginfo packages for evolution-data-server
and openldap and regenerate the backtrace.

See this page for more information:
http://fedoraproject.org/wiki/StackTraces
Comment 6 Brian Millett 2005-05-10 19:33:48 EDT
Ok,
[bpm]$ rpm -qa | grep debuginfo
evolution-webcal-debuginfo-2.2.0-1
evolution-data-server-debuginfo-1.2.2-2
openldap-debuginfo-2.2.23-4
evolution-connector-debuginfo-2.2.2-3
evolution-debuginfo-2.2.2-5

From bugbuddy:
Backtrace was generated from '/usr/libexec/evolution-data-server-1.2'

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread -1209100608 (LWP 4112)]
[New Thread -1242674256 (LWP 4135)]
[New Thread -1211200592 (LWP 4113)]
0x00ca2402 in ?? ()
#0  0x00ca2402 in ?? ()
#1  0x008aa5eb in __waitpid_nocancel () from /lib/libc.so.6
#2  0x008530ad in do_system () from /lib/libc.so.6
#3  0x00853439 in system () from /lib/libc.so.6
#4  0x00a7d309 in system () from /lib/libpthread.so.0
#5  0x0804b621 in gnome_segv_handler (signo=11) at server.c:109
#6  <signal handler called>
#7  0x00df3318 in ?? ()
   from
/usr/lib/evolution-data-server-1.2/extensions/libebookbackendldap.so
#8  0x00df4830 in build_mods_from_contacts (bl=0x9887f88,
current=0x9871c30, 
    new=0x9890af8, new_dn_needed=0xbf9145c0) at
e-book-backend-ldap.c:1081
#9  0x00df8eb5 in modify_contact_search_handler (op=0x988ea80,
res=0x988ddc8)
    at e-book-backend-ldap.c:1653
#10 0x00df69e0 in poll_ldap (bl=0x9887f88) at
e-book-backend-ldap.c:3255
#11 0x00ccbf06 in g_main_context_wakeup () from
/usr/lib/libglib-2.0.so.0
#12 0x00cca3ee in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#13 0x00ccd3f6 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
#14 0x00ccd6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#15 0x0762d625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#16 0x0804be1f in main (argc=3, argv=0xbf9148e4) at server.c:354

Thread 3 (Thread -1211200592 (LWP 4113)):
#0  0x00ca2402 in ?? ()
No symbol table info available.
#1  0x008deae3 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x00ccd248 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x00ccd6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x075f33be in link_thread_io_context () from
/usr/lib/libORBit-2.so.0
No symbol table info available.
#5  0x00ce5e9a in g_static_private_free () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#6  0x00a77b80 in start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x008e8b9e in clone () from /lib/libc.so.6
No symbol table info available.

Thread 2 (Thread -1242674256 (LWP 4135)):
#0  0x00ca2402 in ?? ()
No symbol table info available.
#1  0x008deae3 in poll () from /lib/libc.so.6
No symbol table info available.
#2  0x00ccd248 in g_main_context_check () from
/usr/lib/libglib-2.0.so.0
No symbol table info available.
#3  0x00ccd6e3 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
No symbol table info available.
#4  0x041c02d4 in startup_mainloop (arg=0x0) at e-book.c:3499
	loop = 
Thread 1 (Thread -1209100608 (LWP 4112)):
#0  0x00ca2402 in ?? ()
No symbol table info available.
#1  0x008aa5eb in __waitpid_nocancel () from /lib/libc.so.6
No symbol table info available.
#2  0x008530ad in do_system () from /lib/libc.so.6
No symbol table info available.
#3  0x00853439 in system () from /lib/libc.so.6
No symbol table info available.
#4  0x00a7d309 in system () from /lib/libpthread.so.0
No symbol table info available.
#5  0x0804b621 in gnome_segv_handler (signo=11) at server.c:109
	in_segv = 1
#6  <signal handler called>
No symbol table info available.
#7  0x00df3318 in ?? ()
   from
/usr/lib/evolution-data-server-1.2/extensions/libebookbackendldap.so
No symbol table info available.
#8  0x00df4830 in build_mods_from_contacts (bl=0x9887f88,
current=0x9871c30, 
    new=0x9890af8, new_dn_needed=0xbf9145c0) at
e-book-backend-ldap.c:1081
	current_prop_bers = 
Comment 7 Bojan Smojver 2005-05-24 22:35:12 EDT
*** Bug 158154 has been marked as a duplicate of this bug. ***
Comment 8 Joris Struyve 2005-07-25 05:28:06 EDT
*** Bug 164078 has been marked as a duplicate of this bug. ***
Comment 9 Dave Malcolm 2005-08-09 17:24:06 EDT
The problem is a bad buffer size in the code that encodes email addresses for
contacts for transmission to the LDAP server.

Marking as a duplicate of bug 165269 since the fixed version mentions that bug
in the changelog.

*** This bug has been marked as a duplicate of 165269 ***

Note You need to log in before you can comment on or make changes to this bug.