Bug 165269 - Evolution-data-server crashes when trying to add a contact to a LDAP store
Evolution-data-server crashes when trying to add a contact to a LDAP store
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
4
All Linux
medium Severity high
: ---
: ---
Assigned To: Dave Malcolm
:
: 154956 (view as bug list)
Depends On:
Blocks: FC4Update 165371
  Show dependency treegraph
 
Reported: 2005-08-06 06:03 EDT by Matthew Wright
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: evolution-data-server-1.2.3-2.fc4
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-15 17:19:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 311684 None None None Never

  None (edit)
Description Matthew Wright 2005-08-06 06:03:09 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
Connect evolution to a localhost ldap server either fedora-ds or openldap (we have tested with both).

Try and add a new contact -- Evolution-data-server crashes.

This does not occur in evolution 2.3.6 which is in rawhide.

We would like this fixed as it is the 1 major remaining thing that is holding back our SOE at the organisation I am volunteering @.

This feature is important to small-medium sized businesses who don't have a HR function and need to share contacts.



Version-Release number of selected component (if applicable):
evolution-data-server-1.2.2-3

How reproducible:
Always

Steps to Reproduce:
1. Start Evolution
2. Goto contacts
3.click right button add new address book
4. enter details for your ldap server (openldap or fedora-da)
5. ONLY Choose "never" for use encyrption (another bug that needs attention)
5. enter your login distingusihed name or email address.
6. ok close
7. click in address book area goto do a search.
8 you are asked for your password, give it and save.
9. go right button add new contact
10. enter some details.
11. click save and **CRASH***


This does not occur in 2.3.6 --- 2.3.6 works.  Can you release an update to evolution that is patched for this problem.

Actual Results:  eds and openldap were stuffed -- restarted these add got back under way.

Expected Results:  A contact should have saved to the ldap server and this would then be searchable and auto resolve when your typing a new mail if you set the connection to mark as default when you're diong add new address book in contacts.

Additional info:

I think a patch for this is available upstream however i can't find it at the moment.  I would like this included in the next e-d-s /evolutetion update
Comment 1 Dave Malcolm 2005-08-08 13:06:39 EDT
Thanks you your help in tracking this down.

I believe this is a manifestation of this upstream bug:
http://bugzilla.gnome.org/show_bug.cgi?id=311684

I plan to put out an FC4 update for e-d-s for this later today.
Comment 2 Dave Malcolm 2005-08-09 17:24:26 EDT
*** Bug 154956 has been marked as a duplicate of this bug. ***
Comment 3 Dave Malcolm 2005-08-09 18:27:03 EDT
I've released a test update for FC4 that should fix this issue:
https://www.redhat.com/archives/fedora-test-list/2005-August/msg00073.html

Please can everyone test it and report on whether it fixes the problem for them.
 Thanks.
Comment 4 Matthew Wright 2005-08-10 05:51:33 EDT
It fixes the LDAP crash when you drag and drop and create new entries in the
LDAP address book.  This is fantastic, and is why I logged this bug.

Auto completion isn't working though, but this shouldn't necessarily hold back
the release of this bugfix

ie if you create a new message and you start to type the name of someone who is
in your LDAP address book, the autocomplete feature should start searching the
LDAP store. this only seems to work for Personal address book.

To enable this feature (that isn't working) you have to create your LDAP address
book, set it as default and goto edit preferences | autocompletion and check the
button next to your LDAP adddress book

I have done an additional test to try and narrow down the problem by unchecking
the button next to personal address book in the autocompletion list, and then
restarting my login (logout pkill rm -rf /tmp/*$USER* then /etc/rc.d/init.d/ldap
stop start

But this hasn't fixed the problem --> i'm running openldap as shipped with FC4
and it also seems quite slow (But I can live with that).
Comment 5 Dave Malcolm 2005-08-10 11:54:43 EDT
Thanks for the feedback; good to know that it's working.  I plan to push this as
a full update shortly.

The autocompletion for LDAP is as expected: you have to click on the checkbox to
enable it (though it shouldn't need to be the default addressbook).  Does it
work once the checkbox is checked?  If not, please file this as a separate bug.
Comment 6 Matthew Wright 2005-08-10 13:31:28 EDT
Result is the same if the Autocompletion checkbox is checked or unchecked, 
autocompletion does not work for an LDAP address book.  I have filed bug #165594
to cover this new issue.
Comment 7 Dave Malcolm 2005-08-15 17:19:59 EDT
I pushed this as a full update:
https://www.redhat.com/archives/fedora-announce-list/2005-August/msg00042.html

Closing this bug; please reopen it if problems recur.
Comment 8 Matthew Wright 2005-08-15 18:53:19 EDT
The full update fixed this issue so thank-you for giving this your attention. --
it is most appreciated by myself and colleagues and my users.

Note You need to log in before you can comment on or make changes to this bug.