Bug 1554712 - pinyin: do not return KeyRelease of Shift key
Summary: pinyin: do not return KeyRelease of Shift key
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus-libpinyin   
(Show other bugs)
Version: 28
Hardware: Unspecified Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Peng Wu
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-13 08:37 UTC by lnie
Modified: 2018-03-30 13:14 UTC (History)
6 users (show)

Fixed In Version: ibus-libpinyin-1.9.91-1.fc27 ibus-libpinyin-1.9.91-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-03-27 20:05:23 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screencast (77.84 KB, application/octet-stream)
2018-03-13 08:37 UTC, lnie
no flags Details
ibus.txt (897.68 KB, text/plain)
2018-03-13 08:39 UTC, lnie
no flags Details
journal (897.68 KB, text/plain)
2018-03-13 08:40 UTC, lnie
no flags Details
journal (405.21 KB, text/x-vhdl)
2018-03-14 09:34 UTC, lnie
no flags Details
video1 (1.37 MB, application/octet-stream)
2018-03-14 13:31 UTC, lnie
no flags Details
video2 (684.27 KB, application/octet-stream)
2018-03-14 13:35 UTC, lnie
no flags Details
video3 (736.33 KB, application/octet-stream)
2018-03-16 07:00 UTC, lnie
no flags Details

Description lnie 2018-03-13 08:37:42 UTC
Created attachment 1407471 [details]
screencast

Description of problem:
I've seen this twice but not sure how to reproduce it.As shown in the attached video,I want to type "-", but all I can get is "_" or "——",and I got "A" when I 
type the up arrow,and got "B" when I type the down arrow,I can only type in number using the right numeric keypad.Everything will be fine after a reboot   

Version-Release number of selected component (if applicable):
ibus-1.5.17-10.fc28

How reproducible:
always

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 lnie 2018-03-13 08:39 UTC
Created attachment 1407472 [details]
ibus.txt

Comment 2 lnie 2018-03-13 08:40 UTC
Created attachment 1407473 [details]
journal

Comment 3 fujiwara 2018-03-13 10:47:21 UTC
Would you check which ibus or xkb only do you enable with gsettings command?

% gsettings get org.gnome.desktop.input-sources sources
[('ibus', 'anthy'), ('xkb', 'jp')]

Comment 4 lnie 2018-03-14 09:34:18 UTC
ah,see this once more:
1 do a fresh installation on a VM
2 dnf install emoji-picker
3 add libpinyin 
4 open libreffice writer 
5 type shift to type some English,but all the thing you type will become capital one though you didn't enter CapsLock,and you are able to type the normal letter without enter capsLock on the host machine.And all the symptoms shown in the screencast from comm0.

[lnie@localhost ~]$  gsettings get org.gnome.desktop.input-sources sources
[('xkb', 'us'), ('ibus', 'libpinyin')]

Comment 5 lnie 2018-03-14 09:34 UTC
Created attachment 1407881 [details]
journal

Comment 6 fujiwara 2018-03-14 11:15:43 UTC
(In reply to lnie from comment #0)
> I've seen this twice but not sure how to reproduce it.A

Are you still able to reproduce your issue?

(In reply to lnie from comment #4)
> [lnie@localhost ~]$  gsettings get org.gnome.desktop.input-sources sources
> [('xkb', 'us'), ('ibus', 'libpinyin')]

When you delete libpinyin using `gnome-control-center region`, do you reproduce your issue?

Comment 7 lnie 2018-03-14 13:28:52 UTC
(In reply to fujiwara from comment #6)
> (In reply to lnie from comment #0)
> > I've seen this twice but not sure how to reproduce it.A
> 
> Are you still able to reproduce your issue?

 yes,comment4 is one reproducer,the issue will be gone if you delete libpinyin.
 And you will see this again after you add libpinyin and type shift when you try to search some applications.So the guilty seems to be type shift in the search box with libpinyin on,please see the attached videos for the details.
 
> 
> (In reply to lnie from comment #4)
> > [lnie@localhost ~]$  gsettings get org.gnome.desktop.input-sources sources
> > [('xkb', 'us'), ('ibus', 'libpinyin')]
> 
> When you delete libpinyin using `gnome-control-center region`, do you
> reproduce your issue?

Comment 8 lnie 2018-03-14 13:31 UTC
Created attachment 1407980 [details]
video1

Comment 9 lnie 2018-03-14 13:35 UTC
Created attachment 1407981 [details]
video2

Comment 10 fujiwara 2018-03-16 04:04:47 UTC
(In reply to lnie from comment #7)
> (In reply to fujiwara from comment #6)
> > (In reply to lnie from comment #0)
> > > I've seen this twice but not sure how to reproduce it.A
> > 
> > Are you still able to reproduce your issue?
> 
>  yes,comment4 is one reproducer,the issue will be gone if you delete
> libpinyin.
>  And you will see this again after you add libpinyin and type shift when you
> try to search some applications.So the guilty seems to be type shift in the
> search box with libpinyin on,please see the attached videos for the details.
>  

OK, I can reproduce your problem with gnome-shell's search box and ibus-libpinyin.
search box uses gnome-shell-3.28.0/js/misc/inputMethod.js:vfunc_filter_key_event() .

I noticed ibus-libpinyin.process_key_event() returns FALSE for KeyPress and TRUE for KeyRelease of Shift keys.
I think it's not good because it means to keep pressing the Shift key.
It incidentally works with gdk_put_event() in IBus GTK IM module but it does not work with clutter_event_put().

Forwarding to ibus-libpyin

Comment 11 lnie 2018-03-16 06:59:55 UTC
 It seems that this bug not only affects ibus-libpinyin,but also ibus-anthy,
 in a different way,as another reproducer(reproducible with pinyin and anthy)for me is typing something in the search box and then pressing Backspace key to delete them,the system will just hang there(attached video3) 

 In search box of f28 system,you can switch libpinyin using shift key,but you can't switch anthy using ctrl+space.And the symptoms from  the above comments happen after you successfully switch libpinyin.Maybe I'm talking different bugs,so I have opened more bugs(#bz1557169,#bz1557177),please Dup them if they are,thanks.

Comment 12 lnie 2018-03-16 07:00 UTC
Created attachment 1408660 [details]
video3

Comment 13 fujiwara 2018-03-16 07:10:54 UTC
(In reply to lnie from comment #11)
>  It seems that this bug not only affects ibus-libpinyin,but also ibus-anthy,
>  in a different way,as another reproducer(reproducible with pinyin and
> anthy)for me is typing something in the search box and then pressing
> Backspace key to delete them,the system will just hang there(attached
> video3) 
> 
>  In search box of f28 system,you can switch libpinyin using shift key,but
> you can't switch anthy using ctrl+space.And the symptoms from  the above
> comments happen after you successfully switch libpinyin.Maybe I'm talking
> different bugs,so I have opened more bugs(#bz1557169,#bz1557177),please Dup
> them if they are,thanks.

Seems you are confused the Shift issue with another issue.

Comment 15 Fedora Update System 2018-03-22 08:36:41 UTC
ibus-libpinyin-1.9.91-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-1c9b2c5908

Comment 16 Fedora Update System 2018-03-22 08:36:52 UTC
ibus-libpinyin-1.9.91-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-cc8ea556aa

Comment 17 Fedora Update System 2018-03-22 14:14:31 UTC
ibus-libpinyin-1.9.91-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-cc8ea556aa

Comment 18 Fedora Update System 2018-03-22 17:40:26 UTC
ibus-libpinyin-1.9.91-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-1c9b2c5908

Comment 19 Fedora Update System 2018-03-27 20:05:23 UTC
ibus-libpinyin-1.9.91-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2018-03-30 13:14:07 UTC
ibus-libpinyin-1.9.91-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.