Bug 1554724 - Backspace in the preedit doesn't work on the search box at the Activities Overview
Summary: Backspace in the preedit doesn't work on the search box at the Activities Ove...
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: mutter   
(Show other bugs)
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Florian Müllner
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: i18n
: 1557169 1557177 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-03-13 08:55 UTC by Akira TAGOH
Modified: 2019-04-09 14:25 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2019-04-09 14:25:33 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Akira TAGOH 2018-03-13 08:55:22 UTC
Description of problem:
IBus can be activated on the search box at the Activities Overview though, the characters in the preedit can be deleted by Backspace. the key events seems not forwarding to IBus.

Version-Release number of selected component (if applicable):
gnome-shell-3.27.92-1.fc28.x86_64
gjs-1.51.91-1.fc28.x86_64
ibus-1.5.18-1.fc28.x86_64
ibus-kkc-1.5.22-9.fc28.x86_64

How reproducible:
always

Steps to Reproduce:
1.enter into the activities overview
2.activate ibus to start input in native language
3.type something in the search box
4.press backspace key to delete

Actual results:
no delete in preedit

Expected results:
should delete characters in preedit

Additional info:

Comment 1 Akira TAGOH 2018-03-13 10:44:38 UTC
reported to upstream: https://gitlab.gnome.org/GNOME/gnome-shell/issues/108

Comment 2 Mike FABIAN 2018-03-13 15:42:27 UTC
I can confirm that. The same happens for me in the "enter command" dialog which opens when typing Alt+F2. 

Deleting characters typed already with backspace does *not* work. 
Committing the preedit with Return does not work either.

Comment 3 Akira TAGOH 2018-03-14 04:19:01 UTC
https://gitlab.gnome.org/GNOME/mutter/issues/65

Comment 4 fujiwara 2018-03-16 07:08:31 UTC
*** Bug 1557169 has been marked as a duplicate of this bug. ***

Comment 5 fujiwara 2018-03-16 07:09:37 UTC
*** Bug 1557177 has been marked as a duplicate of this bug. ***

Comment 6 Pooja Yadav 2019-04-05 07:02:03 UTC
Backspace working on search box at Activities overview in Fedora-30
Version release of components:
ibus-1.5.20-1.fc30.x86_64
gnome-shell-3.32.0-1.fc30.x86_64
ibus-kkc-1.5.22-11.fc30.x86_64

Hence, moving it to verified. Please re-open if required.


Note You need to log in before you can comment on or make changes to this bug.