Bug 1564257 - [RFE] CFME 5.9.4 - ability to cancel an in-progress migration
Summary: [RFE] CFME 5.9.4 - ability to cancel an in-progress migration
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
low
Target Milestone: GA
: 5.10.0
Assignee: Marco Berube
QA Contact: Kedar Kulkarni
Steve Bream
URL:
Whiteboard: v2v
: 1572999 1592753 (view as bug list)
Depends On:
Blocks: 1564236 1599997 1601090 1610533
TreeView+ depends on / blocked
 
Reported: 2018-04-05 19:28 UTC by Brett Thurber
Modified: 2019-02-11 14:04 UTC (History)
14 users (show)

Fixed In Version: 5.10.0.8
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1610533 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:04:04 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)

Description Brett Thurber 2018-04-05 19:28:31 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 2 Dave Johnson 2018-04-05 19:45:39 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 3 Dave Johnson 2018-04-05 20:04:28 UTC
Please assess the impact of this issue and update the severity accordingly.  Please refer to https://bugzilla.redhat.com/page.cgi?id=fields.html#bug_severity for a reminder on each severity's definition.

If it's something like a tracker bug where it doesn't matter, please set the severity to Low.

Comment 4 Brett Thurber 2018-05-24 02:56:01 UTC
*** Bug 1572999 has been marked as a duplicate of this bug. ***

Comment 9 Greg McCullough 2018-07-11 20:01:11 UTC
Backend PR: https://github.com/ManageIQ/manageiq/pull/17687

Comment 12 CFME Bot 2018-07-30 22:03:41 UTC
New commits detected on ManageIQ/manageiq-api/master:

https://github.com/ManageIQ/manageiq-api/commit/7cad510307a53ec0bb8580d3d37915e461f4ec2b
commit 7cad510307a53ec0bb8580d3d37915e461f4ec2b
Author:     Brandon Dunne <brandondunne@hotmail.com>
AuthorDate: Fri Jul 13 10:07:02 2018 -0400
Commit:     Brandon Dunne <brandondunne@hotmail.com>
CommitDate: Fri Jul 13 10:07:02 2018 -0400

    Allow href, message and success as string or symbol

    https://bugzilla.redhat.com/show_bug.cgi?id=1564257

 spec/support/api/helpers.rb | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


https://github.com/ManageIQ/manageiq-api/commit/581d8d428442d7f3084cb1916a0711a17d531c49
commit 581d8d428442d7f3084cb1916a0711a17d531c49
Author:     Brandon Dunne <brandondunne@hotmail.com>
AuthorDate: Fri Jul 13 10:08:03 2018 -0400
Commit:     Brandon Dunne <brandondunne@hotmail.com>
CommitDate: Fri Jul 13 10:08:03 2018 -0400

    Add a helper to simplify testing unauthorized requests

    https://bugzilla.redhat.com/show_bug.cgi?id=1564257

 spec/support/api/helpers.rb | 6 +
 1 file changed, 6 insertions(+)


https://github.com/ManageIQ/manageiq-api/commit/d7d00875ea3d910b3ea4378bb5fc29a43aa16549
commit d7d00875ea3d910b3ea4378bb5fc29a43aa16549
Author:     Brandon Dunne <brandondunne@hotmail.com>
AuthorDate: Fri Jul 13 10:12:42 2018 -0400
Commit:     Brandon Dunne <brandondunne@hotmail.com>
CommitDate: Fri Jul 13 10:12:42 2018 -0400

    Add request#cancel support to all 4 requests controllers

    https://bugzilla.redhat.com/show_bug.cgi?id=1564257

 app/controllers/api/automation_requests_controller.rb | 1 +
 app/controllers/api/mixins/resource_cancel.rb | 14 +
 app/controllers/api/provision_requests_controller.rb | 1 +
 app/controllers/api/requests_controller.rb | 1 +
 app/controllers/api/service_requests_controller.rb | 1 +
 config/api.yml | 16 +
 spec/requests/automation_requests_spec.rb | 6 +
 spec/requests/provision_requests_spec.rb | 6 +
 spec/requests/requests_spec.rb | 6 +
 spec/requests/service_requests_spec.rb | 6 +
 spec/support/shared_examples/resource_cancel.rb | 40 +
 11 files changed, 98 insertions(+)


https://github.com/ManageIQ/manageiq-api/commit/63080a82050304d706ec493df43ccf7273985436
commit 63080a82050304d706ec493df43ccf7273985436
Author:     Brandon Dunne <brandondunne@hotmail.com>
AuthorDate: Wed Jul 18 10:40:21 2018 -0400
Commit:     Brandon Dunne <brandondunne@hotmail.com>
CommitDate: Wed Jul 18 10:40:21 2018 -0400

    Add subcollection RequestTask#cancel

    https://bugzilla.redhat.com/show_bug.cgi?id=1564257

 app/controllers/api/subcollections/request_tasks.rb | 7 +
 config/api.yml | 4 +
 spec/requests/automation_requests_spec.rb | 6 +
 spec/requests/provision_requests_spec.rb | 6 +
 spec/requests/requests_spec.rb | 6 +
 spec/requests/service_requests_spec.rb | 6 +
 spec/support/shared_examples/sub_resource_cancel.rb | 38 +
 7 files changed, 73 insertions(+)


https://github.com/ManageIQ/manageiq-api/commit/b7dc2d9c383d95dc49a30d773db660f19b12d963
commit b7dc2d9c383d95dc49a30d773db660f19b12d963
Author:     Brandon Dunne <brandondunne@hotmail.com>
AuthorDate: Wed Jul 18 13:27:37 2018 -0400
Commit:     Brandon Dunne <brandondunne@hotmail.com>
CommitDate: Wed Jul 18 13:27:37 2018 -0400

    Add primary collection RequestTasks#cancel

    https://bugzilla.redhat.com/show_bug.cgi?id=1564257

 app/controllers/api/request_tasks_controller.rb | 1 +
 config/api.yml | 7 +
 spec/requests/request_tasks_spec.rb | 7 +
 3 files changed, 15 insertions(+)


https://github.com/ManageIQ/manageiq-api/commit/e83ed443dfb45a2aa504917b6b9eac403048566b
commit e83ed443dfb45a2aa504917b6b9eac403048566b
Author:     Brandon Dunne <brandondunne@hotmail.com>
AuthorDate: Fri Jul 13 12:16:59 2018 -0400
Commit:     Brandon Dunne <brandondunne@hotmail.com>
CommitDate: Fri Jul 13 12:16:59 2018 -0400

    Allow instance and bulk cancel of service_template service_requests

    https://bugzilla.redhat.com/show_bug.cgi?id=1564257

 app/controllers/api/subcollections/service_requests.rb | 7 +
 config/api.yml | 4 +
 spec/requests/service_orders_spec.rb | 6 +
 spec/requests/service_templates_spec.rb | 6 +
 4 files changed, 23 insertions(+)


https://github.com/ManageIQ/manageiq-api/commit/80b686eec6adcb070baebe9878826c25911da612
commit 80b686eec6adcb070baebe9878826c25911da612
Author:     Brandon Dunne <brandondunne@hotmail.com>
AuthorDate: Thu Jul 19 14:44:26 2018 -0400
Commit:     Brandon Dunne <brandondunne@hotmail.com>
CommitDate: Thu Jul 19 14:44:26 2018 -0400

    Modify the factories to set user rather than `try` everywhere

    https://bugzilla.redhat.com/show_bug.cgi?id=1564257

 spec/support/factory_overrides.rb | 23 +
 spec/support/shared_examples/resource_cancel.rb | 4 +-
 spec/support/shared_examples/sub_resource_cancel.rb | 6 +-
 3 files changed, 28 insertions(+), 5 deletions(-)

Comment 13 Fabien Dupont 2018-07-31 09:11:27 UTC
Should this BZ be moved to POST as the associated PRs are merged ?

Comment 16 Brandon Dunne 2018-08-09 18:17:17 UTC
*** Bug 1592753 has been marked as a duplicate of this bug. ***

Comment 17 Kedar Kulkarni 2018-08-23 20:26:58 UTC
On 5.10.0.12 I could cancel migration in progress.


Note You need to log in before you can comment on or make changes to this bug.