Bug 1564904 - PPPoE Connection fails with NetworkManager-ppp
Summary: PPPoE Connection fails with NetworkManager-ppp
Keywords:
Status: CLOSED DUPLICATE of bug 1564459
Alias: None
Product: Fedora
Classification: Fedora
Component: ppp
Version: 28
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jaroslav Škarvada
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-08 19:14 UTC by Eric Lajoie
Modified: 2018-04-09 13:20 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-09 12:39:36 UTC
Type: Bug


Attachments (Terms of Use)

Description Eric Lajoie 2018-04-08 19:14:05 UTC
Description of problem:
NetworkManager-ppp includes package ppp which includes its own kernel module "rp-pppoe". When trying to connect with nmcli we get error.

Version-Release number of selected component (if applicable):
pppd version 2.4.7
nmcli tool, version 1.10.6-1.fc28

How reproducible:
Always

Steps to Reproduce:
1.Install Fedora 28 minimal server
2.dnf install NetworkManager-ppp
3.nmcli connection add type pppoe ifname enp2s0 username 00xxx5511yyy0001@t-online.de password zzz

Actual results:
nmcli con up pppoe-enp2s0
Error: Connection activation failed: PPP failed

Journalctl -xe
pppd[9931]: /usr/lib/../lib64/pppd/2.4.7/rp-pppoe.so: undefined symbol: the_channel
pppd[9931]: Couldn't load plugin rp-pppoe.so

Expected results:
ppp0 link comes up

Additional info:
This was working in Fedora 27 but I may be missing a config option

Comment 1 Steven Haigh 2018-04-09 06:09:23 UTC
My PPPoE has broken in Fedora 28 as well. Was working fine in F27.

This is certainly a bug.

Comment 2 Steven Haigh 2018-04-09 06:41:01 UTC
For what its worth, I managed to at least get online by installing the rp-pppoe package, then setting up the connection via 'pppoe-setup', then activating with 'ifup ppp0'.

This is at least a workaround until the issue in this report is fixed.

Comment 3 Thomas Haller 2018-04-09 07:50:27 UTC
see https://bugzilla.redhat.com/show_bug.cgi?id=1563157#c7

Comment 4 Steven Haigh 2018-04-09 09:36:11 UTC
This remains broken with -20:

NetworkManager[443]: <info>  [1523266393.3421] device (enp1s0): Activation: starting connection 'SpinTel' (e03287ab-22a5-468b-bcc5-1aa7155e9426)
NetworkManager[443]: <info>  [1523266393.3427] audit: op="connection-activate" uuid="e03287ab-22a5-468b-bcc5-1aa7155e9426" name="SpinTel" pid=5642 uid=0 result="success"
NetworkManager[443]: <info>  [1523266393.3440] device (enp1s0): state change: disconnected -> prepare (reason 'none', sys-iface-state: 'managed')
NetworkManager[443]: <info>  [1523266393.3467] device (enp1s0): state change: prepare -> config (reason 'none', sys-iface-state: 'managed')
NetworkManager[443]: <info>  [1523266393.3526] device (enp1s0): state change: config -> ip-config (reason 'none', sys-iface-state: 'managed')
NetworkManager[443]: <info>  [1523266393.3546] ppp-manager: starting PPP connection
NetworkManager[443]: <info>  [1523266393.3606] ppp-manager: pppd started with pid 5646
NetworkManager[443]: /usr/sbin/pppd: /usr/lib/../lib64/pppd/2.4.7/rp-pppoe.so: undefined symbol: the_channel
NetworkManager[443]: /usr/sbin/pppd: Couldn't load plugin rp-pppoe.so
pppd[5646]: /usr/lib/../lib64/pppd/2.4.7/rp-pppoe.so: undefined symbol: the_channel
pppd[5646]: Couldn't load plugin rp-pppoe.so
NetworkManager[443]: <warn>  [1523266393.3792] ppp-manager: pppd pid 5646 exited with error 2: pppd options error
NetworkManager[443]: <info>  [1523266393.3794] device (enp1s0): state change: ip-config -> failed (reason 'ppp-failed', sys-iface-state: 'managed')
NetworkManager[443]: <warn>  [1523266393.3828] device (enp1s0): Activation: failed for connection 'SpinTel'
NetworkManager[443]: <info>  [1523266393.3854] device (enp1s0): state change: failed -> disconnected (reason 'none', sys-iface-state: 'managed')


$ rpm -qa | grep ppp
NetworkManager-ppp-1.10.6-1.fc28.x86_64
ppp-2.4.7-20.fc28.x86_64
rp-pppoe-3.12-10.fc27.x86_64

Comment 5 Eric Lajoie 2018-04-09 10:22:03 UTC
I did notice the Fedora27 dep includes compat-openssl10 which I did not see install with the Fedora28 packages.  I don't think its the issue but sharing the data point.

Comment 6 Jaroslav Škarvada 2018-04-09 12:39:36 UTC
(In reply to Eric Lajoie from comment #5)
> I did notice the Fedora27 dep includes compat-openssl10 which I did not see
> install with the Fedora28 packages.  I don't think its the issue but sharing
> the data point.

It should install openssl dep, the EAP-TLS patch has been updated, so it doesn't need the compat version.

*** This bug has been marked as a duplicate of bug 1564459 ***

Comment 7 Steven Haigh 2018-04-09 13:20:54 UTC
For the record, this seems fixed in ppp-2.4.7-21.fc28 here:
https://bodhi.fedoraproject.org/updates/FEDORA-2018-d5ee177b23


Note You need to log in before you can comment on or make changes to this bug.