Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1566199 - ipa-client-install fails to run in rhgs 3.3
Summary: ipa-client-install fails to run in rhgs 3.3
Keywords:
Status: CLOSED DUPLICATE of bug 1645428
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: redhat-storage-server
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: ---
Assignee: Milind Changire
QA Contact: Rahul Hinduja
URL:
Whiteboard:
Depends On:
Blocks: 1645428
TreeView+ depends on / blocked
 
Reported: 2018-04-11 18:36 UTC by Dan Lavu
Modified: 2021-06-10 15:46 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1645428 (view as bug list)
Environment:
Last Closed: 2019-04-29 02:45:19 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dan Lavu 2018-04-11 18:36:23 UTC
Description of problem:

ipa-client-install fails to run due to missing python modules, but where are these modules coming from? Looks like a miss package that should have been a dependency.

Version-Release number of selected component (if applicable):

glusterfs-server-3.8.4-54.4.el7rhgs.x86_64
ipa-client-4.5.4-10.el7.x86_64

How reproducible:

Always


Steps to Reproduce:
1. On RHGS installed system, subscription-manager repos --enable=rh-gluster-3-for-rhel-7-server-rpms --enable=rhel-7-server-rpms --enable=rhel-7-server-rhv-4-mgmt-agent-rpms --enable=rh-gluster-3-samba-for-rhel-7-server-rpms
2. yum install -y ipa-client
3. ipa-client-install 

Actual results:

ipa-client-install
Traceback (most recent call last):
  File "/usr/sbin/ipa-client-install", line 22, in <module>
    from ipaclient.install import ipa_client_install
  File "/usr/lib/python2.7/site-packages/ipaclient/install/ipa_client_install.py", line 5, in <module>
    from ipaclient.install import client
  File "/usr/lib/python2.7/site-packages/ipaclient/install/client.py", line 34, in <module>
    from ipalib import api, errors, x509
  File "/usr/lib/python2.7/site-packages/ipalib/x509.py", line 45, in <module>
    from pyasn1_modules import rfc2315, rfc2459
  File "/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2315.py", line 67, in <module>
    class DigestedData(univ.Sequence):
  File "/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2315.py", line 72, in DigestedData
    namedtype.NamedType('digest', Digest)
  File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line 115, in __init__
    self.__ambiguousTypes = 'terminal' not in kwargs and self.__computeAmbiguousTypes() or {}
  File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line 232, in __computeAmbiguousTypes
    ambigiousTypes[idx] = NamedTypes(*partialAmbigiousTypes, **dict(terminal=True))
  File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line 114, in __init__
    self.__tagToPosMap = self.__computeTagToPosMap()
  File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line 205, in __computeTagToPosMap
    for _tagSet in tagMap.presentTypes:
AttributeError: 'property' object has no attribute 'presentTypes'


Expected results:

ipa-client-install

WARNING: ntpd time&date synchronization service will not be configured as
conflicting service (chronyd) is enabled
Use --force-ntpd option to disable it and force configuration of ntpd

Discovery was successful!
Client hostname: rhev1.redhat.com
Realm: REDHAT.COM
DNS Domain: redhat.com
IPA Server: idm1.redhat.com
BaseDN: dc=redhat,dc=com


Additional info:


/usr/sbin/ipa-client-install : 22 
-------------------------------------------------------------------------------------------------------
from ipaclient.install import ipa_client_install
-------------------------------------------------------------------------------------------------------


yum repolist
-------------------------------------------------------------------------------------------------------
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
repo id                                                            repo name                                                               status
rh-gluster-3-for-rhel-7-server-rpms/7Server/x86_64                 Red Hat Gluster Storage 3 Server (RPMs)                                    791
rh-gluster-3-samba-for-rhel-7-server-rpms/7Server/x86_64           Red Hat Gluster Storage 3 Samba (for RHEL 7 Server) (RPMs)                 518
rhel-7-server-rhv-4-mgmt-agent-rpms/7Server/x86_64                 Red Hat Virtualization 4 Management Agents for RHEL 7 (RPMs)             1,043
rhel-7-server-rpms/7Server/x86_64                                  Red Hat Enterprise Linux 7 Server (RPMs)                                20,091
repolist: 22,443
-------------------------------------------------------------------------------------------------------


Attempting to reinstall the package, dependency errors


yum reinstall -y ipa-client
-------------------------------------------------------------------------------------------------------
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
rh-gluster-3-for-rhel-7-server-rpms                                                                                       | 4.0 kB  00:00:00     
rh-gluster-3-samba-for-rhel-7-server-rpms                                                                                 | 4.0 kB  00:00:00     
rhel-7-server-rhv-4-mgmt-agent-rpms                                                                                       | 4.0 kB  00:00:00     
rhel-7-server-rpms                                                                                                        | 3.5 kB  00:00:00     
Resolving Dependencies
--> Running transaction check
---> Package ipa-client.x86_64 0:4.5.4-10.el7 will be reinstalled
--> Finished Dependency Resolution

Dependencies Resolved

=================================================================================================================================================
 Package                          Arch                         Version                            Repository                                Size
=================================================================================================================================================
Reinstalling:
 ipa-client                       x86_64                       4.5.4-10.el7                       rhel-7-server-rpms                       255 k

Transaction Summary
=================================================================================================================================================
Reinstall  1 Package

Total size: 255 k
Installed size: 251 k
Is this ok [y/d/N]: y
Downloading packages:
Running transaction check
ERROR with transaction check vs depsolve:
freeipa-client conflicts with ipa-client-4.5.4-10.el7.x86_64
freeipa-admintools conflicts with ipa-client-4.5.4-10.el7.x86_64
freeipa-admintools conflicts with (installed) ipa-client-4.5.4-10.el7.x86_64
freeipa-client conflicts with (installed) ipa-client-4.5.4-10.el7.x86_64
 You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with:
 yum load-transaction /tmp/yum_save_tx.2018-04-11.14-26.8b_uZT.yumtx
-------------------------------------------------------------------------------------------------------

Comment 2 Milind Changire 2018-04-17 09:06:39 UTC
(In reply to Dan Lavu from comment #0)
> Description of problem:
> 
> ipa-client-install fails to run due to missing python modules, but where are
> these modules coming from? Looks like a miss package that should have been a
> dependency.
> 
> Version-Release number of selected component (if applicable):
> 
> glusterfs-server-3.8.4-54.4.el7rhgs.x86_64
> ipa-client-4.5.4-10.el7.x86_64
> 
> How reproducible:
> 
> Always
> 
> 
> Steps to Reproduce:
> 1. On RHGS installed system, subscription-manager repos
> --enable=rh-gluster-3-for-rhel-7-server-rpms --enable=rhel-7-server-rpms
> --enable=rhel-7-server-rhv-4-mgmt-agent-rpms
> --enable=rh-gluster-3-samba-for-rhel-7-server-rpms
> 2. yum install -y ipa-client
> 3. ipa-client-install 
> 
> Actual results:
> 
> ipa-client-install
> Traceback (most recent call last):
>   File "/usr/sbin/ipa-client-install", line 22, in <module>
>     from ipaclient.install import ipa_client_install
>   File
> "/usr/lib/python2.7/site-packages/ipaclient/install/ipa_client_install.py",
> line 5, in <module>
>     from ipaclient.install import client
>   File "/usr/lib/python2.7/site-packages/ipaclient/install/client.py", line
> 34, in <module>
>     from ipalib import api, errors, x509
>   File "/usr/lib/python2.7/site-packages/ipalib/x509.py", line 45, in
> <module>
>     from pyasn1_modules import rfc2315, rfc2459
>   File "/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2315.py", line
> 67, in <module>
>     class DigestedData(univ.Sequence):
>   File "/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2315.py", line
> 72, in DigestedData
>     namedtype.NamedType('digest', Digest)
>   File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line
> 115, in __init__
>     self.__ambiguousTypes = 'terminal' not in kwargs and
> self.__computeAmbiguousTypes() or {}
>   File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line
> 232, in __computeAmbiguousTypes
>     ambigiousTypes[idx] = NamedTypes(*partialAmbigiousTypes,
> **dict(terminal=True))
>   File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line
> 114, in __init__
>     self.__tagToPosMap = self.__computeTagToPosMap()
>   File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line
> 205, in __computeTagToPosMap
>     for _tagSet in tagMap.presentTypes:
> AttributeError: 'property' object has no attribute 'presentTypes'
> 
> 
> Expected results:
> 
> ipa-client-install
> 
> WARNING: ntpd time&date synchronization service will not be configured as
> conflicting service (chronyd) is enabled
> Use --force-ntpd option to disable it and force configuration of ntpd
> 
> Discovery was successful!
> Client hostname: rhev1.redhat.com
> Realm: REDHAT.COM
> DNS Domain: redhat.com
> IPA Server: idm1.redhat.com
> BaseDN: dc=redhat,dc=com
> 
> 
> Additional info:
> 
> 
> /usr/sbin/ipa-client-install : 22 
> -----------------------------------------------------------------------------
> --------------------------
> from ipaclient.install import ipa_client_install
> -----------------------------------------------------------------------------
> --------------------------
> 
> 
> yum repolist
> -----------------------------------------------------------------------------
> --------------------------
> Loaded plugins: langpacks, product-id, search-disabled-repos,
> subscription-manager
> repo id                                                            repo name
> status
> rh-gluster-3-for-rhel-7-server-rpms/7Server/x86_64                 Red Hat
> Gluster Storage 3 Server (RPMs)                                    791
> rh-gluster-3-samba-for-rhel-7-server-rpms/7Server/x86_64           Red Hat
> Gluster Storage 3 Samba (for RHEL 7 Server) (RPMs)                 518
> rhel-7-server-rhv-4-mgmt-agent-rpms/7Server/x86_64                 Red Hat
> Virtualization 4 Management Agents for RHEL 7 (RPMs)             1,043
> rhel-7-server-rpms/7Server/x86_64                                  Red Hat
> Enterprise Linux 7 Server (RPMs)                                20,091
> repolist: 22,443
> -----------------------------------------------------------------------------
> --------------------------
> 
> 
> Attempting to reinstall the package, dependency errors
> 
> 
> yum reinstall -y ipa-client
> -----------------------------------------------------------------------------
> --------------------------
> Loaded plugins: langpacks, product-id, search-disabled-repos,
> subscription-manager
> rh-gluster-3-for-rhel-7-server-rpms                                         
> | 4.0 kB  00:00:00     
> rh-gluster-3-samba-for-rhel-7-server-rpms                                   
> | 4.0 kB  00:00:00     
> rhel-7-server-rhv-4-mgmt-agent-rpms                                         
> | 4.0 kB  00:00:00     
> rhel-7-server-rpms                                                          
> | 3.5 kB  00:00:00     
> Resolving Dependencies
> --> Running transaction check
> ---> Package ipa-client.x86_64 0:4.5.4-10.el7 will be reinstalled
> --> Finished Dependency Resolution
> 
> Dependencies Resolved
> 
> =============================================================================
> ====================================================================
>  Package                          Arch                         Version      
> Repository                                Size
> =============================================================================
> ====================================================================
> Reinstalling:
>  ipa-client                       x86_64                       4.5.4-10.el7 
> rhel-7-server-rpms                       255 k
> 
> Transaction Summary
> =============================================================================
> ====================================================================
> Reinstall  1 Package
> 
> Total size: 255 k
> Installed size: 251 k
> Is this ok [y/d/N]: y
> Downloading packages:
> Running transaction check
> ERROR with transaction check vs depsolve:
> freeipa-client conflicts with ipa-client-4.5.4-10.el7.x86_64
> freeipa-admintools conflicts with ipa-client-4.5.4-10.el7.x86_64
> freeipa-admintools conflicts with (installed) ipa-client-4.5.4-10.el7.x86_64
> freeipa-client conflicts with (installed) ipa-client-4.5.4-10.el7.x86_64
>  You could try running: rpm -Va --nofiles --nodigest
> Your transaction was saved, rerun it with:
>  yum load-transaction /tmp/yum_save_tx.2018-04-11.14-26.8b_uZT.yumtx
> -----------------------------------------------------------------------------
> --------------------------

Looks like there's a conflict of package ipa-client with freeipa-client and freeipa-admintools packages.

You probably need to uninstall freeipa* set of packages or abstain from installing ipa* set of packages.

Please confirm if freeipa* set of packages are already installed on your system. If so, you probably don't need to install ipa-client at all.

Also, redhat-storage-server does not explicitly pull in either freeipa* or ipa* set of packages. So this does not seem anything related to redhat-storage-server RPM.

Comment 5 Peter Beniaris 2018-05-02 15:39:38 UTC
I have just tested this scenario running on the latest patched version of RHEL 7.5, the latest patched version of Gluster 3.3, and IdM 4.5.4.  I did not have any freeipa packages installed, and installed the ipa-client package.  I get output identical to that listed above.

Comment 6 Cal Calhoun 2018-05-23 18:10:14 UTC
  New case for the same situation.  As indicated in c#5, This customer has no freeIPA packages installed prior to attempting to execute ipa-client-install.  Can we get an update on how to proceed?

Comment 11 Peter Beniaris 2018-06-19 17:08:35 UTC
Just to confirm, per Milind's request, there are no freeipa* packages on any of my Gluster nodes (see following snippet):

[root@rhgs-node1 ~]# yum search freeipa-client
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
Warning: No matches found for: freeipa-client
No matches found

Comment 13 Peter Beniaris 2018-08-09 16:46:28 UTC
Were going on five months with Gluster 3.3 not being able to integrate with Red Hat Identity Manager.  Is there any time frame for fixing this?  The output reported above on April 11 is identical to the output I continue to receive.   Priority and severity are both listed as high, so I am under the impression that this should be addressed.  Please let me know.

Comment 17 JD 2018-08-15 14:20:23 UTC
(In reply to Peter Beniaris from comment #13)
> Were going on five months with Gluster 3.3 not being able to integrate with
> Red Hat Identity Manager.  Is there any time frame for fixing this?  The
> output reported above on April 11 is identical to the output I continue to
> receive.   Priority and severity are both listed as high, so I am under the
> impression that this should be addressed.  Please let me know.

There appears to be some internal conflict with the ipa-client RPM from Red Hat that thinks it has freeipa-* packages as well as ipa-* packages.
Red Hat needs to get off the pot and straightens out their RPM's, Gluser isn't free.
I got my gluster servers (rhel7.5) to join ipa by downgrading the ipa packages until I reached an old enough version that it wasn't broken. For my case that was version 4.4.0-14, your mileage may vary.

]# yum downgrade ipa-client-common-4.4.0-14.el7_3.7.noarch ipa-client-4.4.0-14.el7_3.7.x86_64 pam_krb5-2.4.8-6.el7.x86_64 ipa-common-4.4.0-14.el7_3.7.noarch python-custodia-0.3.1-4.el7.noarch python2-ipaclient-4.4.0-14.el7_3.7.noarch python2-ipalib-4.4.0-14.el7_3.7.noarch

]# ipa-client-install

]# yum update ipa-*

Comment 19 Florence Blanc-Renaud 2018-10-29 15:16:18 UTC
Hi,

ipa-* packages are delivered for RHEL, while freeipa-* packages are delivered for Fedora.

This issue remindes me of the following 2 BZs, also related to conflicting packages between ipa-* and freeipa-* pkgs:
Bug 1564747 - freeipa-client-common conflicts with ipa-client-common-4.5.0-22.el7.centos.noarch
Bug 1574917 - pyanaconda.payload.PayloadError: Payload error - DNF installation has ended up abruptly: ipa-common conflicts with (installed) freeipa-common-4.6.90.pre1-6.1.fc28.noarchTraceback (most recent call last):

Please have a look at https://bugzilla.redhat.com/show_bug.cgi?id=1564747#c2 as it explains how the RHEL packages are named and defines conflict with the Fedora packages.

Comment 20 Milan Zink 2018-11-02 07:53:04 UTC
Hi,

same problem with RHGS3.4. ipa-client-install is broken.

Comment 21 Amar Tumballi 2018-11-20 05:40:50 UTC
@milan, can you check if packages from comment#12 works for you?

Comment 22 Milan Zink 2018-11-20 07:38:01 UTC
The problem is with python2-pyasn1.noarch 0:0.3.7-2.el7rhgs

[rhgs-ohcaz1-pre-c01-n01.storage.phx2.redhat.com] [07:35:41 AM]
[root@rhgs-ohcaz1-pre-c01-n01 ~]# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.6 (Maipo)
[rhgs-ohcaz1-pre-c01-n01.storage.phx2.redhat.com] [07:35:52 AM]
[root@rhgs-ohcaz1-pre-c01-n01 ~]# rpm -qa | grep ipa | sort
ipa-client-4.6.4-10.el7.x86_64
ipa-client-common-4.6.4-10.el7.noarch
ipa-common-4.6.4-10.el7.noarch
libipa_hbac-1.16.2-13.el7.x86_64
python2-ipaclient-4.6.4-10.el7.noarch
python2-ipalib-4.6.4-10.el7.noarch
python-iniparse-0.4-9.el7.noarch
python-ipaddress-1.0.16-2.el7.noarch
python-libipa_hbac-1.16.2-13.el7.x86_64
sssd-ipa-1.16.2-13.el7.x86_64


[root@rhgs-ohcaz1-pre-c01-n01 ~]# ipa-client-install --help
Traceback (most recent call last):
  File "/usr/sbin/ipa-client-install", line 22, in <module>
    from ipaclient.install import ipa_client_install
  File "/usr/lib/python2.7/site-packages/ipaclient/install/ipa_client_install.py", line 7, in <module>
    from ipaclient.install import client
  File "/usr/lib/python2.7/site-packages/ipaclient/install/client.py", line 35, in <module>
    from ipalib import api, errors, x509
  File "/usr/lib/python2.7/site-packages/ipalib/__init__.py", line 921, in <module>
    from ipalib.frontend import Command, LocalOrRemote, Updater
  File "/usr/lib/python2.7/site-packages/ipalib/frontend.py", line 31, in <module>
    from ipalib.parameters import create_param, Param, Str, Flag
  File "/usr/lib/python2.7/site-packages/ipalib/parameters.py", line 124, in <module>
    from ipalib.x509 import (
  File "/usr/lib/python2.7/site-packages/ipalib/x509.py", line 51, in <module>
    from pyasn1_modules import rfc2315, rfc2459
  File "/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2315.py", line 67, in <module>
    class DigestedData(univ.Sequence):
  File "/usr/lib/python2.7/site-packages/pyasn1_modules/rfc2315.py", line 72, in DigestedData
    namedtype.NamedType('digest', Digest)
  File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line 115, in __init__
    self.__ambiguousTypes = 'terminal' not in kwargs and self.__computeAmbiguousTypes() or {}
  File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line 232, in __computeAmbiguousTypes
    ambigiousTypes[idx] = NamedTypes(*partialAmbigiousTypes, **dict(terminal=True))
  File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line 114, in __init__
    self.__tagToPosMap = self.__computeTagToPosMap()
  File "/usr/lib/python2.7/site-packages/pyasn1/type/namedtype.py", line 205, in __computeTagToPosMap
    for _tagSet in tagMap.presentTypes:
AttributeError: 'property' object has no attribute 'presentTypes'


 yum downgrade python2-pyasn1

...
Resolving Dependencies
--> Running transaction check
---> Package python2-pyasn1.noarch 0:0.1.9-7.el7 will be a downgrade
---> Package python2-pyasn1.noarch 0:0.3.7-2.el7rhgs will be erased

...

[rhgs-ohcaz1-pre-c01-n01.storage.phx2.redhat.com] [07:34:22 AM]
[root@rhgs-ohcaz1-pre-c01-n01 ~]# ipa-client-install --help
Usage: ipa-client-install [options]

Options:
  --version             show program's version number and exit
  -h, --help            show this help message and exit
  -U, --unattended      unattended (un)installation never prompts the user
  --uninstall           uninstall an existing installation. The uninstall can
                        be run with --unattended option


We need to get rid of unused python2-pyasn1 0:0.3.7-2.el7rhgs

Comment 23 Amar Tumballi 2018-11-20 08:47:02 UTC
Thanks for the update! Milind, can this be taken care? Or is it in some other package?

Comment 24 Milind Changire 2018-11-20 09:00:42 UTC
Bug 1645428 addresses this issue as well. Please take a look there.


Note You need to log in before you can comment on or make changes to this bug.