Bug 1566298 - [virtio-win][viostor] unattended installation failure on unpartitioned image when using virtio_blk
Summary: [virtio-win][viostor] unattended installation failure on unpartitioned image ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.6
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: ---
Assignee: Vadim Rozenfeld
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-12 02:00 UTC by Yu Wang
Modified: 2018-10-30 16:22 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
NO_DOCS
Clone Of:
Environment:
Last Closed: 2018-10-30 16:21:50 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot (34.02 KB, image/jpeg)
2018-04-12 02:00 UTC, Yu Wang
no flags Details
screenshot_win2008_auto_manual (221.10 KB, application/zip)
2018-04-17 08:41 UTC, Yu Wang
no flags Details
create-submission (12.36 KB, image/png)
2018-04-19 05:36 UTC, Yu Wang
no flags Details
bsod-screenshot (11.42 KB, image/png)
2018-05-28 09:57 UTC, Yu Wang
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3413 0 None None None 2018-10-30 16:22:51 UTC

Description Yu Wang 2018-04-12 02:00:52 UTC
Created attachment 1420618 [details]
screenshot

Description of problem:
unattended installation failure while manually success when using virtio_blk(W2012 saying unsupported NTFS version)


Version-Release number of selected component (if applicable):
virtio-win-prewhql-149


How reproducible:
100%

Steps to Reproduce:
1. boot guest with virio-blk device and install guests

/usr/libexec/qemu-kvm -S -name avocado-vt-vm1 -sandbox off -machine pc -nodefaults -vga std -chardev socket,id=qmp_id_qmpmonitor1,path=/var/tmp/123,server,nowait -mon chardev=qmp_id_qmpmonitor1,mode=control -chardev socket,id=qmp_id_catch_monitor,path=/var/tmp/123,server,nowait -mon chardev=qmp_id_catch_monitor,mode=control -device pvpanic,ioport=0x505,id=idTruRrb -chardev socket,id=serial_id_serial0,path=/var/tmp/123,server,nowait -device isa-serial,chardev=serial_id_serial0 -chardev socket,id=seabioslog_id_20180320-111434-Ps8AET5v,path=/var/tmp/123,server,nowait -device isa-debugcon,chardev=seabioslog_id_20180320-111434-Ps8AET5v,iobase=0x402 -drive id=drive_image1,if=none,snapshot=off,aio=threads,cache=none,format=qcow2,file=/home/kvm_autotest_root/images/install.qcow2 -device virtio-blk-pci,id=image1,drive=drive_image1,bootindex=0,bus=pci.0,addr=0x4 -device virtio-net-pci,mac=9a:d3:d4:d5:d6:d7,id=idqwloVL,vectors=4,netdev=idGbvmFr,bus=pci.0,addr=0x5 -netdev tap,id=idGbvmFr,vhost=on -m 2048 -smp 4,maxcpus=4,cores=2,threads=1,sockets=2 -cpu Nehalem,+kvm_pv_unhalt,hv_relaxed,hv_spinlocks=0x1fff,hv_vapic,hv_time -drive id=drive_cd1,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/home/kvm_autotest_root/iso/ISO/Windows7/en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso -device ide-cd,id=cd1,drive=drive_cd1,bootindex=1,bus=ide.0,unit=0 -drive id=drive_winutils,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/home/kvm_autotest_root/iso/windows/virtio-win-prewhql-0.1-149.iso -device ide-cd,id=winutils,drive=drive_winutils,bootindex=2,bus=ide.0,unit=1 -vnc :0 -rtc base=localtime,clock=host,driftfix=slew -boot menu=on,strict=off,order=cdn,once=c -monitor stdio -qmp tcp:0:4444,server,nowait -drive id=drive_unattended,if=none,snapshot=off,aio=threads,cache=none,media=cdrom,file=/home/autounattend-1.iso -device ide-cd,id=unattended,drive=drive_unattended,bootindex=3,bus=ide.1,unit=0

2.
3.

Actual results:


Expected results:


Additional info:
1 hit on win2008/win7/win2008r2
2 not hit this issue with build145, so it is a regression
3 seems the same issue as bug966861
4 with a pre-formatted img, it works.

Comment 5 Yu Wang 2018-04-17 08:41:03 UTC
Created attachment 1422948 [details]
screenshot_win2008_auto_manual

When installing guest with win2008, hit similar error with win7.

Manual installing:
It shows "Windows cannot be installed to this hard disk space. Windows must be installed to a partition formatted as NTFS" 

Automation:
Windows could not create a partition on disk 0. 
Error code:0x80300025

More info refer to these attachments:
Screenshot-win2008-64-manual for manual
Screenshot-win2008-auto  for automation

Comment 6 lijin 2018-04-17 10:02:25 UTC
(In reply to Yu Wang from comment #5)
> Created attachment 1422948 [details]
> screenshot_win2008_auto_manual
> 
> When installing guest with win2008, hit similar error with win7.
> 
> Manual installing:
> It shows "Windows cannot be installed to this hard disk space. Windows must
> be installed to a partition formatted as NTFS" 
> 
> Automation:
> Windows could not create a partition on disk 0. 
> Error code:0x80300025

win2008-32 vioscsi hit the same code but with much lower reproduce percentage(not stable reproduced and not regression).

Comment 7 Vadim Rozenfeld 2018-04-17 11:07:40 UTC
(In reply to Yu Wang from comment #5)
> Created attachment 1422948 [details]
> screenshot_win2008_auto_manual
> 
> When installing guest with win2008, hit similar error with win7.
> 
> Manual installing:
> It shows "Windows cannot be installed to this hard disk space. Windows must
> be installed to a partition formatted as NTFS" 
> 
> Automation:
> Windows could not create a partition on disk 0. 
> Error code:0x80300025
> 
> More info refer to these attachments:
> Screenshot-win2008-64-manual for manual
> Screenshot-win2008-auto  for automation

I wonder if adding serial number to "-device virtio-blk-pci," makes any difference. Apart from that, for manual install do you use the same qemu cli as mentioned in the bug's description? I'm going to try reproducing the problem on my local setup.

Thanks,
Vadim.

Comment 8 Yu Wang 2018-04-18 04:31:21 UTC
(In reply to Vadim Rozenfeld from comment #7)
> (In reply to Yu Wang from comment #5)
> > Created attachment 1422948 [details]
> > screenshot_win2008_auto_manual
> > 
> > When installing guest with win2008, hit similar error with win7.
> > 
> > Manual installing:
> > It shows "Windows cannot be installed to this hard disk space. Windows must
> > be installed to a partition formatted as NTFS" 
> > 
> > Automation:
> > Windows could not create a partition on disk 0. 
> > Error code:0x80300025
> > 
> > More info refer to these attachments:
> > Screenshot-win2008-64-manual for manual
> > Screenshot-win2008-auto  for automation
> 
> I wonder if adding serial number to "-device virtio-blk-pci," makes any
> difference. 

The same error "Windows must be installed to a partition formatted as NTFS" after adding serial number to device.

> Apart from that, for manual install do you use the same qemu cli
> as mentioned in the bug's description? I'm going to try reproducing the
> problem on my local setup.
> 

Yes, they use the same cli as comment#0

> Thanks,
> Vadim.

Comment 15 Yu Wang 2018-04-19 05:36:13 UTC
Created attachment 1423923 [details]
create-submission

Comment 22 lijin 2018-05-14 07:53:25 UTC
Hi Vadim,
How about this issue?
It still block automation test for win2008/win7/win2008R2.

Comment 23 Vadim Rozenfeld 2018-05-14 09:21:09 UTC
(In reply to lijin from comment #22)
> Hi Vadim,
> How about this issue?
> It still block automation test for win2008/win7/win2008R2.

Hi Li Jin.
Honestly, I was not able to reproduce this problem on my setup to start debugging
the problem. (It was just failing with a different problem). Since it is a regression, I was thinking to return the previous code to the drivers prior to Win10 and keep the new code (which fixes Even Id 158 problem) for Windows 10 /WS 2016 only. I should be build such kind of drivers as soon as virtio-win build system will be fixed again.
Vadim.

Comment 24 Yu Wang 2018-05-28 09:56:38 UTC
Hi,

Tried to verify with build153 on win2008-32/64, win7-32/64 and win2008r2

Win2008r2/win2008-32/win7-32/win7-64: no error occurred now when installing guest, but BSOD when the first reboot to the guest after installation, and cannot boot into the guest (refer to attachment)

It similar with the bug1568739, but not the same code.

win2008-64: still occurred error on win2008-64 as comment#5.



Thanks
Yu Wang

Comment 25 Yu Wang 2018-05-28 09:57:30 UTC
Created attachment 1443099 [details]
bsod-screenshot

Comment 26 Vadim Rozenfeld 2018-05-28 10:38:27 UTC
(In reply to Yu Wang from comment #25)
> Created attachment 1443099 [details]
> bsod-screenshot

Thanks,
I will try to reproduce and trace the problem asap.
Vadim.

Comment 27 Peixiu Hou 2018-06-07 02:17:41 UTC
hit the same issue on rhel8 host, tested on win7-64.

Used versions:
kernel-4.16.0-10.el8+5.x86_64
qemu-kvm-2.12.0-11.el8+619+ba8f0855.1.x86_64
seabios-bin-1.11.0-1.el8+526+412dc3e0.noarch
virtio-win-prewhql-153

Comment 28 Yu Wang 2018-07-05 07:53:55 UTC
verify with build155 on win2008-32/64, win7-32/64 and win2008r2

It can be installed successfully, so change status to verified.

Comment 31 errata-xmlrpc 2018-10-30 16:21:50 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3413


Note You need to log in before you can comment on or make changes to this bug.