Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be unavailable on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1568022 - ceph container image lacks nfs-ganesha-ceph package
Summary: ceph container image lacks nfs-ganesha-ceph package
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Container
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: z2
: 3.0
Assignee: Erwan Velu
QA Contact: Yogev Rabl
URL:
Whiteboard:
Depends On:
Blocks: 1469208 1489938
TreeView+ depends on / blocked
 
Reported: 2018-04-16 15:39 UTC by Tom Barron
Modified: 2018-06-26 23:47 UTC (History)
7 users (show)

Fixed In Version: rhceph-rhel7-docker-3-6
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-26 18:31:07 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-container pull 1019 0 None None None 2018-04-17 15:57:59 UTC
Red Hat Product Errata RHBA-2018:1260 0 None None None 2018-04-26 18:31:40 UTC

Description Tom Barron 2018-04-16 15:39:39 UTC
Description of problem:  ceph-daemon container in RHCS 3.0 does not contain the nfs-ganesha-ceph package.  This package provides libcephfs and is necessary for ganesha to work with the Ceph FSAL (file system abstraction layer), e.g. in RHOSP manila deployment with CephNFS back end.

Version-Release number of selected component (if applicable):

ceph-3.0-rhel-7-docker-candidate-29913-20180411163001

How reproducible:  100%

Steps to Reproduce:

1. Inspect the docker image and its PACKAGES.

# docker images | grep ceph
192.168.24.1:8787/rhceph                                                         ceph-3.0-rhel-7-docker-candidate-29913-20180411163001   80e7c4007047        4 days ago          722 MB
[root@controller-1 ~]# docker inspect 80e7c400704 | grep PACKAGES
                "PACKAGES=ceph-mon ceph-osd ceph-mds ceph-radosgw rbd-mirror nfs-ganesha-rgw e2fsprogs ceph-mgr",

2. Observe that although ngs-ganesha-rgw is included nfs-ganesha-ceph is not

Actual results:

nf-ganesha-ceph is not included in the downstream container even though it is included in the upstream ceph-daemon package: https://github.com/ceph/ceph-container/blob/stable-3.0/src/daemon-base/__GANESHA_PACKAGES__

Expected results:

nfs-ganesha-ceph package will be included in the RHCS 3.0 ceph-daemon container.

Comment 4 Tom Barron 2018-04-16 19:29:32 UTC
I notice that the upstream ceph-daemon container image actually contains *three* nfs-ganesha packages [1]:
  * nfs-ganesha
  * nfs-ganesha-ceph
  * nfs-ganesha-rgw
whereas downstream we have only nfs-ganesha-rgw

In this bug I have requested ngs-ganesha-ceph because I saw that ceph-fsal libraries are missing but do we also need to explicitly include the base nfs-ganesha package as is done upstream?


[1] https://github.com/ceph/ceph-container/blob/stable-3.0/src/daemon-base/__GANESHA_PACKAGES__

Comment 5 Erwan Velu 2018-04-16 20:31:07 UTC
The upstream project is lacking of the RHEL support.
I'm currently working on adding it.
That should be avail soon and of course with the ganesha packages.

Comment 7 Ramakrishnan Periyasamy 2018-04-17 10:08:42 UTC
provided QA_QCK, clearing needinfo flag

Comment 8 Sébastien Han 2018-04-17 16:56:52 UTC
 git push ssh://shan@pkgs.devel.redhat.com/rpms/rhceph-rhel7-docker ceph-3.0-rhel-7:ceph-3.0-rhel-7
shan@pkgs.devel.redhat.com's password:
Counting objects: 33, done.
Delta compression using up to 4 threads.
Compressing objects: 100% (31/31), done.
Writing objects: 100% (33/33), 12.29 KiB | 4.09 MiB/s, done.
Total 33 (delta 21), reused 0 (delta 0)
remote: *** Checking commit 522faf6237ee00807da5f79592ea174e8013e46b
remote: *** Resolves:
remote: ***   Approved:
remote: ***     rhbz#1568022 (qa_ack+, ceph-3.0?, pm_ack+, devel_ack?)
remote: *** Commit 522faf6237ee00807da5f79592ea174e8013e46b allowed
remote: * Publishing information for 1 commits
To ssh://pkgs.devel.redhat.com/rpms/rhceph-rhel7-docker
   96c59a7..522faf6  ceph-3.0-rhel-7 -> ceph-3.0-rhel-7


Ken, I don't see any input from the CI in the BZ, is it normal?

Comment 9 Erwan Velu 2018-04-17 21:44:39 UTC
The first build passed, a small mistake was found.
A new build is required and then this BZ will be over.

Comment 10 Erwan Velu 2018-04-18 09:22:54 UTC
As per yesterday's build, 

I did a package diff between the previous image and rhceph:ceph-3.0-rhel-7-docker-candidate-74449-20180418010804

The following packages were added (none was removed) :

ceph-iscsi-cli-2.5-9.el7cp.noarch
ceph-iscsi-config-2.3-12.el7cp.noarch
gpg-pubkey-00da75f2-5608f154
libtcmu-1.3.0-0.4.el7cp.x86_64
nfs-ganesha-ceph-2.5.5-3.el7cp.x86_64
pyparsing-1.5.6-9.el7.noarch
python2-crypto-2.6.1-16.el7ost.x86_64
python-configshell-1.1.fb23-3.el7.noarch
python-kmod-0.9-4.el7.x86_64
python-netaddr-0.7.5-9.el7.noarch
python-netifaces-0.10.4-3.el7.x86_64
python-rtslib-2.1.fb64-2.el7cp.noarch
python-urwid-1.1.1-3.el7.x86_64
targetcli-2.1.fb47-0.1.20170815.git5bf3517.el7cp.noarch
tcmu-runner-1.3.0-0.4.el7cp.x86_64
unzip-6.0-19.el7.x86_64
wget-1.14-15.el7_4.1.x86_64

As per this BZ, for me the fix is present & provides a good output.

Comment 13 Yogev Rabl 2018-04-20 03:28:21 UTC
Verified, the deployment was successful and Manila is functional

Comment 14 Erwan Velu 2018-04-20 08:16:58 UTC
(In reply to Yogev Rabl from comment #13)
> Verified, the deployment was successful and Manila is functional

Cool !

Comment 17 errata-xmlrpc 2018-04-26 18:31:07 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1260


Note You need to log in before you can comment on or make changes to this bug.