Bug 1469208 - [RFE][manila] Support CephFS NFS back end
Summary: [RFE][manila] Support CephFS NFS back end
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-manila
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Ram Raja
QA Contact: Dustin Schoenbrun
Kim Nylander
URL:
Whiteboard:
: 1469196 (view as bug list)
Depends On: 1543053 1568022 1575023
Blocks: 1414980 1475544 1489934 1489938 1571739
TreeView+ depends on / blocked
 
Reported: 2017-07-10 16:16 UTC by Tom Barron
Modified: 2018-06-27 13:31 UTC (History)
7 users (show)

Fixed In Version: openstack-manila-6.0.0-0.20180122210259.4adbf82.el7ost
Doc Type: Release Note
Doc Text:
The Shared File System service (manila) supports mounting shared file systems backed by a Ceph File System (CephFS) via the NFSv4 protocol. NFS-Ganesha servers operating on Controller nodes are used to export CephFS to tenants with high availability (HA). Tenants are isolated from one another and may only access CephFS through the provided NFS gateway interface. This new feature is fully integrated into director, enabling CephFS back end deployment and configuration for the Shared File System service.
Clone Of:
Environment:
Last Closed: 2018-06-27 13:31:39 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 510547 None MERGED ganesha: store exports and export counter in RADOS 2020-09-10 16:36:33 UTC
OpenStack gerrit 521358 None MERGED [manila] allow cephfs-nfs driver to store ganesha exports 2020-09-10 16:36:33 UTC
Red Hat Product Errata RHEA-2018:2086 normal SHIPPED_LIVE Red Hat OpenStack Platform 13.0 Enhancement Advisory 2018-06-28 19:51:39 UTC

Description Tom Barron 2017-07-10 16:16:48 UTC
Upstream Pike added the NFS ganesha Ceph driver in devstack and as tech preview in TripleO.  This RFE is to make all changes required to support the CephFS NFS back end in RHOSP product.

This will involve addressing at least the following limitations in the tech preview version:

* de-couple placement and scaling of data-plane nfs-ganesha gateways from
  placment and scaling of manila share service

* provide robust HA for nfs-ganesha gateway service since it is in the storage data path

* assure adequate isolation of tenants from one another and from the backend Ceph public network

* integrate fully with OSPd

Comment 1 Tom Barron 2017-07-10 16:17:17 UTC
*** Bug 1469196 has been marked as a duplicate of this bug. ***

Comment 4 Tom Barron 2017-12-06 16:25:13 UTC
(In reply to Tom Barron from comment #0)
> Upstream Pike added the NFS ganesha Ceph driver in devstack and as tech
> preview in TripleO.  This RFE is to make all changes required to support the
> CephFS NFS back end in RHOSP product.
> 
> This will involve addressing at least the following limitations in the tech
> preview version:
> 
> * de-couple placement and scaling of data-plane nfs-ganesha gateways from
>   placment and scaling of manila share service
> 
> * provide robust HA for nfs-ganesha gateway service since it is in the
> storage data path
> 
> * assure adequate isolation of tenants from one another and from the backend
> Ceph public network
> 
> * integrate fully with OSPd

Note that de-coupling and separate scaling are deferred to a later release but that the other requirements are still targeted.

Comment 5 Tom Barron 2017-12-06 16:26:03 UTC
510547 has merged upstream and we expect the merge of 521358 is imminent.

Comment 6 Tom Barron 2017-12-18 11:21:55 UTC
Both 510547 and 521358 have merged upstream, moving to POST

Comment 11 Tom Barron 2018-04-20 13:13:51 UTC
1568022 has been verified

Comment 12 Tom Barron 2018-05-15 14:24:45 UTC
1575023 was fixed in 2018-05-10.3 puddle so this one should now be verifiable.

Comment 13 Dustin Schoenbrun 2018-05-18 21:31:00 UTC
I was able to use Yogev's deployment to go through my Polarion test cases and all passed. Marking as verified.

Comment 18 errata-xmlrpc 2018-06-27 13:31:39 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.