Bug 1489938 - [RFE] Extend TripleO installation & configuration support of nfs-ganesha
Summary: [RFE] Extend TripleO installation & configuration support of nfs-ganesha
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Tom Barron
QA Contact: Yogev Rabl
Derek
URL:
Whiteboard:
: 1450164 (view as bug list)
Depends On: 1469208 1489934 1568022 1575023
Blocks: 1450164 1475544
TreeView+ depends on / blocked
 
Reported: 2017-09-08 17:53 UTC by jomurphy
Modified: 2018-06-27 13:37 UTC (History)
13 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.0-0.20180215092254.
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:36:16 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 471245 None None None 2018-03-27 16:28:03 UTC
OpenStack gerrit 512239 None master: MERGED tripleo-heat-templates: Add a StorageNFS network for use by Manila/Ganesha (If31722d669efe91082c93ecb815e6c41676480c8) 2018-02-21 14:20:44 UTC
OpenStack gerrit 512240 None master: MERGED tripleo-heat-templates: Pass storage nfs VIP to ceph-ansible (I3c0da46dd0f0252158c6065b7c122b8567c88bc0) 2018-02-21 14:20:33 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:37:03 UTC

Description jomurphy 2017-09-08 17:53:11 UTC
E​xtend tripleo templates and mistral workbooks to pass required nfs-ganesha params to ceph-ansible:
both input variables and inventory file for ceph-ansible needs to be updated to support nfs-ganesha service

Comment 9 Christian Schwede (cschwede) 2018-03-27 15:20:26 UTC
*** Bug 1450164 has been marked as a duplicate of this bug. ***

Comment 11 Yogev Rabl 2018-04-16 17:51:03 UTC
The deployment failed due to Bug 1568022

Comment 15 Yogev Rabl 2018-05-23 19:06:22 UTC
verified.

The deployment is successful and Manila is fully functional out of the box

Comment 17 errata-xmlrpc 2018-06-27 13:36:16 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.