Bug 1568368 - Wine fails to install on RHEL 7.5 due to updated libgphoto2
Summary: Wine fails to install on RHEL 7.5 due to updated libgphoto2
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora EPEL
Classification: Fedora
Component: wine
Version: epel7
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Andreas Bierfert
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1568468 1576946 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-17 11:17 UTC by Trond H. Amundsen
Modified: 2019-10-02 19:36 UTC (History)
9 users (show)

Fixed In Version: wine-3.0.1-1.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-15 20:47:30 UTC
Type: Bug


Attachments (Terms of Use)

Description Trond H. Amundsen 2018-04-17 11:17:46 UTC
Hi,

The wine packages need to be rebuilt for the upgraded libgphoto2 in RHEL 7.5:

Error: Package: wine-core-3.0-1.el7.x86_64 (epel)
           Requires: libgphoto2_port.so.10()(64bit)
           Available: libgphoto2-2.5.2-3.el7.x86_64 (rhel-7-workstation-rpms)
               libgphoto2_port.so.10()(64bit)
           Available: libgphoto2-2.5.2-5.el7.x86_64 (rhel-7-workstation-rpms)
               libgphoto2_port.so.10()(64bit)
           Installed: libgphoto2-2.5.15-1.el7.x86_64 (@rhel-7-workstation-rpms)
              ~libgphoto2_port.so.12()(64bit)
Error: Package: wine-core-3.0-1.el7.x86_64 (epel)
           Requires: libgphoto2_port.so.10(LIBGPHOTO2_5_0)(64bit)
           Available: libgphoto2-2.5.2-3.el7.x86_64 (rhel-7-workstation-rpms)
               libgphoto2_port.so.10(LIBGPHOTO2_5_0)(64bit)
           Available: libgphoto2-2.5.2-5.el7.x86_64 (rhel-7-workstation-rpms)
               libgphoto2_port.so.10(LIBGPHOTO2_5_0)(64bit)
           Installed: libgphoto2-2.5.15-1.el7.x86_64 (@rhel-7-workstation-rpms)
              ~libgphoto2_port.so.12(LIBGPHOTO2_5_0)(64bit)

A rebase to a more recent version of wine would also be appreciated :)

Version-Release number of selected component (if applicable):
wine-core-3.0-1.el7.x86_64

How reproducible:
Always

-trond

Comment 1 Michael Cronenworth 2018-04-17 15:05:15 UTC
*** Bug 1568468 has been marked as a duplicate of this bug. ***

Comment 2 Stuart Ritchings 2018-04-24 12:39:05 UTC
hi, I am also getting the same error, I need wine to get some of my programs running, thanks

Comment 3 David Rees 2018-05-04 05:54:07 UTC
On CentOS 7 this is keeping systems that have the CR repo enabled and wine previously installed from updating to the latest gvfs, libgphoto2 and sane-backends packages.

End up with the same error as trond reports above.

Comment 4 Michael Cronenworth 2018-05-10 19:40:55 UTC
*** Bug 1576946 has been marked as a duplicate of this bug. ***

Comment 5 Fedora Update System 2018-05-10 20:46:04 UTC
wine-3.0-2.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-2369adc937

Comment 6 Fedora Update System 2018-05-11 19:36:12 UTC
wine-3.0-2.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-2369adc937

Comment 7 Fedora Update System 2018-05-14 15:50:21 UTC
wine-3.0.1-1.el7 has been submitted as an update to Fedora EPEL 7. https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-2369adc937

Comment 8 Fedora Update System 2018-05-14 19:32:05 UTC
wine-3.0.1-1.el7 has been pushed to the Fedora EPEL 7 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-EPEL-2018-2369adc937

Comment 9 Fedora Update System 2018-05-15 20:47:30 UTC
wine-3.0.1-1.el7 has been pushed to the Fedora EPEL 7 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Joshua Hartman 2019-10-02 18:10:55 UTC
This still seems to be happening even in newer releases.

$ sudo yum install wine
Loaded plugins: langpacks, product-id, rhnplugin, search-disabled-repos, subscription-manager
This system is receiving updates from RHN Classic or Red Hat Satellite.
Resolving Dependencies
--> Running transaction check
---> Package wine.x86_64 0:3.0.2-1.el7 will be installed

....

--> Finished Dependency Resolution
Error: Package: wine-core-3.0.2-1.el7.x86_64 (corp-epel7-r03)
           Requires: libgphoto2_port.so.12()(64bit)
Error: Package: wine-core-3.0.2-1.el7.x86_64 (corp-epel7-r03)
           Requires: libgphoto2_port.so.12(LIBGPHOTO2_5_0)(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Comment 11 Michael Cronenworth 2019-10-02 19:36:36 UTC
You're installing wine from a third party repo source. We only support EPEL here.


Note You need to log in before you can comment on or make changes to this bug.