This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 15706 - wrong keymap written to sysconfig/keyboard - related to using deadkeys?
wrong keymap written to sysconfig/keyboard - related to using deadkeys?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Brock Organ
Brock Organ
Winston rc1
:
: 18385 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-08 04:10 EDT by Michael Redinger
Modified: 2007-03-26 23:34 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-09 15:14:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Redinger 2000-08-08 04:10:15 EDT
When choosing the keymap "de-latin1-nodeadkeys" during (graphical)
installation, the keymap "de" is written to /etc/sysconfig/keyboard.
Running kbdconfig after installation and selecting de-latin1-nodeadkeys
does write the proper keyboard mapping to the config file.
Comment 1 Glen Foster 2000-08-08 11:03:05 EDT
This defect is considered MUST-FIX for Winston Release-Candidate #1
Comment 2 Erik Troan 2000-08-08 12:38:11 EDT
Fixed in RC1. Thanks for noticing this one.
Comment 3 Michael Redinger 2000-08-12 14:23:01 EDT
Sorry, wrong again. This time it becomes de-latin1 instead of
de-latin1-nodeadkeays.
Please, do check this before final release. Seems to be a common point of
mistake ...

I think I can do this myself, saving Glen some keystrokes ... ;)

This defect is considered MUST-FIX for Winston Gold.
Comment 4 Erik Troan 2000-08-15 12:54:59 EDT
I can't reproduce this. I've tried de, de-latin1, and de-latin1-nodeadkeys and
it seems to work perfectly.
Comment 5 borgia 2000-08-18 02:06:28 EDT
Chose it and got it-ibm both on upgrade 6.2->RC1 and on install RC1
Comment 6 Preston Brown 2000-08-21 10:21:53 EDT
*** Bug 16678 has been marked as a duplicate of this bug. ***
Comment 7 Matt Wilson 2000-08-21 10:57:52 EDT
What kind of install is this?  NFS?  CD-ROM?  Did you do keyboard selection from
the text part of the install?  Or GUI?
Comment 8 Michael Redinger 2000-08-22 04:38:57 EDT
Still there in RC2. GUI CD Installation. 102 PC keyboard - german - disable dead
keys.
(text NFS installation to follow today.)

Comment 9 Erik Troan 2000-08-22 09:40:10 EDT
Are you selecting the keymap in a text window or a GUI one?
Comment 10 Michael Redinger 2000-08-22 11:06:42 EDT
*dazed and confused*
Hm, above I wrote that it's a GUI install. Don't really understand that question
as I think this has already been answered. *dazed and confused*

Text CD install works, de-latin1-nodeadkeys is configured as desired.
Comment 11 Erik Troan 2000-08-22 15:54:45 EDT
Where are you picking the keyboard it doesn't work? X-Windows or not? If in X,
what
keyboard are you choosing? If not, what keyboard are you choosing? Do you ever
ask answer any installations questions in X?

I know this is a long list :-(
Comment 12 Erik Troan 2000-08-22 16:01:58 EDT
Ahh, the problem is when you pick de and activate dead keys in GUI that the
wrong keymap is selected in text. Matt's problem :-)
Comment 13 Brock Organ 2000-08-22 16:06:29 EDT
GUI CDROM install; select "German" keyboard and choose "Activaeren dead-keys"
(sic), post install the /etc/sysconfig/keyboard looks like:

KEYBOARDTYPE="pc"
KEYTABLE="de-latin1"

instead of having:

KEYTABLE="de-latin1nodeadkeys"

Comment 14 Matt Wilson 2000-08-22 16:10:55 EDT
Fixing this problem would require a good bit of extra code -- it would
completely revamp the mapping of X keymaps back to kernel keymaps.  Remind me
next release.
Comment 15 Michael Redinger 2000-08-22 17:12:18 EDT
Does this mean that those with a german keyboard have to accept that dead keys
are active even if they choose nodeadkeys? Well, I have to accept this, but this
is a _major_ bug. Using german keyboards this is _very_ annoying (well, I'm
using an english SGI keyboard, so no problem with me ... ). Hm, if I remember
correctly this problem was not present in RHAT 6.2. So I wonder why a major
rewrite is necessary now (again, it doesn't affect me - not even my users as my
kickstart disks can easily catch this problem).

(And yes, I will definitely remind you ... :) ).

Comment 16 Matt Wilson 2000-08-22 17:29:41 EDT
I can't see how this problem didn't exist in 6.2
Comment 17 Brent Fox 2000-12-05 12:00:05 EST
This is fixed in CVS.  That is, selecting a German keyboard with dead keys
disabled now generates a correct /etc/sysconfig/keyboard file.  However, there
is a related bug, 16678, that has the following attributes:  In text mode,
selecting de-latin1-nodeadkeys generates a correct /etc/sysconfig/keyboard file
but an incorrect XF86Config file.
Comment 18 Brock Organ 2000-12-11 14:17:23 EST
using qa1211.0 test tree:

verified /etc/sysconfig/keyboard contents:

GUI install, stage1 TUI keyboard selection:

KEYBOARDTYPE="pc"
KEYTABLE="de-latin1-nodeadkeys"

GUI install, stage1 GUI keyboard selection:

post-install traceback:

Traceback (innermost last):
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/iw/progress_gui.py", line 19, in
run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1693, in
doInstall
    self.x.write (self.instPath + "/etc/X11")
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/xf86config.py", line 959, in
write
    config4 = self.Version4Config ()
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/xf86config.py", line 1241, in
Version4Config
    info["enableVariant"] = ""
NameError: info

Comment 19 Brock Organ 2000-12-11 14:42:19 EST
*** Bug 18385 has been marked as a duplicate of this bug. ***
Comment 20 Brock Organ 2000-12-11 14:46:33 EST
note that the traceback above holds up this issue being fixed, as post-install
the /etc/sysconfig/keyboard values are:

KEYBOARDTYPE="pc"
KEYTABLE="de-latin1-nodeadkeys"

Comment 21 Brent Fox 2000-12-15 01:44:37 EST
So Brock, should this bug be closed now or what?

Note You need to log in before you can comment on or make changes to this bug.