Bug 16678 - deadkeys setting ignored in X configuration
deadkeys setting ignored in X configuration
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-21 10:16 EDT by Bernhard Rosenkraenzer
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-01-03 16:34:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernhard Rosenkraenzer 2000-08-21 10:16:17 EDT
X configuration in anaconda ignores the deadkeys setting.
Chosing, for example, de-latin1-nodeadkeys gives me a German keyboard
layout without deadkeys (ok) on the console, and a German keyboard layout
WITH deadkeys in X (broken).

For XF3.3.6, the line that should get added is
	XkbVariant "nodeadkeys"
For XF4.0, it's 
	Option "XkbVariant" "nodeadkeys"
Comment 1 Preston Brown 2000-08-21 10:22:48 EDT

*** This bug has been marked as a duplicate of 15706 ***
Comment 2 Harald Hoyer 2000-08-23 09:04:37 EDT
This is not a duplicate, cause it refers to the generated /etc/X11/XF86Config's.
So at the installer I choose nodeadkeys and after installing and rebooting I
have deadkeys in X. That is not what the user expected. A very simple and
trivial change to the installer, so that the user doesn't have to modify
/etc/X11/XF86Config himselves.
Comment 3 Michael Fulbright 2000-10-05 12:20:48 EDT
Related to bug 18385.
Comment 4 Daniel Roesen 2000-11-29 17:21:56 EST
Same bug is present in Red Hat 6.2
Comment 5 Brock Organ 2000-12-11 15:08:37 EST
tested in internal tree (qa1211.0):

For XF3.3.6, the line added is
# XkbVariant "nodeadkeys"
For XF4.0, it's 
# Option "XkbVariant" "nodeadkeys"

and they are both commented out ... so the problem is not resolved ...
Comment 6 Brent Fox 2000-12-19 11:54:21 EST
This is currently fixed if you select German keyboard and disable deadkeys in
the graphcial installer.  But, I suspect that there is a problem when booting
off a floppy.  That is, I don't think the loader passes on the keyboard info
properly to the second stage installer.
Comment 7 Brent Fox 2001-01-02 17:06:41 EST
As long as you do a cd-based install, this problem doesn't exist.  After more
tests, I've found that the problem only occurs if you boot off a floppy because
the loader isn't passing the deadkey information to the second stage.
Comment 8 Brent Fox 2001-01-03 16:33:58 EST
I have changed the way the keyboard data structure works so that information on
the XkbVariant can be stored.  Selecting de-latin1-nodeadkeys in the first stage
installer now results in the XkbVariant "nodeadkeys" being written to the
XFree86Config file.

Brock, please verify.  I've got a German keyboard if you want to borrow it.
Comment 9 Brock Organ 2001-01-08 13:26:32 EST
verified fix in qa0108.0 ...

Note You need to log in before you can comment on or make changes to this bug.