Bug 1571901 - [UPGRADES] ceph upgrade failed - Invalid input [name=package_update_plan, class=DirectWorkflowSpec, missing=['container_registry']]
Summary: [UPGRADES] ceph upgrade failed - Invalid input [name=package_update_plan, cla...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-tripleoclient
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 13.0 (Queens)
Assignee: Giulio Fidente
QA Contact: Marius Cornea
URL:
Whiteboard:
Depends On:
Blocks: 1414977 1561169 1574424
TreeView+ depends on / blocked
 
Reported: 2018-04-25 16:07 UTC by Chris Janiszewski
Modified: 2018-06-27 13:55 UTC (History)
8 users (show)

Fixed In Version: python-tripleoclient-9.2.1-6.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:53:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1768586 None None None 2018-05-07 20:57:53 UTC
OpenStack gerrit 566050 None master: MERGED python-tripleoclient: Stop trying to converge during Ceph upgrade command (I025eac40f8bda5f23c789e7fef1a9e9b49947f66) 2018-05-09 10:36:29 UTC
OpenStack gerrit 566944 None stable/queens: MERGED python-tripleoclient: Stop trying to converge during Ceph upgrade command (I025eac40f8bda5f23c789e7fef1a9e9b49947f66) 2018-05-09 10:36:23 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:55:00 UTC

Description Chris Janiszewski 2018-04-25 16:07:36 UTC
Description of problem:
Completed OSP10 -> OSP13 upgrade and verified it's functionality (without upgrading ceph)

Upgrading ceph fails with:
Invalid input [name=package_update_plan, class=DirectWorkflowSpec, missing=['container_registry']]

It looks like Openstack overcloud ceph-upgrade run .. need mechanism for running container parameter

Version-Release number of selected component (if applicable):
OSP10 -> OSP13

How reproducible:
every time

Steps to Reproduce:
1. Deploy RH OSP10
2. FFU to OSP13
3. run command to upgrade ceph
Example command from my env:
time openstack overcloud ceph-upgrade run --templates --stack chrisj-ffu \
     --ntp-server 10.9.71.7   --log-file overcloud_deployment.log \
     -e /home/stack/templates/overcloud_images.yaml \
     -e templates/network-environment.yaml \
     -e templates/node-info.yaml \
     -e templates/ceph-custom-config.yaml \
     -e /usr/share/openstack-tripleo-heat-templates/environments/network-isolation.yaml \
     -e /usr/share/openstack-tripleo-heat-templates/environments/ceph-ansible/ceph-ansible.yaml \
     -e templates/ffu_repos.yaml \
     -e /usr/share/openstack-tripleo-heat-templates/environments/hyperconverged-ceph.yaml \
     -e /usr/share/openstack-tripleo-heat-templates/environments/updates/update-from-ceph-newton.yaml



Actual results:
 Invalid input [name=package_update_plan, class=DirectWorkflowSpec, missing=['container_registry']]

Expected results:
Ceph upgraded to 3.X

Additional info:

Comment 7 errata-xmlrpc 2018-06-27 13:53:37 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.