Bug 1574424 - [UPGRADES] After upgrading an environment with Ceph the controller nodes are missing the ceph-mgr firewall rules
Summary: [UPGRADES] After upgrading an environment with Ceph the controller nodes are ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-heat-templates
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: 13.0 (Queens)
Assignee: Giulio Fidente
QA Contact: Yurii Prokulevych
URL:
Whiteboard:
: 1572533 (view as bug list)
Depends On: 1571901
Blocks: 1414977 1561169
TreeView+ depends on / blocked
 
Reported: 2018-05-03 09:34 UTC by Giulio Fidente
Modified: 2018-06-27 13:56 UTC (History)
6 users (show)

Fixed In Version: openstack-tripleo-heat-templates-8.0.2-16.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:55:29 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Launchpad 1767318 None None None 2018-05-03 09:34:36 UTC
OpenStack gerrit 564686 None master: MERGED tripleo-heat-templates: Ensure config-download mappings are unset on ceph-upgrade (I52312ffcd438c354872ab3c74138b47ae71a... 2018-05-09 14:14:58 UTC
OpenStack gerrit 566019 None stable/queens: MERGED tripleo-heat-templates: Ensure config-download mappings are unset on ceph-upgrade (I52312ffcd438c354872ab3c74138b47ae71a... 2018-05-09 14:14:53 UTC
OpenStack gerrit 566051 None master: NEW tripleo-heat-templates: Set normal CephAnsiblePlaybook on update/upgrade/ffwd converge (If596531cbb1e750ed67e66391743f4c... 2018-05-09 14:14:47 UTC
OpenStack gerrit 567275 None None None 2018-05-09 16:07:45 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:56:49 UTC

Description Giulio Fidente 2018-05-03 09:34:37 UTC
After running an upgade (or FFU) with Ceph, the firewall rules for CephMgr are not configured on the nodes.

It seems that the DeploySteps resources were disabled and prevented puppet from running when it should not have.

Comment 1 Giulio Fidente 2018-05-08 11:06:06 UTC
*** Bug 1572533 has been marked as a duplicate of this bug. ***

Comment 6 Yogev Rabl 2018-05-16 13:59:32 UTC
verified on openstack-tripleo-heat-templates-8.0.2-17.el7ost.noarch

Comment 8 errata-xmlrpc 2018-06-27 13:55:29 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.