Bug 1573966 - libidn POSTIN error during automated install
Summary: libidn POSTIN error during automated install
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libidn
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 15:31 UTC by Giovanni Tirloni
Modified: 2018-05-22 15:06 UTC (History)
16 users (show)

Fixed In Version: libidn-1.34-3.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-22 15:06:13 UTC
Type: Bug


Attachments (Terms of Use)
kickstart (3.19 KB, text/plain)
2018-05-02 15:31 UTC, Giovanni Tirloni
no flags Details
Logs from /tmp (324.55 KB, application/x-gzip)
2018-05-03 16:15 UTC, Giovanni Tirloni
no flags Details
/tmp/*.log (93.97 KB, application/zip)
2018-05-08 14:14 UTC, Peter Janes
no flags Details

Description Giovanni Tirloni 2018-05-02 15:31:33 UTC
Created attachment 1430133 [details]
kickstart

Description of problem:
Anaconda installer exits with error following this message:

--
The following error occurred while installing. This is a fatal error and
installation will be aborted.

DNF error: Non-fatal POSTIN scriptlet failure in rpm package libidn

Press ENTER to exit: Failed to preset unit, unit cups.socket does not exist.
--


Version-Release number of selected component (if applicable):
libidn-1.34-1.fc28

How reproducible:
Always

Steps to Reproduce:
1. Start automated install using the attached kickstart file

Additional info:
kickstart worked fine with Fedora 27

Comment 1 Miroslav Lichvar 2018-05-02 15:56:14 UTC
The libidn's postin scriptlet just calls install-info and ldconfig.

DNS says the libidn error is not fatal, so I suspect this is probably related to the cups error.

Comment 2 Zdenek Dohnal 2018-05-03 06:44:01 UTC
$ rpm -ql cups | grep cups.socket
/usr/lib/systemd/system/cups.socket

cups.socket is correctly in cups-2.2.6-14.fc28 rpm. I suspect the error is in anaconda.

Comment 3 Vendula Poncova 2018-05-03 10:17:03 UTC
Please, attach all files /tmp/*log with anaconda logs.

Comment 4 Giovanni Tirloni 2018-05-03 16:15:42 UTC
Created attachment 1430778 [details]
Logs from /tmp

Comment 5 Giovanni Tirloni 2018-05-03 18:12:32 UTC
I explicitly excluded "libidn" (in the %packages section) and now the installation finished successfully. 

```
%packages --excludedocs
@core
@base-x
@fonts
@multimedia
@hardware-support
@workstation-product
@gnome-desktop
-libidn
%end
```

Added it back in and the error is back. I agree the postin scriptlet seems simple enough so maybe it's something else.

Comment 6 Peter Janes 2018-05-08 14:13:44 UTC
I'm definitely seeing this only in libidn itself.  The graphical installer shows a window with this:

The following error occurred while installing.  This is a fatal error and installation will be aborted.

DNF error: Non-fatal POSTIN scriptlet failure in rpm package libidn

[Exit Installer]

Comment 7 Peter Janes 2018-05-08 14:14:38 UTC
Created attachment 1433234 [details]
/tmp/*.log

Comment 8 Vendula Poncova 2018-05-14 10:47:04 UTC
The reported DNF error is fatal (see https://bugzilla.redhat.com/show_bug.cgi?id=1565123). Reassigning back to libidn.

Comment 9 Miroslav Lichvar 2018-05-14 11:06:43 UTC
Can you please try it with libidn-1.34-2.fc28 fixed for bug #1573961?

https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

I guess ldconfig could be failing due to the symbols having unexpected sizes. However, I'd expect it to at least print an error message.

Comment 10 Peter Janes 2018-05-14 16:12:26 UTC
Command-line and graphical installer both fail with "DNF error: Non-fatal POSTIN scriptlet failure in rpm package libidn".  However, if I go into a console in the graphical installer it seems to have installed successfully.

# rpm -ivh /run/install/repo/Packages/libidn-1.34-2.fc28.x86_64.rpm --root /mnt/sysimage
Preparing...
        package libidn-1.34-2.fc28.x86_64 is already installed

Comment 11 Peter Janes 2018-05-14 16:18:12 UTC
I have %packages configured with --instLangs=en,en_US,en-US, and /usr/share/info/libidn.info.gz doesn't exist. I see that the original reporter has --excludedocs, so I'd guess the info file doesn't exist in his instance either.

Comment 12 Miroslav Lichvar 2018-05-14 16:34:08 UTC
Thanks for the hints.

I think you are right that it's an issue with the info files and not ldconfig. The %ldconfig macro does nothing on F28. install-info is the last command of the scriptlet and if that fails, the scriptlet will fail too.

Comment 13 Giovanni Tirloni 2018-05-14 16:50:07 UTC
Confirmed installing without "--excludedocs" works here.

Comment 14 Fedora Update System 2018-05-15 13:57:59 UTC
ghostscript-9.23-4.fc28 libidn-1.34-3.fc28 mcabber-1.1.0-1.fc28.1 pidgin-2.13.0-1.fc28.1 python-slixmpp-1.3.0-5.fc28.1 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 15 Fedora Update System 2018-05-15 13:58:29 UTC
ghostscript-9.23-4.fc28 libidn-1.34-3.fc28 mcabber-1.1.0-1.fc28.1 pidgin-2.13.0-1.fc28.1 python-slixmpp-1.3.0-5.fc28.1 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 16 Peter Janes 2018-05-15 15:04:18 UTC
Looks good here.

Comment 17 Fedora Update System 2018-05-15 23:02:24 UTC
ghostscript-9.23-4.fc28, libidn-1.34-3.fc28, mcabber-1.1.0-1.fc28.1, pidgin-2.13.0-1.fc28.1, python-slixmpp-1.3.0-5.fc28.1 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-aae2d44488

Comment 18 Giovanni Tirloni 2018-05-16 16:15:10 UTC
Looks good here too. Kickstart install is able to finish successfully with "--excludedocs". Thank you!

Comment 19 Fedora Update System 2018-05-22 15:06:13 UTC
ghostscript-9.23-4.fc28, libidn-1.34-3.fc28, mcabber-1.1.0-1.fc28.1, pidgin-2.13.0-1.fc28.1, python-slixmpp-1.3.0-5.fc28.1 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.