Bug 1575546 - [3.10]openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request don't take effect
Summary: [3.10]openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrout...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 3.10.z
Assignee: Jeff Cantrill
QA Contact: Qiaoling Tang
URL:
Whiteboard:
Depends On:
Blocks: 1592551
TreeView+ depends on / blocked
 
Reported: 2018-05-07 09:16 UTC by Junqi Zhao
Modified: 2018-08-31 06:18 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Installer was creating an incorrect spec attribute for cpu and memory. Additionally, it did not allow modifying the cpu_limit Consequence: The values were ignored Fix: Conditionally patch in cpu_limit if it s defined and correct the attribute name used to specify cpu/mem requests Result: The values are honored as expected
Clone Of:
: 1575547 1592551 (view as bug list)
Environment:
Last Closed: 2018-08-31 06:18:10 UTC


Attachments (Terms of Use)
there are not resources.limits.cpu, and resources.requests.cpu in pod spec (3.47 KB, text/plain)
2018-05-07 09:16 UTC, Junqi Zhao
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2376 None None None 2018-08-31 06:18:58 UTC
Github openshift openshift-ansible pull 8762 None None None 2018-06-14 14:17:08 UTC
Github openshift openshift-ansible pull 8836 None None None 2018-06-18 19:51:43 UTC

Description Junqi Zhao 2018-05-07 09:16:39 UTC
Created attachment 1432536 [details]
there are not resources.limits.cpu, and resources.requests.cpu in pod spec

Description of problem:
Set openshift_logging_eventrouter_cpu_limit=150m and openshift_logging_eventrouter_cpu_request=150m, they don't take effect.
there are not resources.limits.cpu, and resources.requests.cpu in pod spec

spec:
  containers:
  - image: brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/logging-eventrouter:v3.10
    imagePullPolicy: IfNotPresent
    name: kube-eventrouter
    resources:
      limits:
        memory: 128Mi
      requests:
        memory: 128Mi



Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-roles-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-playbooks-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-docs-3.10.0-0.33.0.git.0.0aa585e.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy logging with eventrouter, set openshift_logging_eventrouter_cpu_limit=150m and openshift_logging_eventrouter_cpu_request=150m inventory
2.
3.

Actual results:
openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request don't take effect

Expected results:
openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request take effect

Additional info:
openshift_logging_install_logging=true
openshift_logging_image_prefix=${IMAGE_PREFIX}
openshift_logging_image_version=v3.10
openshift_logging_elasticsearch_cpu_limit=500m
openshift_logging_elasticsearch_memory_limit=1Gi
openshift_logging_install_eventrouter=true
openshift_logging_eventrouter_cpu_limit=150m
openshift_logging_eventrouter_cpu_request=150m

Comment 1 Jeff Cantrill 2018-06-14 14:17:09 UTC
Note this PR fixes cpu request but not limit.  There is a var for cpu limit but it is not utilized.  Removing from defaults

https://github.com/openshift/openshift-ansible/pull/8762

Comment 2 openshift-github-bot 2018-06-18 19:43:47 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/eb9bcff836c03aa2846ca3b7bb5eed4f28ea784a
bug 1575546. Fix logging eventrouter cpu requests

https://github.com/openshift/openshift-ansible/commit/1ea9384857ed3ec940f27fbf6a52f8ce1b44545d
Merge pull request #8762 from jcantrill/1575546_eventrouter_cpu

bug 1575546. Fix logging eventrouter cpu requests

Comment 3 Jeff Cantrill 2018-06-18 19:51:43 UTC
3.10 - https://github.com/openshift/openshift-ansible/pull/8836

Comment 5 Junqi Zhao 2018-08-23 06:03:30 UTC
Issue is fixed in openshift-ansible-3.10.34-1.git.0.48df172None
openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request take effect now, for example:
    resources:
      limits:
        cpu: 150m
        memory: 128Mi
      requests:
        cpu: 150m
        memory: 128Mi

Comment 7 errata-xmlrpc 2018-08-31 06:18:10 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2376


Note You need to log in before you can comment on or make changes to this bug.