Bug 1575547 - [3.9]openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request don't take effect
Summary: [3.9]openshift_logging_eventrouter_cpu_limit and openshift_logging_eventroute...
Keywords:
Status: CLOSED DUPLICATE of bug 1592551
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 3.9.z
Assignee: Jeff Cantrill
QA Contact: Anping Li
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-07 09:17 UTC by Junqi Zhao
Modified: 2018-07-11 08:43 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1575546
Environment:
Last Closed: 2018-07-11 08:43:50 UTC


Attachments (Terms of Use)

Description Junqi Zhao 2018-05-07 09:17:32 UTC
+++ This bug was initially created as a clone of Bug #1575546 +++

Description of problem:
Set openshift_logging_eventrouter_cpu_limit=150m and openshift_logging_eventrouter_cpu_request=150m, they don't take effect.
there are not resources.limits.cpu, and resources.requests.cpu in pod spec

spec:
  containers:
  - image: brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/logging-eventrouter:v3.10
    imagePullPolicy: IfNotPresent
    name: kube-eventrouter
    resources:
      limits:
        memory: 128Mi
      requests:
        memory: 128Mi



Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-roles-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-playbooks-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-docs-3.10.0-0.33.0.git.0.0aa585e.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy logging with eventrouter, set openshift_logging_eventrouter_cpu_limit=150m and openshift_logging_eventrouter_cpu_request=150m inventory
2.
3.

Actual results:
openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request don't take effect

Expected results:
openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request take effect

Additional info:
openshift_logging_install_logging=true
openshift_logging_image_prefix=${IMAGE_PREFIX}
openshift_logging_image_version=v3.10
openshift_logging_elasticsearch_cpu_limit=500m
openshift_logging_elasticsearch_memory_limit=1Gi
openshift_logging_install_eventrouter=true
openshift_logging_eventrouter_cpu_limit=150m
openshift_logging_eventrouter_cpu_request=150m

Comment 1 Junqi Zhao 2018-07-11 08:43:50 UTC

*** This bug has been marked as a duplicate of bug 1592551 ***


Note You need to log in before you can comment on or make changes to this bug.