Bug 1592551 - [3.9]openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request don't take effect
Summary: [3.9]openshift_logging_eventrouter_cpu_limit and openshift_logging_eventroute...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: ---
: 3.9.z
Assignee: Jeff Cantrill
QA Contact: Junqi Zhao
URL:
Whiteboard:
: 1575547 (view as bug list)
Depends On: 1575546
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-06-18 19:53 UTC by Jeff Cantrill
Modified: 2018-07-18 09:19 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Installer was creating an incorrect spec attribute for cpu and memory. Additionally, it did not allow modifying the cpu_limit Consequence: The values were ignored Fix: Conditionally patch in cpu_limit if it s defined and correct the attribute name used to specify cpu/mem requests Result: The values are honored as expected
Clone Of: 1575546
Environment:
Last Closed: 2018-07-18 09:18:59 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:2213 None None None 2018-07-18 09:19:11 UTC
Github openshift openshift-ansible pull 8762 None None None 2018-06-18 19:53:55 UTC
Github openshift openshift-ansible pull 8836 None None None 2018-06-18 19:53:55 UTC
Github openshift openshift-ansible pull 8837 None None None 2018-06-18 19:54:55 UTC

Description Jeff Cantrill 2018-06-18 19:53:55 UTC
+++ This bug was initially created as a clone of Bug #1575546 +++

Description of problem:
Set openshift_logging_eventrouter_cpu_limit=150m and openshift_logging_eventrouter_cpu_request=150m, they don't take effect.
there are not resources.limits.cpu, and resources.requests.cpu in pod spec

spec:
  containers:
  - image: brew-pulp-docker01.web.prod.ext.phx2.redhat.com:8888/openshift3/logging-eventrouter:v3.10
    imagePullPolicy: IfNotPresent
    name: kube-eventrouter
    resources:
      limits:
        memory: 128Mi
      requests:
        memory: 128Mi



Version-Release number of selected component (if applicable):
# rpm -qa | grep openshift-ansible
openshift-ansible-roles-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-playbooks-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-3.10.0-0.33.0.git.0.0aa585e.el7.noarch
openshift-ansible-docs-3.10.0-0.33.0.git.0.0aa585e.el7.noarch


How reproducible:
Always

Steps to Reproduce:
1. Deploy logging with eventrouter, set openshift_logging_eventrouter_cpu_limit=150m and openshift_logging_eventrouter_cpu_request=150m inventory
2.
3.

Actual results:
openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request don't take effect

Expected results:
openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request take effect

Additional info:
openshift_logging_install_logging=true
openshift_logging_image_prefix=${IMAGE_PREFIX}
openshift_logging_image_version=v3.10
openshift_logging_elasticsearch_cpu_limit=500m
openshift_logging_elasticsearch_memory_limit=1Gi
openshift_logging_install_eventrouter=true
openshift_logging_eventrouter_cpu_limit=150m
openshift_logging_eventrouter_cpu_request=150m

--- Additional comment from Jeff Cantrill on 2018-06-14 10:17:09 EDT ---

Note this PR fixes cpu request but not limit.  There is a var for cpu limit but it is not utilized.  Removing from defaults

https://github.com/openshift/openshift-ansible/pull/8762

--- Additional comment from openshift-github-bot on 2018-06-18 15:43:47 EDT ---

Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/eb9bcff836c03aa2846ca3b7bb5eed4f28ea784a
bug 1575546. Fix logging eventrouter cpu requests

https://github.com/openshift/openshift-ansible/commit/1ea9384857ed3ec940f27fbf6a52f8ce1b44545d
Merge pull request #8762 from jcantrill/1575546_eventrouter_cpu

bug 1575546. Fix logging eventrouter cpu requests

--- Additional comment from Jeff Cantrill on 2018-06-18 15:51:43 EDT ---

3.10 - https://github.com/openshift/openshift-ansible/pull/8836

Comment 1 Jeff Cantrill 2018-06-18 19:54:56 UTC
3.9 https://github.com/openshift/openshift-ansible/pull/8837

Comment 3 Junqi Zhao 2018-06-28 02:19:31 UTC
Change back to POST,need new openshift-ansible package, the currently latest package is openshift-ansible-3.9.31-1, the fix is not contained in this packages

Comment 4 Junqi Zhao 2018-07-11 05:29:57 UTC
Please change to ON_QA, issue is fixed, openshift_logging_eventrouter_cpu_limit and openshift_logging_eventrouter_cpu_request take effect now.

eg:
    resources:
      limits:
        cpu: 350m
        memory: 128Mi
      requests:
        cpu: 150m
        memory: 128Mi

# rpm -qa | grep openshift-ansible
openshift-ansible-docs-3.9.33-1.git.56.19ba16e.el7.noarch
openshift-ansible-playbooks-3.9.33-1.git.56.19ba16e.el7.noarch
openshift-ansible-3.9.33-1.git.56.19ba16e.el7.noarch
openshift-ansible-roles-3.9.33-1.git.56.19ba16e.el7.noarch

Comment 5 Junqi Zhao 2018-07-11 08:43:50 UTC
*** Bug 1575547 has been marked as a duplicate of this bug. ***

Comment 6 Junqi Zhao 2018-07-12 00:47:13 UTC
Set it to VERIFIED based on Comment 4

Comment 8 errata-xmlrpc 2018-07-18 09:18:59 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2213


Note You need to log in before you can comment on or make changes to this bug.