Bug 157871 - iiimf candidate window and hotmenu placed at top-left
iiimf candidate window and hotmenu placed at top-left
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: iiimf-le-xcin (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caius Chance
:
: 158507 158508 (view as bug list)
Depends On: 135501
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-16 12:22 EDT by Jens Petersen
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-09-05 16:04:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jens Petersen 2005-05-16 12:22:58 EDT
+++ This bug was initially created as a clone of Bug #135501 +++

Description of problem:
It has been observed that when using IIIMF in mozilla, the candidate
window will always be position at 0,0. In addition, it is not possible
to move the window elsewhere using mouse click.

This bugs affects all LE with candidate window option and hotkey menu

Version-Release number of selected component (if applicable):
- im-sdk-12.0.1-13.svn1943
- mozilla-1.7.3-11

How reproducible:
Always

Steps to Reproduce:
1.in gdm login as normal user with simplified chinese / gnome session
2.after run gnome, press alt-f2 to run dialog, enter epiphany
3.in the browser, goto URL, http:www.google.com
4.in the Search Text Box, activate LE
5.enter hong

OR
1.in gdm login as normal user with simplified chinese / gnome session
2.after run gnome, press alt-f2 to run dialog, enter epiphany
3.in the browser, goto URL, http:www.google.com
4.ctrl-shift-space to acticate hotkey menu  

Actual results:
Both the candidate window and hotkey menu are displayed in the 0,0
position.

Expected results:
Should follow the cursor position and allow user to move the menu around.

Additional info:
Please see attached screenshot for more detail.
Comment 1 Lawrence Lim 2005-05-23 01:36:22 EDT
Chris, 
Could you make the fix available for EL4 as well?


Thanks
Comment 12 Jens Petersen 2005-11-06 04:37:59 EST
Yes this seems already fixed in RHEL4U2.
Comment 13 Lawrence Lim 2005-11-17 23:49:17 EST
Confirmed fix for all LE except xcin LE in firefox, is it because xcin is using
non-customise window so it is hardcoded to 0,0 position?
Comment 16 Leon Ho 2006-07-13 02:02:04 EDT
*** Bug 158507 has been marked as a duplicate of this bug. ***
Comment 17 Leon Ho 2006-07-13 02:02:14 EDT
*** Bug 158508 has been marked as a duplicate of this bug. ***
Comment 20 RHEL Product and Program Management 2006-09-05 15:53:20 EDT
The component this request has been filed against is not planned for inclusion
in the next update. The decision is based on weighting the priority and number
of requests for a component as well as the impact on the Red Hat Enterprise
Linux user-base: other components are considered having higher priority and the
number of changes we intend to include in update cycles is limited.
Comment 21 RHEL Product and Program Management 2006-09-05 16:04:34 EDT
Product Management has reviewed and declined this request.  You may appeal this
decision by reopening this request. 

Note You need to log in before you can comment on or make changes to this bug.