Due to a recent update on Javascript code a full page refresh on your browser might be needed.
Bug 1581860 - [3.9] Limit ranges are being applied with cpu-cfs-quota set to false
Summary: [3.9] Limit ranges are being applied with cpu-cfs-quota set to false
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.7.0
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.9.z
Assignee: Seth Jennings
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On: 1581409 1581861 1581862 1581863 1582486 1582487
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-23 19:40 UTC by Seth Jennings
Modified: 2018-06-06 15:46 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixes an issue where cfs_quota might still be set on a pod even when cpu-cfs-quota is set to false on the node
Clone Of: 1581409
Environment:
Last Closed: 2018-06-06 15:46:21 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1796 None None None 2018-06-06 15:46:42 UTC

Comment 3 weiwei jiang 2018-05-30 07:01:20 UTC
Checked with 
# oc version 
oc v3.9.30
kubernetes v1.9.1+a0ce1bc657
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://ip-172-18-3-197.ec2.internal:8443
openshift v3.9.30
kubernetes v1.9.1+a0ce1bc657

And can not reproduce this issue 

# cat /sys/fs/cgroup/cpu/kubepods.slice/kubepods-*.slice/kubepods*/cpu.cfs_quota_us
-1
-1
-1
-1
-1
-1
-1
-1
-1
-1
-1
-1
-1
-1
-1
-1
-1

Comment 5 errata-xmlrpc 2018-06-06 15:46:21 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1796


Note You need to log in before you can comment on or make changes to this bug.