Bug 1581862 - [3.7] Limit ranges are being applied with cpu-cfs-quota set to false
Summary: [3.7] Limit ranges are being applied with cpu-cfs-quota set to false
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Node
Version: 3.7.0
Hardware: Unspecified
OS: Linux
unspecified
urgent
Target Milestone: ---
: 3.7.z
Assignee: Seth Jennings
QA Contact: DeShuai Ma
URL:
Whiteboard:
: 1582486 (view as bug list)
Depends On: 1581409 1581863 1582486 1582487
Blocks: 1581860 1581861
TreeView+ depends on / blocked
 
Reported: 2018-05-23 19:41 UTC by Seth Jennings
Modified: 2018-06-07 08:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Fixes an issue where cfs_quota might still be set on a pod even when cpu-cfs-quota is set to false on the node
Clone Of: 1581409
Environment:
Last Closed: 2018-06-07 08:40:56 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1798 None None None 2018-06-07 08:41:31 UTC

Comment 2 Seth Jennings 2018-05-25 15:02:36 UTC
*** Bug 1582486 has been marked as a duplicate of this bug. ***

Comment 4 DeShuai Ma 2018-05-28 06:28:20 UTC
Verify on v3.7.51


1. Set cpu-cfs-quota=false in /etc/origin/node/node-config.yaml then create a pod check the value of cpu.cfs_quota_us
[root@ip-172-18-15-169 ~]# oc get po -n dma1
NAME              READY     STATUS    RESTARTS   AGE
burstable-p95td   1/1       Running   0          3m
[root@ip-172-18-15-169 ~]# oc get po -n dma1 -o yaml|grep uid
      openshift.io/scc: anyuid
    uid: 20e73511-623f-11e8-96f1-0ee986d138ca
[root@ip-172-18-15-169 ~]# cat /sys/fs/cgroup/cpu/kubepods.slice/kubepods-burstable.slice/kubepods-burstable-pod20e73511_623f_11e8_96f1_0ee986d138ca.slice/cpu.cfs_quota_us 
-1

2. Set cpu-cfs-quota=true in /etc/origin/node/node-config.yaml then create a pod check the value of cpu.cfs_quota_us
[root@ip-172-18-15-169 ~]# oc get po -n dma -w
NAME              READY     STATUS              RESTARTS   AGE
burstable-t9f62   0/1       ContainerCreating   0          6s
burstable-t9f62   1/1       Running   0         9s
[root@ip-172-18-15-169 ~]# oc get po -n dma -o yaml|grep uid
      openshift.io/scc: anyuid
    uid: e5e3caa1-623c-11e8-96f1-0ee986d138ca
[root@ip-172-18-11-1 ~]# cat /sys/fs/cgroup/cpu/kubepods.slice/kubepods-burstable.slice/kubepods-burstable-pode5e3caa1_623c_11e8_96f1_0ee986d138ca.slice/cpu.cfs_quota_us 
100000

Comment 6 errata-xmlrpc 2018-06-07 08:40:56 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1798


Note You need to log in before you can comment on or make changes to this bug.