Bug 160269 - kernel panic vfs: cannot open a root device "<NULL>"
kernel panic vfs: cannot open a root device "<NULL>"
Status: CLOSED DUPLICATE of bug 159026
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-13 20:12 EDT by Jason
Modified: 2007-11-30 17:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-15 14:43:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jason 2005-06-13 20:12:26 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
I am trying to install FC4 on my Intel D865GLC motherboard.  I have an ide hard drive, zip drive, cd-rom, and dvd/cd-rw drive.  The bios is the latest bios version available.  The sha1sums match and the mediacheck (on a different motherboard) passess.

When I try to boot FC4 disc1 in a D865GLC system I get the following kernel panic:
VFS: cannot open a root device "<NULL>" or unknown-block(8,3)
Please append a correct root= boot option

I have tried the following:
linux acpi=disabled
linux acpi=ht
linux nofb
linux text nofb

Version-Release number of selected component (if applicable):
fc4 disc 1 iso

How reproducible:
Always

Steps to Reproduce:
1. boot a FC4 disc1
2. on a D865GLC
3.
  

Actual Results:  kernel panic

Expected Results:  I should be able to install

Additional info:
Comment 1 Stuart Clark 2005-06-15 00:14:59 EDT
I confirm that this occurs for me on a similar Intel mainboard D865GVHZ
http://intel.com/design/motherbd/hz/index.htm

It also occurs on an Intel mainboard D915GUX
http://intel.com/design/motherbd/ux/index.htm

I am using the boot.iso CD found in the /images directory of FC4 disc1 for use
with a network HTTP install.  I gat the same results as above.
Comment 2 Glen Eustace 2005-06-15 00:23:26 EDT
In my case it is an Intel D865GB, interestingly enough, I am running vmWare on 
FC3 at the moment and I can install FC4 to a virtual m/c on the same hardware. 
Comment 3 Marc Missire 2005-06-15 11:51:05 EDT
This also happens to me with an Intel D865PERL motherboard, when trying to boot
the Fedora Core 4 installation DVD.

Fedora Core 3 worked on the same hardware.
Comment 4 Ray 2005-06-15 12:36:46 EDT
Having the same problem on a Tyan 2880 and 2882 but only with Fedora 64. The
Fedora 32 loads and operates fine. 


VFS: Cannot open root device "<NULL>" or unknown-block(3,2)"
Comment 5 stef 2005-06-15 14:15:11 EDT
same thing for me described at bug 160385, however I reported in this report
more than one flaw I experience with 2.6.11 series kernels.

FC4 x86_64 DVD
Bi-Opteron system (SMP) on Tyan Tiger K8W motherboard

Kernel Panic - not syncing: VFS: Unable to mount root fs on unknown-block(3,2)
Comment 6 Warren Togami 2005-06-15 14:43:03 EDT
Please try the workaround in Bug 159026, most likely it solves your problem.  If
not then please open a new bug that contains detailed hardware information and
what you see on the screen when it crashes.

*** This bug has been marked as a duplicate of 159026 ***
Comment 7 stef 2005-06-15 15:19:02 EDT
Works !
This is the WEIRDEST thing I've ever seen in a Linux install !

just to make easy for other people reading this report :
1- at boot: prompt just type in some random crap
2- validate, the system will just give an error
3- at the boot: prompt again, just press enter

Still, explonation appreciate here too

Note You need to log in before you can comment on or make changes to this bug.