Bug 159026 - (i915boot) machine oopses on booting from CD
machine oopses on booting from CD
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: syslinux (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Peter Jones
Brock Organ
:
: 159920 160269 160333 160350 160385 160472 160723 160925 161237 161423 161979 leeson 162786 163464 163546 164803 164920 165175 165440 167527 167562 167565 168336 169088 171514 171808 172061 173068 173590 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-27 17:16 EDT by Bill Nottingham
Modified: 2014-03-16 22:54 EDT (History)
45 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-10 15:24:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel bootup log (5.58 KB, text/plain)
2005-05-27 17:16 EDT, Bill Nottingham
no flags Details

  None (edit)
Description Bill Nottingham 2005-05-27 17:16:19 EDT
Description of problem:

Intel i915 SDV (D3x2502)

Booting from CD oopses the kernel with the attached log.

Booting an older install, copying over the kernel + initrd from the CD to the
HD, and booting that works fine.

This is with FC4-re0527.0.
Comment 1 Bill Nottingham 2005-05-27 17:16:19 EDT
Created attachment 114931 [details]
kernel bootup log
Comment 2 Peter Jones 2005-06-09 17:10:54 EDT
*** Bug 159920 has been marked as a duplicate of this bug. ***
Comment 3 Nathan G. Grennan 2005-06-14 02:47:44 EDT
I am seeing this bug on D865GBF/PERC boards. I didn't have this problem with
Fedora Core 3, or one of the Fedora Core 4 test releases. I have reproduced this
on two different computers with the same board. I tried changing cds, ide
cables, cdrom drives, bios settings, kernel options, computers(same board), and
more. Nothing I changed helped. I did manage to get to to crash differently if I
used "linux root=/dev/hdc". Where hdc was the cdrom drive. D845 boards work just
fine with Fedora Core 4. They don't have SATA onboard.

https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160269 is another duplicate
bug that mentions a D865GLC board. The D865GLC is just a mATX form of the
D865GBF ATX board.

I have at least four computers I want to upgrade that have D865 boards in them.
If there is anything I can do to help.
Comment 4 nekdo123 2005-06-14 05:23:14 EDT
Same problem in D915PGNL board.

I also found another problem: problem with RAM more than 512MB. I had to start 
installation with linux mem=512M or it stopped right after pressing enter 
(kernel panic etc...).
Comment 5 Rahul Sundaram 2005-06-14 08:28:15 EDT
Here is a strange workaround to try

http://forums.fedoraforum.org/showthread.php?t=59051&page=2&pp=15

Type "mediacheck" into the bootprompt. It will return an error. Followup with
"linux mediacheck". See if that helps
Comment 6 Thorsten Leemhuis 2005-06-14 08:37:02 EDT
(In reply to comment #5)
> Here is a strange workaround to try
> 
> http://forums.fedoraforum.org/showthread.php?t=59051&page=2&pp=15
> 
> Type "mediacheck" into the bootprompt. It will return an error. Followup with
> "linux mediacheck". See if that helps

See Bug 159920 (dupe of this one) -- something similar worked for me also
Comment 7 Stefan Schull 2005-06-14 08:58:56 EDT
I ran into the same sort of dump the parent poster had.  Only this was on a Dell
Optiplex GX260 (845G chipset,) using the i386 CD set.  I did a cold boot
afterwards and the install proceeded.  I have not been able to reproduce the
problem since.
Comment 8 Nathan G. Grennan 2005-06-14 13:02:36 EDT
I tried the workaround and it works. I would still like to know why and see a fix.

I found what seems to be another duplicate,
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=160350
Comment 9 Bill Nottingham 2005-06-14 13:06:22 EDT
*** Bug 160350 has been marked as a duplicate of this bug. ***
Comment 10 Steve Wendt 2005-06-14 13:38:55 EDT
Bug 159920 matches what I see on an i915G and an NForce4 (AMD Opteron) system. 
I'm not sure it's quite the same as this bug?
Comment 11 nekdo123 2005-06-14 13:57:35 EDT
It worked for me too... and it also resolves my problem with 512MB RAM max.

Thank you, for now for workaround.
Comment 12 Rodolfo Alcazar 2005-06-14 16:46:01 EDT
Just generate any error and works

boot: incorrectomondo
Could not find kernel image: incorrectomondo
boot: (just an enter keypress)
Loading...

(then works)
Comment 13 Warren Togami 2005-06-15 14:41:49 EDT
*** Bug 160472 has been marked as a duplicate of this bug. ***
Comment 14 Warren Togami 2005-06-15 14:43:04 EDT
*** Bug 160269 has been marked as a duplicate of this bug. ***
Comment 15 strife 2005-06-15 14:45:09 EDT
It doesnt work for everyone. For me it got me past the ramdisk error and then 
I was presented with: 

Traceback (most recent call last):
File /usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/proress_gui.py", line 244, in renderCallback 
self.intf.icw/nextClicked)_
File "usr/lib/anaconda/gui.py", line 837, in nextClicked
self.dispatch.gotoNext()
File "usr/lib/anaconda/dispatch.py", line 174 in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
diskset.savePartitions ()
File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
disk.commit()
error: Error: Error informing the kernel about modifications to 
partition /dev/hda2 - Device or resource busy. This means Linux won't know 
about any changes you made to /dev/hda2 until you reboot - so you should't 
mount it or use it in any way before rebooting"
Comment 16 stef 2005-06-15 15:20:47 EDT
Works !
This is the WEIRDEST thing I've ever seen in a Linux install !

Still, explonation appreciate here for me too
Comment 17 Peter Jones 2005-06-15 19:48:29 EDT
The workaround above should work on most machines.  If people could also test
the boot.iso at http://people.redhat.com/pjones/i915/booti915.iso (6M download),
that would be greatly appreciated.
Comment 18 Jerry 2005-06-15 22:09:23 EDT
Tested booti915.iso on a D865GLC.  Booted fine.  I took it as far as a
successful media check on the FC4 Disk 1 and it passed.  I bailed out to get
back here and report.  I will go ahead and try a complete install.  If this is a
fix, I think this is one case where the iso files should be updated since people
not in the know can't even install with the buggy iso.
Comment 19 Stuart Clark 2005-06-15 22:29:03 EDT
I tested booti915.iso to work fine on a D915GUX board.  I did not go past a
successful stage2 load from a HTTP install method.
Comment 20 Jerry 2005-06-16 00:12:26 EDT
Tried to proceed with FC4 installation.  Seemed to proceed fine.  When all done
and I reboot I get: (after my comment #18)

mkrootdev: label / not found

So, unfortunaely I hosed my system.  Can't boot at all now.  Need help with
incantations to fix this.  Would be much appreciated, otherwise I go back and
try install of FC3 and see if I can get it back.  FC4 rescue disk panics out.
FC3 rescue disk works so I can go in and fix things, I just don't remember what.
 Its been a while.
Comment 21 Bill Nottingham 2005-06-16 12:03:06 EDT
Boots for me.
Comment 22 Jason 2005-06-16 14:00:17 EDT
I tired the type garbage press enter, type linux press enter and install trick.
 It works, but when I get to the autopartition part of the install, if I use the
numeric keyboard I get all sorts of kernel stack tracks and I have to stop the
install.  I guess it is time for another bugzilla entry.
Comment 23 Bill Nottingham 2005-06-16 16:58:33 EDT
*** Bug 160723 has been marked as a duplicate of this bug. ***
Comment 24 Dave Zhao 2005-06-16 17:41:15 EDT
The GA-8I915G-MF board I used does not even boot the i386 DVD image.  It was
reported in Bug 160723.

Comment 25 Jerry 2005-06-16 21:38:19 EDT
Peter,

Did you need more information?  The booti915.iso allowed me to get into the
install but the kernel that is installed for FC4 won't boot.  Shall I grab an
rpm of that and install it under FC3 and see if it still has the boot problem?

Jerry
Comment 26 Jerry 2005-06-17 20:37:26 EDT
More info.  I went back and did an install to an unused partition using the
"garbage" workaround and FC4 installed cleanly.  So I went back and did an
upgrade on the FC3 partition and got a successful upgrade with the "garbage"
workaround.

What I had done before was started with the booti915.iso and switched midstream
to the FC4 cds.  Thats what hosed the bootimage.

Regardless all is fine now.  With the weird "garbage" workaround.
Comment 27 Warren Togami 2005-06-18 11:36:35 EDT
More Information
================
Possible Affected Southbridge chipsets:
865, 875, 915, 925, 945, 955

I heard at least one report of 865 not being affected, but others affected.
Many 915 are affected, don't know if any are not affected.
I heard one report of 925 being affected with Nocona processors.
No reports from 945 or 955 yet.

Within the BIOS options for your ICH[567] IDE configs, does "Legacy",
"Enhanced", or "AHCI" make any difference in this panic?
Comment 28 Nathan G. Grennan 2005-06-18 14:30:40 EDT
I installed FC4 on a D915 the other day. I never saw this ram image crash. I did
have a problem with the ata_piix driver and the ICH6 until I switched from
Enhanced to Legacy. With Enhanced it would hang at the driver every time. If I
didn't do anything special it would say Disabling IRQ #10. I could disable the
error message with noirqdebug=1, but it would still hang. I also tried acpi=off,
and a few other things. One interesting note, I was using the onboard video and
when the ICH6 was set to Enhanced the framebuffer didn't draw right. When it was
set to Legacy it drew correctly.

I have had issues with Enhanced on other boards before. When I think of it, I
always switch it to Legacy to prevent problems like the one above.
Comment 29 Jerry 2005-06-18 15:32:33 EDT
I am using SATA drives.  Without Enhanced set I can not boot.  D865GLC
Comment 30 Nathan G. Grennan 2005-06-18 20:48:22 EDT
With the example above, I was using SATA drives and had to set Legacy. With
everything else, including D865GLC boards it has been with PATA drives and I set
Legacy. But I guess we have a inconsistant mess.
Comment 31 Oliver Wurdak 2005-06-20 09:43:34 EDT
I have the same problem with a Intel SE7221BK1-E board.
the garbage workaround works till the X Server should start (the graphic 
freezes)
"linux text" works
Comment 32 Scott Sloan 2005-06-20 13:09:55 EDT
I have two Intel 845 Chipsets displaying this problem. 
Comment 33 Jonathan M. Prigot 2005-06-23 12:17:00 EDT
I have an Averatec 6240EH1 laptop (Athlon 64) with this problem. The "garbage"
workaround did it for me.
Comment 34 Heishiro Mitsurugi 2005-06-24 09:29:47 EDT
The same problem happened to me. I have an Intel 865PERL Motherboard. I had to
type some garbage at the boot: prompt and then press enter twice in order to get
into the install. 

Comment 35 Dave Jones 2005-06-24 23:20:25 EDT
*** Bug 161237 has been marked as a duplicate of this bug. ***
Comment 36 foster 2005-06-27 00:57:58 EDT
(In reply to comment #15)
> It doesnt work for everyone. For me it got me past the ramdisk error and then 
> I was presented with: 
> 
> Traceback (most recent call last):
> File /usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
> self.currentWindow.renderCallback()
> File "/usr/lib/anaconda/iw/proress_gui.py", line 244, in renderCallback 
> self.intf.icw/nextClicked)_
> File "usr/lib/anaconda/gui.py", line 837, in nextClicked
> self.dispatch.gotoNext()
> File "usr/lib/anaconda/dispatch.py", line 174 in gotoNext
> self.moveStep()
> File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
> rc = apply(func, self.bindArgs(args))
> File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
> diskset.savePartitions ()
> File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
> disk.commit()
> error: Error: Error informing the kernel about modifications to 
> partition /dev/hda2 - Device or resource busy. This means Linux won't know 
> about any changes you made to /dev/hda2 until you reboot - so you should't 
> mount it or use it in any way before rebooting"
> 

I have the same problem!
Did you find a solution?
Thanks,
KF
Comment 37 Metlaev Evgeniy 2005-06-27 09:09:02 EDT
It seems that smp-kernels not affected. I've installed FC4 without problem but
when I've tried to boot that I've got a kernel panic.

On smp machine (2xPII-450 with Intel bx440) fc4 works fine.
On single cpu machine (PIII-933 with Intel bx440 + hpt370) fc4 get kernel panic.
On another kernel (2.6.10-1.760_FC3) all works fine.

Maybe chipset is not a reason. 

P.s. I've heard reports that AMD-chipsets (ViA) affected too but for now I can't
check it.
Comment 38 nekdo123 2005-06-27 14:13:55 EDT
It's not true.. i have problem with SMP too!

I installed FC$ using "garbage" fix.. i starder computer (HT enabled) as SMP... 
disabled few services(IISS, PCMCIA, BlueTooth, ISDN, iptables6), enable few 
services(vsftpd, httpd, mysql, smb).. rebooted... and now i can start only 
single CPU kernel, dual kernel oopses right after initrd... it detects hardware 
(sound, network...) and hungs up...

single kernel works...

maybe another problem??
Comment 39 Jeremy Katz 2005-06-27 16:23:40 EDT
*** Bug 161423 has been marked as a duplicate of this bug. ***
Comment 40 Warren Togami 2005-07-01 08:43:23 EDT
Please do not confuse other users by mentioning your X or SMP kernel bugs in
this report.  This report is only the very early installer crash on 845, 865,
875, 915, 925, 945, 955 Intel chipsets (Pentium4 and Nocona).
Comment 41 Jonathan M. Prigot 2005-07-01 09:40:21 EDT
But this workaround also took care of my Athlon 64 laptop boot problem (Bug 
159026). Is this bug report that focused? 
Comment 42 Jonathan M. Prigot 2005-07-01 09:41:24 EDT
But this workaround also took care of my Athlon 64 laptop boot problem (Bug  
159026). Is this bug report that focused? 
 
> (In reply to comment #40) 
> Please do not confuse other users by mentioning your X or SMP kernel bugs in 
> this report.  This report is only the very early installer crash on 845, 
865, 
> 875, 915, 925, 945, 955 Intel chipsets (Pentium4 and Nocona). 
 
 
Comment 43 Stefan Neufeind 2005-07-04 18:41:42 EDT
Could somebody please explain: What is the technical difference for the
installer between before and after entering garbage? Why is there a difference?
If the gurus seem to have found a cause, would it be possible to offer an
updated ISO for trying the fix?
Comment 44 Dave Jones 2005-07-05 16:25:09 EDT
*** Bug 160333 has been marked as a duplicate of this bug. ***
Comment 45 Davide Rossetti 2005-07-07 11:19:14 EDT
I want to add to this thread. 

Same problem as above installing FC4 x86_64, not tried i386. but tried the old
FC3 x86_64 boot.iso and it was ok.

My Mobo is SuperMicro X6DHR-8G2 with E7520 + ICH5R + Xeon EM64T 3.2GHz

I have got 2 problems, this one plus another:
- the sysinstall problem: "VFS: Cannot open root device "<NULL>" or
unknown-block(x,y)"
  workaround: "type garbage ..."
- the disk partiotioner (druid) can't sync the changes on the partition table:
"partition /dev/hdXY - Device or resource busy."
  workaround: "install twice"
Comment 46 Davide Rossetti 2005-07-07 11:23:04 EDT
(In reply to comment #45)
> I want to add to this thread. 
> 
> Same problem as above installing FC4 x86_64, not tried i386. but tried the old
> FC3 x86_64 boot.iso and it was ok.
> 
> My Mobo is SuperMicro X6DHR-8G2 with E7520 + ICH5R + Xeon EM64T 3.2GHz
> 
sorry. it's a X6DVA-EG
Comment 47 Dave Jones 2005-07-07 20:05:11 EDT
*** Bug 160925 has been marked as a duplicate of this bug. ***
Comment 48 Jeremy Katz 2005-07-08 14:18:02 EDT
*** Bug 161979 has been marked as a duplicate of this bug. ***
Comment 49 Jeremy Katz 2005-07-08 14:28:46 EDT
*** Bug 162101 has been marked as a duplicate of this bug. ***
Comment 50 Jeremy Katz 2005-07-08 14:56:09 EDT
*** Bug 162786 has been marked as a duplicate of this bug. ***
Comment 51 Warren Togami 2005-07-18 16:10:45 EDT
*** Bug 163546 has been marked as a duplicate of this bug. ***
Comment 52 joel jaeggli 2005-07-18 16:40:33 EDT
Is this problem definitivly concluded to be with syslinux?
Comment 53 Alexandre Oliva 2005-07-18 20:04:09 EDT
Same problem here on a bunch of boxes with D865 chipset: installer kernel fails
to mount the installer root filesystem.  Unaware of the installer work around, I
ended up arranging for a pre-existing grub to load the kernel and initrd, and
that worked just fine.
Comment 54 Nitin 2005-07-21 02:40:16 EDT
(In reply to comment #15)
> It doesnt work for everyone. For me it got me past the ramdisk error and 
then 
> I was presented with: 
> Traceback (most recent call last):
> File /usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
> self.currentWindow.renderCallback()
> File "/usr/lib/anaconda/iw/proress_gui.py", line 244, in renderCallback 
> self.intf.icw/nextClicked)_
> File "usr/lib/anaconda/gui.py", line 837, in nextClicked
> self.dispatch.gotoNext()
> File "usr/lib/anaconda/dispatch.py", line 174 in gotoNext
> self.moveStep()
> File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
> rc = apply(func, self.bindArgs(args))
> File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
> diskset.savePartitions ()
> File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
> disk.commit()
> error: Error: Error informing the kernel about modifications to 
> partition /dev/hda2 - Device or resource busy. This means Linux won't know 
> about any changes you made to /dev/hda2 until you reboot - so you should't 
> mount it or use it in any way before rebooting"


I had same problem when installing on 845 chipset.
It seems that this problem occurs when u have extended partitions also.
But when I created partitions from winxp(2 primary partitions - one for / and 
other for swap) and then started fc4 install it worked just fine!
Comment 55 Warren Togami 2005-08-02 03:33:49 EDT
*** Bug 164803 has been marked as a duplicate of this bug. ***
Comment 56 Jeremy Katz 2005-08-02 16:01:01 EDT
*** Bug 164920 has been marked as a duplicate of this bug. ***
Comment 57 Dave Jones 2005-08-04 00:59:44 EDT
*** Bug 160385 has been marked as a duplicate of this bug. ***
Comment 58 Gerwin Krist 2005-08-07 15:09:25 EDT
*** Bug 165175 has been marked as a duplicate of this bug. ***
Comment 59 David J. Schwartz 2005-08-10 03:37:57 EDT
This bug is in state "NEEDINFO". What info is needed?
Comment 60 Warren Togami 2005-08-10 15:24:45 EDT
http://forums.fedoraforum.org/showthread.php?t=62400
This bug has been fixed in rawhide post-FC4.  Unfortunately there is nothing we
can do about the FC4 installer.  Please follow the workaround procedure in order
to install.
Comment 61 Edgar Hoch 2005-08-10 16:22:35 EDT
You write that the bug is fixed in rawhide post-FC4.
I think it would be best for the Fedora reputation
to release updated iso images of FC4
which does not have this error.

I think the Fedora team should be so flexible to release updated iso images
when they are needed (e.g. because of a bug while the installation process).
Not doing so would wonder many people why there is only a workaround in
the release notes instead of just a updated iso image without his error.

I heard that there is no plan to release new iso images between the offical
release and test dates. I want to vote against this and propose to
- release new iso images whenever a installation process bug exists
  and a fix exists
  this iso images may contain also other updated packages
- optional release new iso images in regular intervals between offical releases
  (e.g. every two or three months) that are like the offical release iso images
  but contain installation process fixes and all updated packages for that
  release that are available at the date of building that iso image.

Thanks, and best regards
Edgar
Comment 62 Nathan G. Grennan 2005-08-10 17:52:44 EDT
I agree with Edgar. This is a simple issue to fix, and I think it should be.
Comment 63 Jacek Piskozub 2005-08-11 02:39:21 EDT
I know this is not the best place to do so, but I'll suggest a wider idea.

Fedora Why not issuing updates at a rate of over 500MB/month (last two months
were acutally closer to 1GB/month). Why not issue a "service pack" full set of
updated Fedora disks every 2-3 months? I mean not anynew release but just the
last one with updated packages (from fedora-updates) and updated installer in
case of a bug like this one. Let's say (only half-joking) "FC4 SP1".

What do you think? Should I open a new bug with this idea? What component that
would be?
Comment 64 Stefan Neufeind 2005-08-11 02:40:13 EDT
Totally agreed from my side as well. It seems that "insiders" know about the
background of this bug and that it's theoretically fixable. So I'm for releasing
a new bootup-ISO (new CD1 and DVD) as well!
Comment 65 Rob 2005-08-23 17:21:07 EDT
As a proponent of linux in a new IT teaching position trying to win a Windows
campus over to linux, this early install error problem is not helping our cause.
I was having the same problem booting with the FC4 disc1 when the Campus Network
admin happened to stop by my office and ask what I was doing!?
Comment 66 Rob 2005-08-23 17:24:29 EDT
As a proponent of linux in a new IT teaching position trying to win a Windows
campus over to linux, this early install error problem is not helping our cause.
I was having the same problem booting with the FC4 disc1 when the Campus Network
admin happened to stop by my office and ask what I was doing!?
Comment 67 Michael Madore 2005-08-26 19:36:10 EDT
Can anyone explain what the root cause of this problem is?  I burn my own custom
Fedora CDs and I would like to fix this if possible.  I tried using the
isolinux.bin from rawhide, but that didn't help.
Comment 68 Dave Jones 2005-09-05 02:23:51 EDT
*** Bug 167527 has been marked as a duplicate of this bug. ***
Comment 69 Rahul Sundaram 2005-09-05 13:05:45 EDT
*** Bug 167562 has been marked as a duplicate of this bug. ***
Comment 70 Rahul Sundaram 2005-09-05 13:31:06 EDT
*** Bug 167565 has been marked as a duplicate of this bug. ***
Comment 71 Ghassan Tchelepi 2005-09-08 01:23:37 EDT
(In reply to comment #70)
> *** Bug 167565 has been marked as a duplicate of this bug. ***
I have the same problem (i.e. FC 4 install kernel panic on  915P) The bug log
states resolved (CANTFIX) do you you know why (is there a real fix for this problem)

Thanks,
Ghassan....
Comment 72 Gerwin Krist 2005-09-10 08:00:05 EDT
*** Bug 163464 has been marked as a duplicate of this bug. ***
Comment 73 Rahul Sundaram 2005-09-14 23:01:48 EDT
*** Bug 168336 has been marked as a duplicate of this bug. ***
Comment 74 Cedric Bompart 2005-09-20 03:55:08 EDT
...same issue with an Acorp 6A815EPD1 - 2xPIII 1000Mhz - 512M
- North Bridge System Chipset : Intel 815EP support 66/100/133 FSB
- South Bridge System Chipset : Intel ICH2
Comment 75 Rahul Sundaram 2005-09-22 17:22:46 EDT
*** Bug 169088 has been marked as a duplicate of this bug. ***
Comment 76 Ghassan Tchelepi 2005-09-23 10:47:28 EDT
I was able to load FC 4 on my PC (The problem was that my PC has an ATI X700
PCI-X graphics card and the FC4 install apparently does not support it). So I
installed using text mode with the option pci=nosort. After, FC4 installed in
text mode, I installed the ATI driver and reconfigured X server). 
Comment 77 Dave Jones 2005-09-30 01:54:55 EDT
*** Bug 165440 has been marked as a duplicate of this bug. ***
Comment 78 Joel Gibson 2005-10-21 21:08:58 EDT
*** Bug 171514 has been marked as a duplicate of this bug. ***
Comment 79 Dave Jones 2005-10-27 20:10:14 EDT
*** Bug 171808 has been marked as a duplicate of this bug. ***
Comment 80 Dave Jones 2005-10-30 15:34:40 EST
*** Bug 172061 has been marked as a duplicate of this bug. ***
Comment 81 Edward Pilipczuk 2005-10-31 03:33:54 EST
Why fedora team leaves this bug as CANTFIX?
I agree with Edgar (comment #61) that ISO files FC4-mr1 (maintenance release) 
shall be released ASAP.
Not doing that may cause moving users to other linux distributions. 
Is this required by FC team?

Edward
Comment 82 Ken Smith 2005-11-01 05:53:04 EST
The i915 chipset and the others affected are common. We need an HCL for Fedora 
PDQ. How can anyone encourage use of FC when the install falls apart on common 
hardware? Come on folks - this urgently need addressed if we are serious about 
Fedora. 

Ken
Comment 83 chris 2005-11-20 16:50:15 EST
If you have python errors, like:
File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
disk.commit()
error: Error: Error informing the kernel about modifications to 
partition /dev/hda2 - Device or resource busy. This means Linux won't know 
about any changes you made to /dev/hda2 until you reboot - so you should't 
mount it or use it in any way before rebooting"

And this problem, you can do:

mediacheck
linux text

And the text version doesn't have the python errors.
Comment 84 Dave Jones 2005-11-21 11:44:32 EST
*** Bug 173590 has been marked as a duplicate of this bug. ***
Comment 85 starback 2005-11-28 04:44:27 EST
How can I use the workaround when booting with kickstart?
Comment 86 Dave Jones 2006-02-02 19:53:58 EST
*** Bug 173068 has been marked as a duplicate of this bug. ***
Comment 87 Rob 2006-07-06 19:57:14 EDT
(In reply to comment #85)
> How can I use the workaround when booting with kickstart?

I was able to get around this problem using a similar method to what is 
mentioned above. First type in "mediacheck" at the first prompt you get. 
Second start the kickstart install as you would normally, ie: 
"linux ks=http://myserver.mydomain.com/kickstart/myconfigfile.cfg".

Rob


Note You need to log in before you can comment on or make changes to this bug.