Bug 160385 - Installer hangs with Kernel Panic
Installer hangs with Kernel Panic
Status: CLOSED DUPLICATE of bug 159026
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 16:18 EDT by stef
Modified: 2015-01-04 17:20 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 00:58:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
kernel crash with 2.6.11 kernels on FC3 with acpi=off (207.79 KB, image/jpeg)
2005-06-14 16:21 EDT, stef
no flags Details
kernel panic on booting DVD of FC4 x86_64 - part1 (167.50 KB, image/jpeg)
2005-06-14 16:30 EDT, stef
no flags Details
ernel panic on booting DVD of FC4 x86_64 - part2 (178.52 KB, image/jpeg)
2005-06-14 16:30 EDT, stef
no flags Details

  None (edit)
Description stef 2005-06-14 16:18:29 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
When booting on DVD version of x86_64 of FC4, the system loads the kernel and crashes with Kernel Panic.

Computer is Dual-Opteron 242 on Tyan Tiger K8W Motherboard, 1GB DDR266 RAM
more about motherboard at http://www.tyan.com/products/html/tigerk8w.html


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.burn a DVD with ISO image of FC4
2.boot up on DVD


Actual Results:  system crashes with kernel panic

Expected Results:  should be able to install

Additional info:

This bug can be seen as a duplicate of bug 160269, but I will report here too the problems I experience since I installed the 2.6.11 kernel series on my FC3.
These are new buggy behaviours introduced since 2.6.11 kernel series poped-up :
-impossible to boot with acpi=off kernel option (system freezes at kernel booting)
-system doesn't shutdown itself anymore, you have to pull the cord or press reset to be able to turn off the computer after the shutdown sequence completes, the power doesn't turn off.
-system can freeze when disk access is done on high stress, happens when I play Doom3 game, runs completely fine until trying to save game or the system needs to load some informations and so does disk accesses (reported to IDsoftware too, asked to do a bug report to distribution providers).

I made several tests with SMP and non-SMP kernels, same results.
Comment 1 stef 2005-06-14 16:21:10 EDT
Created attachment 115424 [details]
kernel crash with 2.6.11 kernels on FC3 with acpi=off
Comment 2 stef 2005-06-14 16:30:03 EDT
Created attachment 115426 [details]
kernel panic on booting DVD of FC4 x86_64 - part1
Comment 3 stef 2005-06-14 16:30:48 EDT
Created attachment 115427 [details]
ernel panic on booting DVD of FC4 x86_64 - part2
Comment 4 stef 2005-06-15 15:20:26 EDT
Solution for Kernel Panic on boot from bug 159026

1- at boot: prompt just type in some random crap
2- validate, the system will just give an error
3- at the boot: prompt again, just press enter
Comment 5 stef 2005-06-16 14:58:11 EDT
Regarding the crash with 2.6.11 kernels and acpi, I tryed the 'solution'
proposed in bug report 155127 but it doesn't do any good.

the acpi=off and acpi=ht kernel parameters fails the same way.
Comment 6 Martin Kuetzing 2005-06-17 01:06:49 EDT
I also have seen an installer kernel panic message on hardware that runs 
FC4_TEST3 just fine.  Your comment number 4 above, solved the problem for me.
Comment 7 stef 2005-06-17 05:28:10 EDT
Additional infos for FC3  2.6.11 kernel series behaviours:

installed FC4 on a disk in the same machine.
-the acpi=off boot option no longer crash the system
-the power-off sequence now completes on its own, no need to pull the cord

I read some reports about problems with ACPI introduced in FC3 2.6.11 kernels,
it seems the patches comited to make the FC4 kernel fixed the problems.
Comment 8 stef 2005-07-04 07:58:35 EDT
I revert comment #7

I dunno why but the power off process worked once on a newly installed FC4 (and
only once).
But finally the buggy behaviour of "power not turned off" still remain, the new
kernel 2.6.12-1.1387_FC4 doesn't change a thing.
Comment 9 Dave Jones 2005-07-05 16:45:38 EDT
There's so much going on in this bug report that it's hard to make head or tail
what's going on. Every other comment is talking about a different release and a
different bug.

Please, focus this bug on the problem that the x86_64 dvd doesn't boot, and
ignore all the other problems (and file separate bugs for them if needbe).

The screen captures from the DVD boot failure are showing a failure trying to
mount /dev/hda2 as a root filesystem which the initrd from the DVD doesn't do.

Are you adding command line arguments to the boot prompt when booting the DVD ?
Comment 10 stef 2005-07-06 03:11:42 EDT
It's right, I put perhaps a bit too much in this repport but all of this was happening at same time, the 
2.6.11 "adventures" on FC3 was the thing getting on my nerves that pushed me to install FC4 and then 
encountered new troubles, and old ones still not resolved... so I did repport all in one.

For your question in Comment #9 I don't use any command line argument, only pressing the Enter key.
Comment 11 Dave Jones 2005-07-15 17:37:33 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 12 stef 2005-08-03 18:32:03 EDT
Retested with 2.6.12-1.1398_FC4

My problem however isn't about being unable to boot, but being unable to have a
computer that shuts down on itself.

Anyway, I tryed as you suggested to recreate the hardware description files but
no changes, the power still remains on the board at the end of the shutdown process.

And for info I started on a clean FC4 install, not an upgrade.

On the other hand I read the 2.6.13-rc4 kernel Changelog and saw a HUGE number
of fixes about reboot/shutdown processes and ACPI... could this be related ?
Comment 13 Dave Jones 2005-08-04 00:58:53 EDT
Ok, I'm going to close this, as the initial bug report was a dupe of the
i915boot bug. There is at least one other bug open about the reboot/shutdown
problem, and there's a number of changes going on upstream as you've noticed. 
I'll look into getting some of those in an update soon.

thanks.


*** This bug has been marked as a duplicate of 159026 ***
Comment 14 stef 2005-09-05 15:33:28 EDT
found a solution at report bug 160269 to install and avoid the crash (strange
behaviour though).

for more info, I compiled and installed a 2.6.13 vanilla kernel, and since
everything is going just fine !

-power off working
-no more crash with high-stress program like Doom3

Note You need to log in before you can comment on or make changes to this bug.