Bug 16038 - RFE:ftp install shouldnt crash when it cant find package(s)
RFE:ftp install shouldnt crash when it cant find package(s)
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michael Fulbright
: FutureFeature
: 12805 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-11 18:19 EDT by Steve Dum
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-09-17 14:18:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Dum 2000-08-11 18:19:42 EDT
Summary says it all.  I assume this might be a dup of
15302, but bugzilla won't let me see that bug.

Doing a ftp install, it cherns away installing about 400
packages and when it has 86 to go it crashes.  So I cut
the CD's do do a 'normal' cd install and it appears that
this is the place where the ftp install should have asked
for cd2 to be installed.  Looks like it forgot to ask and
then tried to open a undefined variable.

BTW, When trying to do a nfs install, I could never get
the machine to mount the remote directory.  I could access
it from other machines just fine.  Since the installer doesn't 
provide much info here, I can't imagine what I can supply to 
help you trace this problem down.
Comment 1 Preston Brown 2000-08-14 11:55:16 EDT
ftp installs can only install with all packages in a single directory.
Comment 2 Steve Dum 2000-08-18 14:12:49 EDT
I think you missed part of the point - while yes I think you should make ftp
installs support the second disk, the issue here is that anaconda CRASHED.  That
simply put, should NEVER happen.
If it crashes its broken and needs fixed.  You can take the cop-out solution, of
simply printing out a message that 'foo isn't supported', but it is a bug.
Comment 3 Michael Fulbright 2000-08-21 12:45:02 EDT
Marked as a request for enchancement, added to future feature list.
Comment 4 Michael Fulbright 2000-09-14 15:36:45 EDT
I don't think there is anything that can be done if you cannot get the required
packages from the ftp server.
Perhaps we could prompt to 'Retry' to get the file.  We could certainly try to
pop up a nice dialog box
before bailing out.
Comment 5 Michael Fulbright 2000-09-14 15:45:35 EDT
Related to bug number 15982.
Comment 6 Steve Dum 2000-09-14 22:46:31 EDT
The reason I think this should be handled, is that the
way I make the ftp images available is by downloading the
iso images and then mounting them in loop back mode.  I thought
this was a common approach.  With the data split across 2 cd's
in 6.9 It is very hard to meet the requirement that all the rpm's 
exist in the same directory.
Comment 7 Michael Fulbright 2000-09-15 12:00:44 EDT
*** Bug 12805 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2000-09-26 12:09:57 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 9 Michael Fulbright 2000-09-26 12:55:39 EDT
Moving to RESOVLED - DEFERRED from CLOSED - DEFERRED
Comment 10 Michael Fulbright 2000-09-26 16:51:47 EDT
Related to bug 15982.
Comment 11 Michael Fulbright 2001-09-17 14:18:14 EDT
It is now possible to loopback mount the isos as disc1/ and disc2/ and have an
ftp install work.

Note You need to log in before you can comment on or make changes to this bug.