Bug 15982 - no install recovery if CD2 bad/missing
no install recovery if CD2 bad/missing
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Michael Fulbright
: FutureFeature
: 15698 18379 19552 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-11 09:38 EDT by whampton
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-11-02 16:24:52 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description whampton 2000-08-11 09:38:52 EDT
Due to a new 8X CD and some bad media, I had a good CD1 but unreadable CD2
(it verified fine on the CD-R but was not readable on a CD-ROM nor
DVD-ROM).  When attempting to do an upgrade on my system (RH 6.1 with
updated kernel), the install prompted for CD2.  However since my CD2 was
unreadable, I was stuck with a partially installed system.  The only option
on the screen was OK (I think).  Basically, I had to hit reset and hope
that the previously installed kernel came up -- it did and I was able to
use a command line cdrecord to blow a fuctional CD2.

A dual CD install is great, however the install should not hang/fail if the
second CD
is missing/unreadable.  The install should allow you to complete a mostly
functional
install so your system does not get totally FUBAR'd.  From there, you could
then recover
your system (like I was able to do, since I was doing an upgrade).

Overall, I love pinstripe!
Comment 1 Preston Brown 2000-08-14 11:43:14 EDT
this is going to be very difficult to fix.
Comment 2 whampton 2000-08-14 12:05:25 EDT
I agree on the difficulty, however this problem has happened and will happen
again, e.g., most likely from someone who doesn't read the FAQ and only gets a
copy of CD1 or downloads CD1 ISO only (plus the occasional bad/scratched CD2). 
Maybe fix in 7.1?  DVD anyone?  For 7.0, could RH handle this with a warning in
the README's (e.g., where you download the ISO)?   For 7.0, could RH at least
make sure that the system is in a usable state (e.g., basic install, drivers,
kernel, initscripts, lilo)?  Possibly when CD2 is unreadable, have skip with a
dialog indicating missing files/not complete -- and then run lilo?
Comment 3 TJ McNeely 2000-09-01 01:34:17 EDT
I sorta agree too... I tried to install it and did not know that CD2 was now
part of the distro instead of like power tools or something (upon closer
inspection there are SEVERAL ISO's in that folder). So I had my system partially
installed.. but I formatted / on linux (I hate upgrades), so I couldnt
recover... I actually had to find my old (IDE) hard drive with winblows
installed on it (surprised it actually still booted) to download CD 2 and burn
it so I could RE-do the install :)

I agree that is going to make the install script get really hairy there.. but
there has to be some sort of way to "skip" the rest of the packages and go on to
lilo install. (or whatever is next ) 

TJ McNeely
KnopHead
Comment 4 Michael Fulbright 2000-09-14 15:44:46 EDT
Related to bug number 16038.
Comment 5 Michael Fulbright 2000-09-14 15:55:41 EDT
*** Bug 15698 has been marked as a duplicate of this bug. ***
Comment 6 Michael Fulbright 2000-09-26 16:50:32 EDT
Related to bug 16038.
Comment 7 Michael Fulbright 2000-10-05 12:27:48 EDT
*** Bug 18379 has been marked as a duplicate of this bug. ***
Comment 8 Michael Fulbright 2000-10-30 14:26:24 EST
*** Bug 19552 has been marked as a duplicate of this bug. ***
Comment 9 Michael Fulbright 2000-11-02 16:24:49 EST
This is not currently possible given how the RPM transactions are handled.

Note You need to log in before you can comment on or make changes to this bug.