Bug 160391 - Computer reboots after "Loading initrd.img...."
Computer reboots after "Loading initrd.img...."
Status: CLOSED INSUFFICIENT_DATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity high
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
: 160447 161860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 16:47 EDT by Rob King
Modified: 2015-01-04 17:20 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-04 09:52:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rob King 2005-06-14 16:47:25 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
When booting from FC4-Disc1, the boot makes it as far as "Loading initrd.img...." and then the computer immediately reboots.

The installation CDs were checksummed correctly after downloading, and this occurs on multiple copies of the CD burned on different burners and media.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot with Disc 1.
2. Enter installation options.
3. Hit enter.
  

Actual Results:  Computer reboots.

Expected Results:  Installation should have continued.

Additional info:

The computer is a AMD64 Mobile 3200+ with 512MB of RAM, 40GB HD, ATI Radeon 9700.
Comment 1 Rob King 2005-06-14 16:53:10 EDT
Chip level specifications:

Host bridge: Silicon Integrated Systems [SiS] 755 Host (rev 01)
PCI bridge: Silicon Integrated Systems [SiS] SG86C202
ISA bridge: Silicon Integrated Systems [SiS] SiS963 [MuTIOL Media IO] (rev 25)
IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
Multimedia audio controller: Silicon Integrated Systems [SiS] Sound Controller
(rev a0)
USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
Ethernet controller: Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet
(rev 91)
FireWire (IEEE 1394): Texas Instruments TSB43AB22/A IEEE-1394a-2000 Controller
(PHY/Link)
CardBus bridge: O2 Micro, Inc. OZ711M1 SmartCardBus MultiMediaBay Controller
(rev 20)
System peripheral: O2 Micro, Inc. OZ711Mx MultiMediaBay Accelerator
Host bridge: Advanced Micro Devices [AMD] K8 NorthBridge
VGA compatible controller: Mobility Radeon 9700 - 128MB Graphics Memory
Comment 2 Tim Stauffer 2005-06-16 00:49:00 EDT
Same problem as above, but with much older hardware.  Seems to happen
immediately upon entering installation options.  Verified integrity of ISO
download, and was able to run media check on another PC to verify the CD had
burned correctly.  Tried swapping out the memory and CDROM drives, but to no
avail.  FC3 installed with no problem.

Basic system stats:
CPU:  AMD K6-2+
MB:  Tyan S1598
RAM:  512MB
Video:  Diamondmm Viper II
Audio:  SBlive
Comment 3 Chris Lumens 2005-06-16 11:52:08 EDT
*** Bug 160447 has been marked as a duplicate of this bug. ***
Comment 4 Rob King 2005-06-16 12:56:39 EDT
I can get the computer to boot from the CD if I pass acpi=off to the kernel.
Just to make things interesting, however - once FC4 is installed, not only is
the acpi=off line NOT required, the system will actually fail to boot (it will
lock up) if acpi=off is specified (to the installed boot kernel).
Comment 5 Marcello Foschi 2005-06-17 13:52:03 EDT
Same problem with a mobile AMD 3000+ and a SIS chipset (Fujitsu Siemens Amilo
notebook) but no parameter is working. Tried acpi=off and anithing else I could
imagine, but still no result.
Comment 6 Marcello Foschi 2005-06-18 02:56:06 EDT
(In reply to comment #5)
> Same problem with a mobile AMD 3000+ and a SIS chipset (Fujitsu Siemens Amilo
> notebook) but no parameter is working. Tried acpi=off and anithing else I could
> imagine, but still no result.

My fault.. please ignore my comment. I got a Sempron on my notebook, and thought
it was a 64 bit processor. I will try to install the i386 version of FC4 when I
will finish downloading it.
Comment 7 Rob King 2005-06-20 21:13:24 EDT
The above entry must have been a fluke. The acpi=off only worked that one time.
On subsequent installs, it fails.
Comment 8 Tim Stauffer 2005-06-22 16:13:33 EDT
I tried acpi=off; no luck.  I also decided to download and try the FC4 test 3
cd.  Also no luck.  I reintalled FC3 and used YUM to update to FC4.  Once
installed, FC4 boots with no problems, so it appears to be specifically an
anaconda problem.
Comment 9 renke 2005-07-07 13:58:01 EDT
i got the same problem with a fujitsu-siemens laptop (amilo a7645, also with
amd-turion and sis-chipset)
Comment 10 Rahul Sundaram 2005-07-07 17:32:29 EDT
*** Bug 161860 has been marked as a duplicate of this bug. ***
Comment 11 renke 2005-07-11 12:06:27 EDT
seems to be a duplicate of #159026, the problem described in this bug is the
same as in #162786, marked as a duplicate.

i will test the workaround and post my experiences
Comment 12 renke 2005-07-12 02:45:34 EDT
the solution of #159026 works for me (amd-turion with sis M760 & 963L Chipset)

this bug is imho a duplicate
Comment 13 Dave Jones 2005-07-15 17:15:11 EDT
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.
Comment 14 Rob King 2005-07-15 17:31:18 EDT
This unfortunately does not apply, as this bug occurs from the installation CD.
I've never been able to install FC4, much less upgrade it.
Comment 15 daniel renfro 2005-07-27 00:55:58 EDT
fedora core4 ran fine for a ~week, then after weekly reboot i ran into this
problem. used the i386 install cds on this machine: 

processor:  Pentium IV - 1.4Ghz
chipset:    i850
memory:     128 RDRAM
harddrive:  20GB, 80GB 
video:      Nvidia Riva TNT2 m64
audio:      Creative Soundblaster PCI128
Comment 16 Dave Jones 2005-09-15 02:27:20 EDT
an intermittent problem like this smells like hardware problems. Have you tried
running memtest86 overnight on this box ?
Comment 17 Rob King 2005-09-15 09:14:49 EDT
I've run memtest86 overnight on the box, and have also run NetBSD/amd64,
FreeBSD/amd64, and Solaris/x64 on the box for weeks without problem, even under
heavy load. I've also run RHEL 4 and FC3 on the box without issue for weeks. It
is specifically only FC4 that has this problem.
Comment 18 Naresh Sukhija 2005-09-18 11:25:58 EDT
I have the same experience with fedora core 4 installation CD on AMD64 i.e. AMD
ATHLON 64 2800+ on Asus K8S-MX motherboard (SiS chipset) with 256MB of memory.
Any other version of Fedora Core works OK.A work-around found on some site
states that when the CD boots, instead of pressing enter or giving any
installation options,    type any garbage word and press enter. Then the
installation CD gives an error about it and again comes to boot prompt, but now
magically put your actual desired string for example "linux" or "linux text"
whatever, the installation goes smoothly.
Comment 19 Dave Jones 2005-09-30 02:24:07 EDT
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.
Comment 20 rh 2005-09-30 05:27:14 EDT
Would it be possible to boot your box with this kernel to start installing FC4?
Comment 21 Dave Jones 2005-09-30 05:56:17 EDT
sadly not. though this bug does sound like the i915boot bug.
Have you tried entering something random on the boot command line ?
Comment 22 Dave Jones 2005-11-10 14:24:23 EST
2.6.14-1.1637_FC4 has been released as an update for FC4.
Please retest with this update, as a large amount of code has been changed in
this release, which may have fixed your problem.

Thank you.
Comment 23 Mitya Mikhailov 2005-11-11 05:16:41 EST
Whats about crash during install process of FC4 from cd/dvd? This bug is marked
as duplicated... Would you change installer now or i am to wait next release?
Comment 24 Dave Jones 2005-11-12 01:36:26 EST
http://fedora.isphuset.no has FC4 iso's with updated packages, which *may* fix
problems with installation seen with earlier kernels.
Comment 25 Dave Jones 2006-02-03 01:42:24 EST
This is a mass-update to all currently open kernel bugs.

A new kernel update has been released (Version: 2.6.15-1.1830_FC4)
based upon a new upstream kernel release.

Please retest against this new kernel, as a large number of patches
go into each upstream release, possibly including changes that
may address this problem.

This bug has been placed in NEEDINFO_REPORTER state.
Due to the large volume of inactive bugs in bugzilla, if this bug is
still in this state in two weeks time, it will be closed.

Should this bug still be relevant after this period, the reporter
can reopen the bug at any time. Any other users on the Cc: list
of this bug can request that the bug be reopened by adding a
comment to the bug.

If this bug is a problem preventing you from installing the
release this version is filed against, please see bug 169613.

Thank you.
Comment 26 John Thacker 2006-05-04 09:52:06 EDT
Closing per previous comment.

Note You need to log in before you can comment on or make changes to this bug.