Bug 160499 - Can't start installation after selecting packages - /dev/hda2 - Device or resource busy
Can't start installation after selecting packages - /dev/hda2 - Device or res...
Status: CLOSED DUPLICATE of bug 160387
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-15 10:14 EDT by jon
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-15 10:19:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description jon 2005-06-15 10:14:27 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2 StumbleUpon/1.9995

Description of problem:
I'm experiencing bug #159026.  Used the "linux mediacheck" workaround, also passed the "nofb" parameter, due to a problem getting the SiS video card to display properly.

After selecting packages, and pressing continue, I get:

"Error informing the kernel about modifications to partition /dev/hda2 - Device or resource busy. This means Linux won't know about any changes you made to /dev/hda2 until you reboot - so you should't mount it or use it in any way before rebooting"

With the options to "Ignore" or "Cancel".  When choosing "Ignore" I receive the following message:

"An unhandled exception has occured. This is most likely a bug. Please copy the full text of this exception and file a detailed bug report against anaconda at http://bugzilla.redhat.com/bugzilla/.

Traceback (most recent call last):
File /usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/proress_gui.py", line 244, in renderCallback self.intf.icw/nextClicked)_
File "usr/lib/anaconda/gui.py", line 837, in nextClicked
self.dispatch.gotoNext()
File "usr/lib/anaconda/dispatch.py", line 174 in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
diskset.savePartitions ()
File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
disk.commit()
error: Error: Error informing the kernel about modifications to partition /dev/hda2 - Device or resource busy. This means Linux won't know about any changes you made to /dev/hda2 until you reboot - so you should't mount it or use it in any way before rebooting"

And yes, it took me forever to type that all out :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot to FC4 CD
2. start anaconda with "linux mediacheck nofb"
3. Go through installation, choosing localization, packages, partitioning, etc.
4. Click continue to actually begin installation
5. Click "Ignore" on message box.
  

Actual Results:  I received the error message indicated above.

Expected Results:  Not sure, I was hoping the installation would proceed as it always had.  

Additional info:

I don't know if this matters at all, but the same procedure (minus the mediacheck option) got FC4 test 3 installed and working.  I don't know if thats of any help to you, just thought I'd mention it.
Comment 1 Chris Lumens 2005-06-15 10:19:13 EDT

*** This bug has been marked as a duplicate of 160387 ***

Note You need to log in before you can comment on or make changes to this bug.