Bug 160387 - Can't start installation after selecting packages - /dev/hda2 - Device or resource busy
Can't start installation after selecting packages - /dev/hda2 - Device or res...
Status: CLOSED DUPLICATE of bug 160693
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
i386 Linux
high Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Mike McLean
:
: 160499 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-06-14 16:28 EDT by jon
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 11:17:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gateway BIOS update changelog (10.29 KB, text/plain)
2005-06-16 18:43 EDT, Jack Tanner
no flags Details
anaconda dump txt file. (796.67 KB, text/plain)
2005-06-29 20:51 EDT, Andrew Jones
no flags Details

  None (edit)
Description jon 2005-06-14 16:28:06 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050317 Firefox/1.0.2 StumbleUpon/1.9995

Description of problem:
I'm experiencing bug #159026.  Used the "linux mediacheck" workaround, also passed the "nofb" parameter, due to a problem getting the SiS video card to display properly.

After selecting packages, and pressing continue, I get:

"Error informing the kernel about modifications to partition /dev/hda2 - Device or resource busy. This means Linux won't know about any changes you made to /dev/hda2 until you reboot - so you should't mount it or use it in any way before rebooting"

With the options to "Ignore" or "Cancel".  When choosing "Ignore" I receive the following message:

"An unhandled exception has occured. This is most likely a bug. Please copy the full text of this exception and file a detailed bug report against anaconda at http://bugzilla.redhat.com/bugzilla/.

Traceback (most recent call last):
File /usr/lib/anaconda/gui.py", line 1137, in handleRenderCallback
self.currentWindow.renderCallback()
File "/usr/lib/anaconda/iw/proress_gui.py", line 244, in renderCallback self.intf.icw/nextClicked)_
File "usr/lib/anaconda/gui.py", line 837, in nextClicked
self.dispatch.gotoNext()
File "usr/lib/anaconda/dispatch.py", line 174 in gotoNext
self.moveStep()
File "/usr/lib/anaconda/dispatch.py", line 242, in moveStep
rc = apply(func, self.bindArgs(args))
File "/usr/lib/anaconda/packages.py", line 579, in turnOnFilesystems
diskset.savePartitions ()
File "/usr/lib/anaconda/partedUtils.py", line 726, in savePartitions
disk.commit()
error: Error: Error informing the kernel about modifications to partition /dev/hda2 - Device or resource busy. This means Linux won't know about any changes you made to /dev/hda2 until you reboot - so you should't mount it or use it in any way before rebooting"

And yes, it took me forever to type that all out :)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot to FC4 CD
2. start anaconda with "linux mediacheck nofb"
3. Go through installation, choosing localization, packages, partitioning, etc.
4. Click continue to actually begin installation
5. Click "Ignore" on message box.
  

Actual Results:  I received the error message indicated above.

Expected Results:  Not sure, I was hoping the installation would proceed as it always had.  

Additional info:

I don't know if this matters at all, but the same procedure (minus the mediacheck option) got FC4 test 3 installed and working.  I don't know if thats of any help to you, just thought I'd mention it.
Comment 1 G. Krist 2005-06-15 06:35:49 EDT
You can add me to the list, already had it on 2 machines. New hdd seems to
"fixed" it
Comment 2 Randy Ramsdell 2005-06-15 07:05:59 EDT
Same isssue here.

ASUS p4p-800 deluxe MB
2 SATA drives

Early oon in install I get a warning about not being able to mount "/dev/sda2"
I think "/dev/sda2" is swap

Comment 3 Chris Lumens 2005-06-15 10:19:22 EDT
*** Bug 160499 has been marked as a duplicate of this bug. ***
Comment 4 Tom Wood 2005-06-15 15:01:30 EDT
Getting same issue, with the only difference as being /dev/hda3.  System had FC3
and then FC4 test 1/2/3 on it before full reinstall that generated the above
error.  Drive is a 120GB Western Digital IDE drive.  Motherboard is a dual
processor PIII (Abit VP6).
Comment 5 Andreas Ott 2005-06-16 15:32:09 EDT
Here is a workaround that worked for me:
After the first failure (similar to the above, but with swap partition on
/dev/sda2), I rebooted and installed again. The partition table was correct
as I entered it via dis druid in the first run but it noted that sda2 is of type 
swap but not formatted as a swap partition. I got prompted to do that [OK]. After 
that I had to set the 'mkfs' options and mount points on all filesystem partitions
manually and was prompted to confirm if I'm sure that all of them get formatted. 
After all that the install just started fine (well, it was painful to go through 
all the options and selections again).
Comment 6 jon 2005-06-16 15:49:12 EDT
I ended up booting to a gentoo (sorry redhat) cd that I happened to have lying
around, fdisk'd hda, remove partitions 1-4, wrote back the table, rebooted, and
installed fine.

I think the only people experencing this bug, are people who had FC4T3
installed.  Basically if you just wax the old partitions w/ test 3 on it,
everything works fine.  Don't ask me why, but that seems to be everyone's
solution, just different ways of getting there.

I'd love to hear an explanation, because I'm completely clueless.
Comment 7 Jack Tanner 2005-06-16 17:49:13 EDT
Same here. I am attempting a clean install, partitioned as follows:

/dev/hda has one existing partition, which contains data that should not be
touched by this install.

/dev/hdb and /dev/hdd contain one software RAID-1 device (/dev/md0) that, in
turn, contains 3 LVM VolGroups (swap, /, and /home), and a bit of reserved free
space. In addition, /dev/hdd has /boot, and GRUB is set to be installed not in
the MBR, but in /dev/hdd1.

I've selected about 3GB+ packages from all 4 CDs.

P.S. Additional similar reports:
http://thread.gmane.org/gmane.linux.redhat.fedora.general/132504
Comment 8 Jack Tanner 2005-06-16 18:43:53 EDT
Created attachment 115582 [details]
Gateway BIOS update changelog
Comment 9 Jack Tanner 2005-06-16 18:46:57 EDT
Workaround! I've updated the BIOS in my PC and turned off legacy USB support on
a whim, and the installation is going fine.

I've attached the readme containing the changelog for the BIOS update (it's
available from
ftp://ftp.gateway.com/pub/hardware_support/bios/pentium/rg84510a/9524633.exe as
a self-extracting WinZip archive, but that's not, er, appropriate for this forum).
Comment 10 Andreas Ott 2005-06-16 20:26:57 EDT
a few additional comments for the troubleshooters:

* my box is a 1U Dell PowerEdge 1550, 2x1GHz P-III, 1GB RAM, SCSI RAID-1

* I have not changed anything in BIOS or elsewhere, the install went fine
  on 2nd attempt and IMHO it has to do with the swap partition to be
  either not recognized or not being formatted as swap in the anaconda 
  installer

* the box had a RH-7.2 based custom install on it before (dated from the
  stone age^W^W year 2002) and was not used for any of the FC4T* installs
Comment 11 Randy Ramsdell 2005-06-17 01:09:36 EDT
Easy Workaround: Didn't quite follow comment #5

Just boot "linux rescue" and then fdisk the drives. Delete all of the
partitions. This allows full install without problems. 

However, it would be nice to know what is broken.

rcr
Comment 12 Scott Johnson 2005-06-18 12:05:48 EDT
(In reply to comment #6)
> I ended up booting to a gentoo (sorry redhat) cd that I happened to have lying
> around, fdisk'd hda, remove partitions 1-4, wrote back the table, rebooted, and
> installed fine.
> 
> I think the only people experencing this bug, are people who had FC4T3
> installed.  Basically if you just wax the old partitions w/ test 3 on it,
> everything works fine.  Don't ask me why, but that seems to be everyone's
> solution, just different ways of getting there.
> 
> I'd love to hear an explanation, because I'm completely clueless.



Same problem with FC4 install from a DVD and used basically same work around.  I
had Novell Linux and Ubuntu Linux installed on two drives.  Install would crap
out every time when I tried to automatically configure the partitioning (I
wanted to see what I ended up with for defaults).  Wasn't until I manually wiped
the partition table that it would continue without error after package
selection.  I'm using Maxtor drives.  Hope this helps.
Comment 13 pinter 2005-06-20 17:39:00 EDT
In my case, I was doing a bare-metal install on a Dell C600 laptop with virgin
15GB Hitachi drive. No ubuntu or FC3 or anything previously installed.

Local workaround involved doing a 'linux text' mode install until packages
started copying down, then reboot into a GUI install, re-selecting packages,
etc. So far, so good, except...

It still hangs at the same spot (formating?), but this time if I gingerly click
'Back' and 'Continue' a few times until the message box confirming I have CD's
FC1, FC2, etc. available appears to give whatever is hosed enuf time to get on
its feet.

Baffling.
Comment 14 Michael Young 2005-06-24 07:25:46 EDT
This error seems to occur when there are existing partitions that the install
process changes. I have just seen this with a kickstart install, which took 3
attempts to install. It worked 3rd time without changing any configuration, and
I think during the first two attempts first one, then the other of the two disks
in the machine was given the correct partition (both had existing partitions
from an XP install to overwrite).
Comment 15 Andrew Jones 2005-06-29 20:51:49 EDT
Created attachment 116159 [details]
anaconda dump txt file.
Comment 16 Andrew Jones 2005-06-29 20:53:44 EDT
I've spotted this on an old dual pentium3 SGI 1200. Have attached the
debug state text file, hope it is useful...
Comment 17 Thomas Fante 2005-07-15 01:05:48 EDT
I had this same error on a panasonic toughbook CF-W2 laptop. I was installing 
the newest stable release of fedora 4 as of July, 14, 2004. At first it had 
trouble reading the DVD. I then made another DVD, even downloading another 
image file, and it refused to read it as well. After that, I decided to 
install via FTP. I got to just after selecting all of my packages, where it 
would normally create the partitions. Instead of creating the partitions it 
errired out with the exact same error that was seen above. I also noticed that 
the installer did not delete all partitions as it said it would. I was able to 
reboot and the windows XP that I thought I had removed came up running 
perfectly on my system! After trying all sorts of reinstalls, different 
configurations, and bios settings changes, I completely zeroed out my drive. 
After doing this the FTP install worked flawlessly. I am assuming that zeroing 
out the drive would have fixed the error I had when loading from the DVD as 
well. Now my panasonic toughbook is running well using Fedora 4.
Comment 18 Jeremy Katz 2005-07-29 11:17:10 EDT

*** This bug has been marked as a duplicate of 160693 ***
Comment 19 Matt S 2006-01-14 13:19:54 EST
(In reply to comment #13)
> In my case, I was doing a bare-metal install on a Dell C600 laptop with virgin
> 15GB Hitachi drive. No ubuntu or FC3 or anything previously installed.
> Local workaround involved doing a 'linux text' mode install until packages
> started copying down, then reboot into a GUI install, re-selecting packages,
> etc. So far, so good, except...
> It still hangs at the same spot (formating?), but this time if I gingerly 
click
> 'Back' and 'Continue' a few times until the message box confirming I have CD's
> FC1, FC2, etc. available appears to give whatever is hosed enuf time to get on
> its feet.
> Baffling.

I was having the same problem on my c600 dell, though it wasn't a clean hd, but 
after fdisk it should have worked..   I took your advice and did linux test so 
far so good, its at 38%.  I didn't try to reboot into the gui iface since this 
appears to be working
Comment 20 Terry Barnaby 2006-01-19 06:35:15 EST
I have the same problem "Error informing the kernel about modifications to
partition ...". I don't want to clear the partitions to zero as they contain
important data and this appears from reading reports on this error the only sure
way of installing FC4.
I assume there is a bug in Anaconda causing this.
Is there a workaround using an updated anaconda perhaps applied using updates.img ?

Note You need to log in before you can comment on or make changes to this bug.